Bug 220546 - [patch] zfs.ko: undefined reference to abd_is_linear(), abd_copy_to_buf() and (probably) others with ASSERT's enabled
Summary: [patch] zfs.ko: undefined reference to abd_is_linear(), abd_copy_to_buf() and...
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-fs (Nobody)
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-07-07 19:49 UTC by Andriy Voskoboinyk
Modified: 2017-08-20 12:35 UTC (History)
1 user (show)

See Also:


Attachments
Add 'static' keyword to inline functions in abd.h (1.18 KB, patch)
2017-07-08 11:14 UTC, Andriy Voskoboinyk
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andriy Voskoboinyk freebsd_committer 2017-07-07 19:49:16 UTC
These functions are used inside assertions; an example:

ASSERT(abd_is_linear(abd));

They declared in headers as 'inline'd; probably, they should be staticized as well.
Comment 1 Andriy Voskoboinyk freebsd_committer 2017-07-08 11:14:23 UTC
Created attachment 184171 [details]
Add 'static' keyword to inline functions in abd.h

I think this was (also) caused by 'CFLAGS=-O0'; anyway, the patch fixes this issue for me.
Comment 2 Andriy Voskoboinyk freebsd_committer 2017-08-20 12:35:25 UTC
Committed in r322601.