Bug 220568 - Cannot access https://forums.freebsd.org from some NordVPN servers
Summary: Cannot access https://forums.freebsd.org from some NordVPN servers
Status: Closed Works As Intended
Alias: None
Product: Services
Classification: Unclassified
Component: Forums (show other bugs)
Version: unspecified
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-08 17:23 UTC by ben.lavery@hashbang0.com
Modified: 2019-09-11 06:02 UTC (History)
4 users (show)

See Also:


Attachments
CSV of VPN servers that cannot access https://forums.freebsd.org (2.95 KB, text/plain)
2017-07-08 17:23 UTC, ben.lavery@hashbang0.com
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description ben.lavery@hashbang0.com 2017-07-08 17:23:24 UTC
Created attachment 184190 [details]
CSV of VPN servers that cannot access https://forums.freebsd.org

I use NordVPN (https://nordvpn.com) most of the time when I'm accessing the Internet.  I've noticed that sometimes https://forums.freebsd.org was unavailable.  I've tracked this down to a number of the VPN servers I use to connect to the FreeBSD forums.

I've tested all of the UK NordVPN servers and have made a list of those that cannot access the FreeBSD forums, there are 29.  The list is attached in CSV format (with headers), the format is:
vpn server name,vpn server IP, curl message

These IPs are valid, but I suspect that the FreeBSD forums are blocking them.  Please can they be unblocked as a number of them get auto-selected by my VPN client (the official NordVPN client).

@FreeBSDHelp advised I open a ticket (https://twitter.com/FreeBSDHelp/status/877116717951893504), apologies it has taken so long!

If I can find time, I shall also try the other NordVPN servers.  However there are >2000 so I need to find a better way to automate the process than what I used for this.
Comment 1 freebsd 2017-07-10 14:09:24 UTC
While I appreciate how inconvenient it must be, you have to realize that *all* anonymizing services, including public VPN networks, are used by script kiddies and their ilk, and that popular (well-indexed by Google) forums are among their prime targets.

The FreeBSD Forums employ blacklisting to keep them out, deriving their entries by importing listings from several sources (a broad array of unrelated firewalls, plus specific services for forums abuse, like StopForumSpam).

Every IP address that is imported will be blacklisted for thirty days, and will expire automatically thereafter.

I will not go down the entire list you provided, because I think you'll get the picture after reading the details for the first five entries:

212.84.181.72 - not currently blacklisted, but has a history:
http://stopforumspam.com/ipcheck/212.84.181.72

5.152.210.246 - imported blacklisting, expires 20170719
http://stopforumspam.com/ipcheck/5.152.210.246

5.152.210.253 - imported blacklisting, expires 20170711
http://stopforumspam.com/ipcheck/5.152.210.253

130.185.151.227 - imported blacklisting, expires 20170717
http://stopforumspam.com/ipcheck/130.185.151.227

88.150.206.163 - not currently blacklisted, but has a history:
http://stopforumspam.com/ipcheck/88.150.206.163

All of these have been listed and delisted more than once, so all are likely to be repeat offenders.

All I can do is give you this resource to look up what the problem with a specific IP address can be (though we do use other sources, most of the forum-specific hits will be found on StopForumSpam). 

Add a month to the latest entry, and you'll know whether it is (still) blacklisted.

I have no better news. 

This works extremely well for the safety and cleanliness of the FreeBSD Forums, and we plan to keep using it.

Ben a.k.a. DutchDaemon,
FreeBSD Forums Administrator.
Comment 2 freebsd 2017-07-10 14:34:45 UTC
By the way, you can also search at /24 level, so searching for e.g. "5.152.210" at StopForumSpam will give you all of the listings in that network. Repeat for "130.185.151", etc.
Comment 3 worldwa 2019-09-11 05:29:53 UTC
MARKED AS SPAM
Comment 4 worldwa 2019-09-11 05:30:13 UTC
MARKED AS SPAM
Comment 5 palak agrawal 2019-09-11 06:01:28 UTC
MARKED AS SPAM
Comment 6 palak agrawal 2019-09-11 06:01:54 UTC
MARKED AS SPAM
Comment 7 palak agrawal 2019-09-11 06:02:11 UTC
MARKED AS SPAM
Comment 8 palak agrawal 2019-09-11 06:02:25 UTC
MARKED AS SPAM
Comment 9 palak agrawal 2019-09-11 06:02:36 UTC
MARKED AS SPAM
Comment 10 palak agrawal 2019-09-11 06:02:44 UTC
MARKED AS SPAM