Bug 220608 - graphics/poppler: Update to >= 0.56.0, Multiple security (CVE) vulnerabilities
Summary: graphics/poppler: Update to >= 0.56.0, Multiple security (CVE) vulnerabilities
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Some People
Assignee: Steve Wills
URL:
Keywords: needs-patch, needs-qa, security
Depends on:
Blocks:
 
Reported: 2017-07-10 18:03 UTC by Andrew Marks
Modified: 2017-08-24 01:06 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Marks 2017-07-10 18:03:52 UTC
CVE-2017-9775
CVE-2017-9775
Comment 1 commit-hook freebsd_committer 2017-08-24 01:02:44 UTC
A commit references this bug:

Author: swills
Date: Thu Aug 24 01:01:45 UTC 2017
New revision: 448641
URL: https://svnweb.freebsd.org/changeset/ports/448641

Log:
  Document issues in poppler

  PR:		220608

Changes:
  head/security/vuxml/vuln.xml
Comment 2 commit-hook freebsd_committer 2017-08-24 01:03:47 UTC
A commit references this bug:

Author: swills
Date: Thu Aug 24 01:03:00 UTC 2017
New revision: 448642
URL: https://svnweb.freebsd.org/changeset/ports/448642

Log:
  graphics/poppler: update to 0.57.0

  PR:		220608
  Reported by:	Andrew Marks <amracks@gmail.com>
  Approved by:	gnome@ (kwm)
  MFH:		2017Q3
  Security:	eca2d861-76f4-42ed-89d2-23a2cb396c87

Changes:
  head/graphics/poppler/Makefile
  head/graphics/poppler/distinfo
  head/graphics/poppler/pkg-plist
  head/graphics/poppler-glib/pkg-plist
  head/graphics/poppler-qt5/pkg-plist
Comment 3 commit-hook freebsd_committer 2017-08-24 01:05:50 UTC
A commit references this bug:

Author: swills
Date: Thu Aug 24 01:04:44 UTC 2017
New revision: 448643
URL: https://svnweb.freebsd.org/changeset/ports/448643

Log:
  MFH: r448642

  graphics/poppler: update to 0.57.0

  PR:		220608
  Reported by:	Andrew Marks <amracks@gmail.com>
  Approved by:	gnome@ (kwm)
  Security:	eca2d861-76f4-42ed-89d2-23a2cb396c87

  Approved by:	ports-secteam (implicit)

Changes:
_U  branches/2017Q3/
  branches/2017Q3/graphics/poppler/Makefile
  branches/2017Q3/graphics/poppler/distinfo
  branches/2017Q3/graphics/poppler/pkg-plist
  branches/2017Q3/graphics/poppler-glib/pkg-plist
  branches/2017Q3/graphics/poppler-qt5/pkg-plist
Comment 4 Steve Wills freebsd_committer 2017-08-24 01:06:18 UTC
Committed, thanks for the heads up.