Bug 220722 - sysutils/tmux: lost the ability to record utmp entries in 2.3 -> 2.4.
Summary: sysutils/tmux: lost the ability to record utmp entries in 2.3 -> 2.4.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mathieu Arnold
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-07-14 05:23 UTC by Peter Wemm
Modified: 2017-07-14 09:40 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (mat)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Wemm freebsd_committer freebsd_triage 2017-07-14 05:23:40 UTC
Since 1.9, it has auto-detected the libutempter/libulog libraries we provide. Since 2.4 you have to enable detection of the library.

Quick and dirty workaround:

-CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc
+CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc --enable-utempter

We rely on this in the freebsd.org cluster.
Comment 1 commit-hook freebsd_committer 2017-07-14 07:59:14 UTC
A commit references this bug:

Author: mat
Date: Fri Jul 14 07:58:08 UTC 2017
New revision: 445733
URL: https://svnweb.freebsd.org/changeset/ports/445733

Log:
  Add utmp support back.

  UTMP support is no longer auto-detected, it needs to be enabled manually.

  PR:		220722
  Reported by:	peter
  Sponsored by:	Absolight

Changes:
  head/sysutils/tmux/Makefile