Bug 220727 - Cannot reboot Lenovo X1 Carbon (5th gen/2017)
Summary: Cannot reboot Lenovo X1 Carbon (5th gen/2017)
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords: needs-qa
: 224557 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-07-14 09:17 UTC by Tobias C. Berner
Modified: 2021-01-16 21:43 UTC (History)
11 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias C. Berner freebsd_committer 2017-07-14 09:17:25 UTC
Hi

When calling reboot the X1 hangs on the Lenovo boot screen. 
Powering it off via the Power-Button and starting it up again normally works fine.


mfg Tobias
Comment 1 Andrey V. Elsukov freebsd_committer 2017-07-14 11:26:46 UTC
Hi Tobias, this is offtopic, but can you write some info this notebook here https://wiki.freebsd.org/Laptops/Thinkpad_X1_Carbon ?
Comment 2 Tobias C. Berner freebsd_committer 2017-07-14 20:20:17 UTC
Sure. I modified the page.
Comment 3 stefanw 2017-10-10 15:41:54 UTC
I have the very same problem with a Lenovo P50
Comment 4 Sam Gwydir 2017-12-13 18:01:20 UTC
I can ad that this is not yet fixed as of r325585
Comment 5 Arne Ehrlich 2018-02-16 10:03:41 UTC
Hi,

i can confirm the same for T46p. Reboot hangs on Logo or even before displaying the BIOS info screen, when the logo is disabled in the BIOS. Only a text cursor is on the screen in that case.

Good to know i`m not alone ;-)

Some reboot related stuff does not seem to work. `reboot` in the kernel debugger for instance just hangs and does not restart the machine.
Comment 6 Loïc Bartoletti freebsd_committer 2018-03-03 06:08:32 UTC
I confirm too with Lenovo X1 Carbon 5th gen with FreeBSD 11 RELEASE, STABLE and FreeBSD CURRENT
Comment 7 Oleksandr Tymoshenko freebsd_committer freebsd_triage 2018-03-03 06:41:38 UTC
Same problem with Thinkpad X260
Comment 8 Andrey V. Elsukov freebsd_committer 2018-03-06 07:56:17 UTC
I had the same problem with X1 Carbon Gen4, but when I started using drm-next-kmod this problem seems disappeared. I'm not sure, because this happened just after upgrade to 12.0-CURRENT r329155. Now it can reliable reboot from X11 and from console.
Comment 9 Jan Bramkamp 2018-03-06 16:28:58 UTC
I encountered the same problem with my T470s.
Comment 10 Neel Chauhan freebsd_committer 2018-03-23 01:06:41 UTC
I also have this issue on a Dell Inspiron 7352. I have a separate bug report for this laptop: Bug 224557. For a little while it rebooted, but it suddenly stopped working with very recent CURRENTs.

I do not have this issue on a HP EliteBook Folio 1040 G1 (which I am typing this message from).

Both laptops are personal, however the former is limited to schoolwork/internship (which is mostly non-FreeBSD other than testing) and the latter runs FreeBSD and is used for personal stuff (and port maintenance when I'm not on my dekstop).
Comment 11 Neel Chauhan freebsd_committer 2018-03-23 01:34:03 UTC
(In reply to Neel Chauhan from comment #10)

I also tried graphics/drm-next-kmod on the Inspiron, but it still couldn't reboot. No wonder why I have the EliteBook.
Comment 12 Neel Chauhan freebsd_committer 2018-03-26 17:55:51 UTC
On the Dell Inspiron 7352, I noticed that if I boot in single user mode, I can reboot successfully. So I am suspecting that the problem is in userspace and not in the kernel (or could be a userland program setting something in the kernel which prevents reboots on some laptops).
Comment 13 Neel Chauhan freebsd_committer 2018-03-26 17:56:15 UTC
(In reply to Neel Chauhan from comment #12)
Rebooting successfully provided I don't go to multi-user mode.
Comment 14 Neel Chauhan freebsd_committer 2018-04-26 18:54:56 UTC
I believe this is an issue with ng_ubt. Information on how to fix it (at least on my Inspiron, maybe also for ThinkPads) is described on my website:

https://www.neelc.org/dell-inspiron-7352-fixing-the-blank-screen-on-reboot-problem-on-freebsd/

In short, you need a .conf file in /etc/devd with:

nomatch 50 {
    match "bus" "uhub[0-9]+";
    match "mode" "host";
    match "vendor" "VENDOR_ID";
    match "product" "PRODUCT_ID";
    #action "kldload -n ng_ubt";
    action "logger blocked bluetooth module";
};

Replace VENDOR_ID and PRODUCT_ID with the vendor and product IDs from ubt0. You can find this out with:

grep -R ubt /var/log/messages
Comment 15 Jan Bramkamp 2018-04-27 14:15:55 UTC
Preventing devd from loading the bluetooth driver allows my T470s running 12-CURRENT to reboot without problems.
Comment 16 Kirill Radzikhovskyy 2018-04-29 22:12:41 UTC
Same with my T470s,
just a note that Neels solution wasn't enough, I had to follow 
https://gist.github.com/myfreeweb/44f4f3e791a057bc4f3619a166a03b87
in order to prevent bluetooth being loaded,
but after that rebooting is working !
Comment 17 Neel Chauhan freebsd_committer 2018-04-29 23:02:47 UTC
First off, thank you so much for the positive feedback around my workaround.

Regarding Comment 16, the reason why I did not disable Bluetooth completely is because if people occasionally plug in a USB Bluetooth adapter, they shouldn't lose BT even if it means a hassle to reboot once in a while. But if you had better success disabling BT completely then hey, maybe that's the way to go.

Also my workaround (in terms of rebooting) doesn't work if you don't put in **your** VENDOR and PRODUCT hex values (your meaning not mine).
Comment 18 Tobias C. Berner freebsd_committer 2018-05-03 21:29:59 UTC
Disabling the BT chip in the BIOS seems to do the trick for me. Good catch. 

Thanks for the workaround.
Comment 19 Neel Chauhan freebsd_committer 2018-05-08 12:06:25 UTC
*** Bug 224557 has been marked as a duplicate of this bug. ***
Comment 20 Tom Jones freebsd_committer 2021-01-16 21:43:04 UTC
This issue was resolved on the Thinkpad x270 in summer 2020, if it still holds please reopen the bug.