Bug 220751 - x11/xfce4-terminal: Update to 0.8.6
Summary: x11/xfce4-terminal: Update to 0.8.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-xfce (Nobody)
URL:
Keywords: patch-ready
Depends on:
Blocks:
 
Reported: 2017-07-16 04:38 UTC by Olivier Duchateau
Modified: 2017-09-18 15:18 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (xfce)


Attachments
Patch to update x11/xfce4-terminal (1.15 KB, patch)
2017-07-16 04:38 UTC, Olivier Duchateau
no flags Details | Diff
New patch to update x11/xfce4-terminal (2.18 KB, patch)
2017-08-06 03:53 UTC, Olivier Duchateau
no flags Details | Diff
Revised patch (2.92 KB, patch)
2017-09-15 15:00 UTC, Guido Falsi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Duchateau 2017-07-16 04:38:24 UTC
Created attachment 184381 [details]
Patch to update x11/xfce4-terminal

Update to 0.8.6
Comment 1 Vladimir Omelchuk 2017-07-16 05:33:11 UTC
This patch works for me.
When will be committed in the ports tree this and many other patches for xfce?
Comment 2 Olivier Duchateau 2017-07-16 07:34:17 UTC
(In reply to Vladimir Omelchuk from comment #1)

When a committer will be interesting to Xfce.

As I'm not anymore ports committer I don't know when updates will be in ports tree. Perhaps tell to ports@ mailing list there are lots of updates for Xfce ports.
Comment 3 Olivier Duchateau 2017-07-16 08:05:38 UTC
I noticed, if you have defined custom color for your cursor (CursorColor variable and its value are defined in .config/xfce4/terminal/terminalrc) you must add new variable ColorCursorUseDefault=FALSE (by default it's TRUE).

I think an update of files/pkg-message.in is needed or an new entry in UPDATING ir order to tell users their preferences are still present.
Comment 4 Vladimir Omelchuk 2017-07-19 18:32:20 UTC
I think I found a bug.
After rename title tab, the cursor sometimes does not become active.
See example: http://files.dp.ua/file?source=17071921192340342266
Comment 5 Vladimir Omelchuk 2017-07-31 12:25:57 UTC
I created PR for upstream: https://bugzilla.xfce.org/show_bug.cgi?id=13754
Comment 6 Olivier Duchateau 2017-07-31 15:52:58 UTC
(In reply to Vladimir Omelchuk from comment #5)

Sorry Vladimir, I can't reproduce cursor behavior (also tested on Linux box).
Comment 7 Olivier Duchateau 2017-08-06 03:53:57 UTC
Created attachment 185070 [details]
New patch to update x11/xfce4-terminal

Same patch as previously, with fix focus of title in popover (obtained from upstream repository).
Comment 8 Guido Falsi freebsd_committer 2017-09-15 15:00:26 UTC
Created attachment 186418 [details]
Revised patch

I revised your patch slightly.

I moved the USES line to make portlint happy and added the changes you suggest to pkg-message.

Does my wording in pkg-message look correct?
Comment 9 Olivier Duchateau 2017-09-15 19:57:10 UTC
(In reply to Guido Falsi from comment #8)

Your patch looks fine.

In pkg-message, in fact if a user has defined color for his/her cursor and wants to keep its value. Value of ColorCursorUseDefault variable (it's new variable) must be equal to FALSE (by default it's TRUE). Other way, he/she goes to Preferences window.
Comment 10 Guido Falsi freebsd_committer 2017-09-15 20:24:14 UTC
(In reply to Olivier Duchateau from comment #9)
> (In reply to Guido Falsi from comment #8)
> 
> Your patch looks fine.
> 
> In pkg-message, in fact if a user has defined color for his/her cursor and
> wants to keep its value. Value of ColorCursorUseDefault variable (it's new
> variable) must be equal to FALSE (by default it's TRUE). Other way, he/she
> goes to Preferences window.

I see, I'll reword again to specify the user can add hte option by hand OR reconfigure via the UI (hope I got it right)
Comment 11 commit-hook freebsd_committer 2017-09-18 15:16:22 UTC
A commit references this bug:

Author: madpilot
Date: Mon Sep 18 15:15:53 UTC 2017
New revision: 450045
URL: https://svnweb.freebsd.org/changeset/ports/450045

Log:
  - Update x11/xfce4-terminal to 0.8.6
  - Silence USES portlint warning
  - Rework pkg-message, and add new informations

  PR:		220751
  Submitted by:	Olivier Duchateau <duchateau.olivier@gmail.com>

Changes:
  head/x11/xfce4-terminal/Makefile
  head/x11/xfce4-terminal/distinfo
  head/x11/xfce4-terminal/files/patch-terminal_terminal-window.c
  head/x11/xfce4-terminal/files/pkg-message.in
Comment 12 Guido Falsi freebsd_committer 2017-09-18 15:18:46 UTC
Committed. Thanks!