Bug 220805 - deskutils/xfce4-tumbler: Update to 0.2.0
Summary: deskutils/xfce4-tumbler: Update to 0.2.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-xfce (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks: 220407
  Show dependency treegraph
 
Reported: 2017-07-17 16:06 UTC by Olivier Duchateau
Modified: 2017-09-18 15:12 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (xfce)


Attachments
Patch to update deskutils/xfce4-tumbler (5.04 KB, patch)
2017-07-17 16:06 UTC, Olivier Duchateau
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Duchateau 2017-07-17 16:06:21 UTC
Created attachment 184442 [details]
Patch to update deskutils/xfce4-tumbler

- Update to 0.2.0 (this is a major upgrade, because it was ported to GDbus)

Otherwise same comment as bug #219848 (update to 0.1.32)
- Sort USES
- Simplify options, remove FONTS, JPEG, POPPLER, ODF (already set by default), and COVER (requires API key for authentication)
- Regenerate patches (with 'make makepatch')
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2017-07-18 12:48:23 UTC
Thank you Olivier. Please confirm this change passes QA (portlint, poudriere)
Comment 2 Guido Falsi freebsd_committer 2017-09-15 14:46:03 UTC
(In reply to Olivier Duchateau from comment #0)
> Created attachment 184442 [details]
> Patch to update deskutils/xfce4-tumbler
> 
> - Update to 0.2.0 (this is a major upgrade, because it was ported to GDbus)
> 
> Otherwise same comment as bug #219848 (update to 0.1.32)
> - Sort USES
> - Simplify options, remove FONTS, JPEG, POPPLER, ODF (already set by
> default), and COVER (requires API key for authentication)
> - Regenerate patches (with 'make makepatch')

You think removing the COVER option is really needed? While I agree on leaving that disabled it could be useful for some users.

The other options should be evaluated too. I agree that a desktop user most probably has the required dependency installed anyway. I'd be interested in your reasoning behind this change mainly.

Thanks.
Comment 3 Olivier Duchateau 2017-09-15 19:46:15 UTC
(In reply to Guido Falsi from comment #2)

COVER plugin requires API user key for themoviedb.org (stored in tumbler.rc file), and by default (in configure script) this option is disabled. User must create an account on this host in order to use this plugin.

Tumbler already provides 2 plugins for video thumbnails (GStreamer and Ffmpeg), I thought it was enough.
Comment 4 Guido Falsi freebsd_committer 2017-09-16 20:40:57 UTC
(In reply to Olivier Duchateau from comment #3)
> (In reply to Guido Falsi from comment #2)
> 
> COVER plugin requires API user key for themoviedb.org (stored in tumbler.rc
> file), and by default (in configure script) this option is disabled. User
> must create an account on this host in order to use this plugin.
> 
> Tumbler already provides 2 plugins for video thumbnails (GStreamer and
> Ffmpeg), I thought it was enough.

This does not invalidate having a COVER option.

GStreamer and FFMpeg will extract a frame from the video(sometimes just a black one). This is quite different from getting movie art like a poster from a website.

We can "fix" the problem of requiring registration to the website with a pkg-message, and also adding a note in the option description (like "requires additional configuration"). Also, this is a port, if upstream provides the option we need some good technical reason to remove it.

You did not specify the reasoning behind the removal of the other options. Since they are there we have to account for users who maybe find them useful.

If they work correctly there's no reason to remove them.
Comment 5 commit-hook freebsd_committer 2017-09-18 15:12:14 UTC
A commit references this bug:

Author: madpilot
Date: Mon Sep 18 15:11:44 UTC 2017
New revision: 450044
URL: https://svnweb.freebsd.org/changeset/ports/450044

Log:
  - Update deskutils/xfce4-tumbler to 0.2.0 [1]
  - Update x11-fm/thunar 1.6.12 [2]
  - Silence USES portlint warning [2]
  - Regenerate patches [2]
  - Add warning about COVER tunar plugin requiring manual
    configuration [1]

  PR:		220805 [1], 220407 [2]
  Submitted by:	Olivier Duchateau <duchateau.olivier@gmail.com>

Changes:
  head/deskutils/xfce4-tumbler/Makefile
  head/deskutils/xfce4-tumbler/distinfo
  head/deskutils/xfce4-tumbler/files/patch-configure
  head/deskutils/xfce4-tumbler/files/patch-tumblerd__tumbler.rc
  head/deskutils/xfce4-tumbler/files/pkg-message.in
  head/deskutils/xfce4-tumbler/pkg-plist
  head/x11-fm/thunar/Makefile
  head/x11-fm/thunar/distinfo
  head/x11-fm/thunar/files/patch-configure
Comment 6 Guido Falsi freebsd_committer 2017-09-18 15:12:39 UTC
Committed. With some changes.

Thanks!