Bug 220896 - deskutils/kdeconnect-kde-kf5 not working
Summary: deskutils/kdeconnect-kde-kf5 not working
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: kde
URL: https://mail.kde.org/pipermail/kde-fr...
Keywords: needs-patch
Depends on:
Blocks: kdeconnect-import
  Show dependency treegraph
 
Reported: 2017-07-21 05:51 UTC by Stefan Rumetshofer
Modified: 2018-09-30 19:25 UTC (History)
6 users (show)

See Also:
tcberner: maintainer-feedback+
koobs: merge-quarterly-


Attachments
shar (26.07 KB, text/plain)
2018-06-04 10:14 UTC, mikael.urankar
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Rumetshofer 2017-07-21 05:51:54 UTC
As suggested by TCB i open a PR even the port is not in the official ports tree
but the port is availabe in the area51 repo. See the post on the kde-freebsd mailing list [url]https://mail.kde.org/pipermail/kde-freebsd/2017-July/026414.html[/url]

The problem: kdeconnect dies when i try to connect via the app on my phone.
So i started the daemon from the command line and i get the following output:

 % /usr/local/lib/libexec/kdeconnectd
kdeconnect.core: KdeConnect daemon starting
qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set1_groups
kdeconnect.core: onStart
kdeconnect.core: KdeConnect daemon started
kdeconnect.core: Broadcasting identity packet
kdeconnect.core: Fallback (1), try reverse connection (send udp packet)
"Connection refused"
Speicherschutzverletzung

The problem is not limited to my phone, i also tried an other android device with the same result.

Tell me if you need more information.

Stefan
Comment 1 Tobias C. Berner freebsd_committer 2017-07-23 12:48:44 UTC
I can confirm that it seems to crash.
Still have to investigate the issue though.

Mfg Tobias
Comment 2 Patrick McMunn 2017-11-07 04:40:35 UTC
Have you had a chance to look into this? I encountered the "qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set1_groups" and segfault error with another application (not in ports) called Orion which is a desktop client for Twitch. I Googled the error, and this bug came up. Maybe the issue is with the QT library since there are at least two applications segfaulting with the same error.
Comment 3 Tobias C. Berner freebsd_committer 2017-11-07 05:45:46 UTC
(In reply to Patrick from comment #2)

I think the 
   qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set1_groups
is a red herring.

mfg Tobias
Comment 4 Friedrich Volkmann 2017-12-23 12:43:50 UTC
I am having the same error with astro/merkaartor. It should certainly be filed under net/qt5-network. I reinstalled it (portupgrade -Rf qt5-network), but the error did not go away. The problem may be related to a change in the base system, as I only got the error after upgrading the OS from 10.3-STABLE to 11.1-STABLE.

$ merkaartor 
****  "2017-12-23T10:58:17"  -- Starting  "Merkaartor/0.18.2 (Other)"
------- "using Qt version 5.7.1 (built with 5.7.1)"
------- "using PROJ4 version 4.9.3"
------- "using GDAL version 2.2.3"
------- with arguments:  ("merkaartor")
PluginsDir: "/usr/local/lib/merkaartor/plugins"
Loading plugins from directory  "plugins"
Loading plugins from directory  "background"
  Loading "libMGdalBackgroundPlugin.so" as plugin.
...
Requesting preferences from OSM server.
QSslSocket: cannot resolve SSL_CTX_set1_groups

Segmentation fault (core dumped)
Comment 5 Friedrich Volkmann 2017-12-23 15:43:05 UTC
This seems like a duplicate of #218421, where conflicting SSL libaries have been identified as the problem. I moved /usr/lib/libssl.* to a backup directory in order to see which libary is linked to them:

$ merkaartor 
Shared object "libssl.so.7" not found, required by "libcurl.so.4"

Now I reinstalled ftp/curl and moved the libssl.* back to /usr/lib/. That solved the problem in Merkaator, and I guess that you can resolve the crashes in kdeconnect and Orion in the same way.
Comment 6 mikael.urankar 2018-06-04 10:14:00 UTC
Created attachment 193987 [details]
shar

I think I fixed the crash, can someone test this port?
Comment 7 Tobias C. Berner freebsd_committer 2018-06-04 10:42:59 UTC
Seems to work, thanks :)
Comment 8 Stefan Rumetshofer 2018-06-05 17:03:17 UTC
(In reply to Tobias C. Berner from comment #7)
I can confirm that it is working now.
Comment 9 Patrick McMunn 2018-06-06 02:37:47 UTC
(In reply to mikael.urankar from comment #6)

I have tested your new port on two machines. It seems to work (I haven't tested in extensively) on a netbook running 11.2-RC1. It does not work on a desktop running 12-CURRENT r334647. Since it at least works on the one running a stable branch, I'd call this a win.
Comment 10 Patrick McMunn 2018-06-06 03:03:04 UTC
Correction. It does work on the desktop running 12-CURRENT. However, on the 12-CURRENT desktop I do not get a notification tray popup telling me a pairing request has been sent when I send a request from my phone. However, if I open the KDE Connect application on the desktop and click on my phone's listing, I can accept the request. I do get the popup notification on my 11.2-RC1 netbook when I send a pairing request from my phone. For some reason I do not get a notification on my phone when I send a pairing request from either of my FreeBSD computers. But that may have nothing to do with FreeBSD or the KDE Connect application and may only be an issue with the Android app.
Comment 11 commit-hook freebsd_committer 2018-09-30 19:23:08 UTC
A commit references this bug:

Author: tcberner
Date: Sun Sep 30 19:22:46 UTC 2018
New revision: 480969
URL: https://svnweb.freebsd.org/changeset/ports/480969

Log:
  Add new port: deskutils/kdeconnect-kde -- the KF5 baesed version of deskutils/kdeconnect-kde-kde4.

  Thanks to mikael.urankar@gmail.com for the patch fixing segfaults on IPv4 mapped IPV6 addresses.

  PR:		220896
  PR:		227832

Changes:
  head/deskutils/Makefile
  head/deskutils/kdeconnect-kde/
  head/deskutils/kdeconnect-kde/Makefile
  head/deskutils/kdeconnect-kde/distinfo
  head/deskutils/kdeconnect-kde/files/
  head/deskutils/kdeconnect-kde/files/patch-core_backends_lan_lanlinkprovider.cpp
  head/deskutils/kdeconnect-kde/pkg-plist
  head/deskutils/kdeconnect-kde-kde4/Makefile
Comment 12 Tobias C. Berner freebsd_committer 2018-09-30 19:25:08 UTC
Finally committed. Thanks for the patch Mikael.