Bug 221050 - emulators/virtualbox-ose: Bridged network doesn't work (11.1-RELEASE)
Summary: emulators/virtualbox-ose: Bridged network doesn't work (11.1-RELEASE)
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Virtualbox Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-27 16:08 UTC by lavr
Modified: 2017-11-19 13:28 UTC (History)
12 users (show)

See Also:
vlad-fbsd: maintainer-feedback? (vbox)


Attachments
kBuild build failure from 2017Q3 ports on 11.1-RELEASE (201.62 KB, text/plain)
2017-07-27 16:50 UTC, steinex
no flags Details
virtualbox-ose build failure from 2017Q3 ports on 11.1-RELEASE (386.21 KB, text/plain)
2017-07-27 16:51 UTC, steinex
no flags Details
Vbox.log from a session where bridged network does not work (67.95 KB, text/plain)
2017-07-27 16:55 UTC, steinex
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lavr 2017-07-27 16:08:07 UTC
Hi All,

host:

[good]~ > uname -rm
11.1-RELEASE amd64
[good]~ > freebsd-version
11.1-RELEASE
[good]~ > pkg info | grep virtualbox
virtualbox-ose-5.1.22_1        General-purpose full virtualizer for x86 hardware
virtualbox-ose-kmod-5.1.22     VirtualBox kernel module for FreeBSD
[good]~ > 

[good]~ > kldstat 
Id Refs Address            Size     Name
 1   75 0xffffffff80200000 1f67a88  kernel
 2    1 0xffffffff82169000 720d8    if_igb.ko
 3    1 0xffffffff821dc000 6968     ng_bridge.ko
 4    6 0xffffffff821e3000 19ec0    netgraph.ko
 5    1 0xffffffff821fd000 6a20     ng_eiface.ko
 6    1 0xffffffff82204000 7688     ng_ether.ko
 7    1 0xffffffff8220c000 7f48     ng_socket.ko
 8    1 0xffffffff82214000 4480     aibs.ko
 9    1 0xffffffff82219000 b760     sem.ko
10    3 0xffffffff82225000 7de80    vboxdrv.ko
11    1 0xffffffff822a3000 1a8c8    fuse.ko
12    1 0xffffffff825e6000 2018f1   zfs.ko
13    1 0xffffffff827e8000 9aea     opensolaris.ko
14    1 0xffffffff827f2000 5936     fdescfs.ko
15    1 0xffffffff827f8000 a877     linprocfs.ko
16    3 0xffffffff82803000 7b0f     linux_common.ko
17    1 0xffffffff8280b000 bb55     tmpfs.ko
18    1 0xffffffff82817000 965599   nvidia.ko
19    1 0xffffffff8317d000 42864    linux.ko
20    1 0xffffffff831c0000 23528    ipfw.ko
21    2 0xffffffff831e4000 2a1f     vboxnetflt.ko
22    1 0xffffffff831e7000 3f86     vboxnetadp.ko
23    1 0xffffffff831eb000 3650     ums.ko
24    1 0xffffffff831ef000 2986     uhid.ko
25    1 0xffffffff831f2000 3c93f    linux64.ko
26    1 0xffffffff83368000 47af     efirt.ko
[good]~ >

[good]~ > ipfw show
00100     36      2984 allow ip from any to any via lo0
00200      0         0 deny ip from any to 127.0.0.0/8
00300      0         0 deny ip from 127.0.0.0/8 to any
00400      0         0 deny ip from any to ::1
00500      0         0 deny ip from ::1 to any
00600      0         0 allow ipv6-icmp from :: to ff02::/16
00700      0         0 allow ipv6-icmp from fe80::/10 to fe80::/10
00800      0         0 allow ipv6-icmp from fe80::/10 to ff02::/16
00900      0         0 allow ipv6-icmp from any to any ip6 icmp6types 1
01000      0         0 allow ipv6-icmp from any to any ip6 icmp6types 2,135,136
65000 305512 276162676 allow ip from any to any
65535      0         0 deny ip from any to any
[good]~ >

Guest OS: freebsd or linux
Comment 1 steinex 2017-07-27 16:16:23 UTC
I experience the same issue, with virtualbox-ose and virtualbox-ose-kmod from 2017Q3 packages.

I tried rebuilding virtualbox-ose from ports (2017Q3 branch) to build the kernel module against the 11.1 kernel to see if this helps, but the build fails. I have not a log of the failure right now but I could hand in later.
Comment 2 Eugene Grosbein freebsd_committer 2017-07-27 16:18:09 UTC
It works for me just fine. You should be more specific in problem description. Do not afraid to supply extra details, that's better that no enough details.
Comment 3 steinex 2017-07-27 16:50:11 UTC
Created attachment 184772 [details]
kBuild build failure from 2017Q3 ports on 11.1-RELEASE
Comment 4 steinex 2017-07-27 16:51:41 UTC
Created attachment 184773 [details]
virtualbox-ose build failure from 2017Q3 ports on 11.1-RELEASE
Comment 5 steinex 2017-07-27 16:52:55 UTC
Some more details.

This is from 2017Q3 packages:

* I have no firewall or whatsoever in place on the host.
* Attached is VBox.log when running an OpenBSD guest where bridged networking does not work. It doesn't work for any guest though, no matter what OS as far as I can tell. I can't spot obvious errors the log though.
** The interface to be bridged is em0 (Intel(R) 82579V Gigabit Network Device).
** Symptom is DHCP-requests just time out.

* I don't know if its important but I thought it may be worth mentioning. When doing "/usr/local/etc/rc.d/vboxnet onestop" to unload the modules again, dmesg shows: "Warning: memory type iprtheap leaked memory on destroy (2 allocations, 128 bytes leaked)."

* When trying to build virtualbox-ose from ports r2017Q3-branch (any dependency but virtualbox-ose-kmod is already installed from packages at this point, including kBuild), build failure log is attached as virtualbox-ose-buildfailure.txt

* When trying to build virtualbox-ose from ports r2017Q3-branch (any dependency but virtualbox-ose-kmod and kBuild are already installed from packages at this point, build failure log is attached as kBuild-buildfailure.txt

Please tell me if I can supply any more details.
Comment 6 steinex 2017-07-27 16:55:45 UTC
Created attachment 184774 [details]
Vbox.log from a session where bridged network does not work
Comment 7 Jung-uk Kim freebsd_committer 2017-07-27 18:00:08 UTC
(In reply to steinex from comment #5)
> /usr/local/lib/gcc5/gcc/x86_64-portbld-freebsd11.0/5.4.0/include-fixed/sys/types.h:266:9: error: unknown type name '__vm_ooffset_t'
 typedef __vm_ooffset_t vm_ooffset_t;
>          ^
> /usr/local/lib/gcc5/gcc/x86_64-portbld-freebsd11.0/5.4.0/include-fixed/sys/types.h:268:9: error: unknown type name '__vm_pindex_t'
 typedef __vm_pindex_t vm_pindex_t;
>          ^

Build failures are coming from broken lang/gcc5.  As you can see, it was built on 11.0 and it is incompatible with 11.1 unfortunately.
Comment 8 steinex 2017-07-27 20:19:30 UTC
Ok, I can confirm that bridged networking  works again when virtualbox-ose is build from source  when it's complete dependency chain is also built from ports.

It makes sense to me that virtualbox needs to be compiled against the new kernel after upgrading, I didn't spot the gcc5 issue, thanks for that.

However, I'm not the original bug submitter and I can relate to the confusion as of why a package stops working after upgrade to a new minor-release. I see a chicken-and-egg problem between quarterlies (and most probably even latest) packages that provide out-of-tree modules and a new -RELEASE.

I have no stake in here what to do, having a virtualbox-ose package sure is nice, but having none at all may be less confusing.


tl;dr: bridged networking in virtualbox from ports (2017Q3) with 11.1 is totally fine, if you compile virtualbox with it's complete dependency chain from ports and not use packages.
Comment 9 Eugene Grosbein freebsd_committer 2017-07-28 02:17:16 UTC
You generally need not rebuild ports/packages after minor OS upgrade. Unfortunately, this does not apply to packages containing own kernel modules - you may need to rebuild/reinstall them after minor upgrade.
Comment 10 Kurt Jaeger freebsd_committer 2017-07-28 05:11:50 UTC
Maybe a pkg-message that explains how to rebuild and how to test would be helpful ? Is there an easy test ?
Comment 11 lavr 2017-07-28 07:31:51 UTC
Hi All,

sorry for noise.

Affect only package virtualbox-ose-kmod-5.1.22 from FreeBSD pkg-repo.

After deleting:

# pkg delete -f virtualbox-ose-kmod-5.1.22

and build new vbox modules on fresh FreeBSD 11.1-RELEASE

# make -C /usr/ports/emulators/virtualbox-ose-kmod install

all ok, VirtualBox Bridged networking work fine.

Thanks to All.

Best regards,
--
lavr
Comment 12 Marko Cupać 2017-07-31 10:19:57 UTC
(In reply to Eugene Grosbein from comment #9)

Thank you for this information, as this updates my understanding that all the packages for all the consequent minor releases are always built on an unpatched initial major release.

Contrary to above concept, I have been building packages for minor releases on latest binary patchlevels for these releases in poudriere, which resulted in quite a number of complete rebuilds. I've been considering the idea to start building everything on an unpatched 11.0-RELEASE poudriere jail. According to this PR, it appears it's better not to.
Comment 13 John Hood 2017-07-31 19:43:11 UTC
(In reply to lavr from comment #11)

This works for me too-- only virtualbox-ose-kmod must be rebuilt on 11.1, all of its build dependencies can come from packages.

This does suggest that there is still some KBI incompatibility between 11.0 and 11.1 though.
Comment 14 rkoberman 2017-07-31 23:38:51 UTC
(In reply to John Hood from comment #13)
Just to clarify for people, while developers try to not adjust the KBI within a major release, it has never been a commitment.

The bottom line is that all kernel modules from ports should be re-built every time the kernel is updated. For those running releases, this is for every release as well as security patches which involve a kernel replacement whether by a re-build or freebsd-update. For those of us running stable, it is every time the kernel is updated.

While lsof does not involve a kernel module, it does poke around in the kernel and will break far more easily with kernel changes than modules as it does its poking outside the documented KBI.

If you build kernels from source, you can list ports needing updating in /etc/src.conf like this:
PORTS_MODULES=emulators/virtualbox-ose-kmod sysutils/lsof

If you install packages you need to wait until a package build has been completed after a release. This is usually two or three days, but I have seen it take as long as a week.
Comment 15 Slawomir Wojciech Wojtczak 2017-08-07 12:59:55 UTC
Compilation fails for me:

# make -C /usr/ports/emulators/virtualbox-ose-kmod install
(...)
rm -rf $backupdir; exit $rc
gmake[7]: Leaving directory '/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/sed/doc'
Making all in testsuite
gmake[7]: Entering directory '/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/sed/testsuite'
gmake[7]: Nothing to be done for 'all'.
gmake[7]: Leaving directory '/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/sed/testsuite'
gmake[7]: Entering directory '/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/sed'
gmake[7]: Leaving directory '/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/sed'
gmake[6]: Leaving directory '/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/sed'
gmake[5]: Leaving directory '/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/sed'
cp -f /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/sed/sed/sed /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/kmk/kmk_sed
ln -s /bin/echo /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/kmk/kmk_echo
cp -f /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/kmk/config.h /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/kmk/config.h.freebsd
echo "" >> /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/kmk/config.h.freebsd
echo '#include "inlined_memchr.h"' >> /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/kmk/config.h.freebsd
cp -f /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/sed/config.h /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/sed/config.h.freebsd
KBUILD_BIN_PATH=/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/kmk /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/kmk/kmk -C /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998 KBUILD_BOOTSTRAP=1
kmk: Entering directory `/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998'
Config.kmk:87: Neither SvnInfo nor .svn/* was found in the root. Will have to cook up something too keep the build happy.
Config.kmk:99: /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/SvnInfo.kmk: No such file or directory
kmk_builtin_rm -f /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/SvnInfo.kmk
kmk_builtin_mkdir -p /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj
kmk_builtin_append /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/SvnInfo.kmk 'KBUILD_SVN_REV := 0'
kmk_builtin_append /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/SvnInfo.kmk 'KBUILD_SVN_URL := /dev/null'
kmk: Leaving directory `/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998'
kmk: Entering directory `/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998'
Config.kmk:87: Neither SvnInfo nor .svn/* was found in the root. Will have to cook up something too keep the build happy.
kBuild: Pass - Build Programs
kBuild: Pass - Libraries
kBuild: Compiling kDep - /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/kDep.c
kBuild: Compiling kUtil - /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/crc32.c
kBuild: Compiling kUtil - /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/md5.c
kBuild: Compiling kUtil - /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/maybe_con_write.c
In file included from /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/crc32.c:48:0:
/usr/local/lib/gcc48/gcc/x86_64-portbld-freebsd11.0/4.8.5/include-fixed/sys/types.h:266:1: error: unknown type name '__vm_ooffset_t'
 typedef __vm_ooffset_t vm_ooffset_t;
 ^
In file included from /usr/local/lib/gcc48/gcc/x86_64-portbld-freebsd11.0/4.8.5/include-fixed/unistd.h:46:0,
                 from /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/maybe_con_write.c:45:
/usr/local/lib/gcc48/gcc/x86_64-portbld-freebsd11.0/4.8.5/include-fixed/sys/types.h:266:1: error: unknown type name '__vm_ooffset_t'
 typedef __vm_ooffset_t vm_ooffset_t;
 ^
/usr/local/lib/gcc48/gcc/x86_64-portbld-freebsd11.0/4.8.5/include-fixed/sys/types.h:268:1: error: unknown type name '__vm_pindex_t'
 typedef __vm_pindex_t vm_pindex_t;
 ^
/usr/local/lib/gcc48/gcc/x86_64-portbld-freebsd11.0/4.8.5/include-fixed/sys/types.h:268:1: error: unknown type name '__vm_pindex_t'
 typedef __vm_pindex_t vm_pindex_t;
 ^
In file included from /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/mytypes.h:36:0,
                 from /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/md5.h:4,
                 from /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/md5.c:19:
/usr/local/lib/gcc48/gcc/x86_64-portbld-freebsd11.0/4.8.5/include-fixed/sys/types.h:266:1: error: unknown type name '__vm_ooffset_t'
 typedef __vm_ooffset_t vm_ooffset_t;
 ^
/usr/local/lib/gcc48/gcc/x86_64-portbld-freebsd11.0/4.8.5/include-fixed/sys/types.h:268:1: error: unknown type name '__vm_pindex_t'
 typedef __vm_pindex_t vm_pindex_t;
 ^
kmk: *** [/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/crc32.o] Error 1
The failing command:
@gcc48 -c -O2 -g -O3 -m64 -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/kStuff/include -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/kmk/glob -I/usr/local/include -DKBUILD_VERSION_MAJOR=0 -DKBUILD_VERSION_MINOR=1 -DKBUILD_VERSION_PATCH=9998 -DKBUILD_OS_FREEBSD -DKBUILD_ARCH_AMD64 -DNDEBUG -Wp,-MD,/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/crc32.o.dep -Wp,-MT,/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/crc32.o -Wp,-MP -o /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/crc32.o /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/crc32.c
kmk: *** Waiting for unfinished jobs....
kmk: *** [/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/maybe_con_write.o] Error 1
The failing command:
@gcc48 -c -O2 -g -O3 -m64 -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/kStuff/include -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/kmk/glob -I/usr/local/include -DKBUILD_VERSION_MAJOR=0 -DKBUILD_VERSION_MINOR=1 -DKBUILD_VERSION_PATCH=9998 -DKBUILD_OS_FREEBSD -DKBUILD_ARCH_AMD64 -DNDEBUG -Wp,-MD,/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/maybe_con_write.o.dep -Wp,-MT,/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/maybe_con_write.o -Wp,-MP -o /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/maybe_con_write.o /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/maybe_con_write.c
In file included from /usr/include/sys/time.h:37:0,
                 from /usr/include/sys/stat.h:99,
                 from /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/kDep.c:44:
/usr/local/lib/gcc48/gcc/x86_64-portbld-freebsd11.0/4.8.5/include-fixed/sys/types.h:266:1: error: unknown type name '__vm_ooffset_t'
 typedef __vm_ooffset_t vm_ooffset_t;
 ^
/usr/local/lib/gcc48/gcc/x86_64-portbld-freebsd11.0/4.8.5/include-fixed/sys/types.h:268:1: error: unknown type name '__vm_pindex_t'
 typedef __vm_pindex_t vm_pindex_t;
 ^
kmk: *** [/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/md5.o] Error 1
The failing command:
@gcc48 -c -O2 -g -O3 -m64 -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/kStuff/include -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/kmk/glob -I/usr/local/include -DKBUILD_VERSION_MAJOR=0 -DKBUILD_VERSION_MINOR=1 -DKBUILD_VERSION_PATCH=9998 -DKBUILD_OS_FREEBSD -DKBUILD_ARCH_AMD64 -DNDEBUG -Wp,-MD,/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/md5.o.dep -Wp,-MT,/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/md5.o -Wp,-MP -o /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kUtil/md5.o /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/md5.c
kmk: *** [/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kDep/kDep.o] Error 1
The failing command:
@gcc48 -c -O2 -g -O3 -m64 -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/kStuff/include -I/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/kmk/glob -I/usr/local/include -DKBUILD_VERSION_MAJOR=0 -DKBUILD_VERSION_MINOR=1 -DKBUILD_VERSION_PATCH=9998 -DKBUILD_OS_FREEBSD -DKBUILD_ARCH_AMD64 -DNDEBUG -Wp,-MD,/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kDep/kDep.o.dep -Wp,-MT,/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kDep/kDep.o -Wp,-MP -o /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/obj/kDep/kDep.o /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/src/lib/kDep.c
kmk: Leaving directory `/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998'
kmk: Entering directory `/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998'
kmk: *** Exiting with status 2
gmake[4]: *** [bootstrap.gmk:221: /usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998/out/freebsd.amd64/release/bootstrap/ts-stage2-build] Error 2
gmake[4]: Leaving directory '/usr/ports/obj/usr/ports/devel/kBuild/work/kBuild-0.1.9998'
./kBuild/env.sh: info: rc=2: gmake -f bootstrap.gmk
*** Error code 2

Stop.
make[3]: stopped in /usr/ports/devel/kBuild
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/kBuild
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/emulators/virtualbox-ose-kmod
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/virtualbox-ose-kmod
Comment 16 Kubilay Kocak freebsd_committer freebsd_triage 2017-08-07 13:16:57 UTC
(In reply to vermaden from comment #15)

Please use attachments (not comments) for long bodfies of text like log/build files, configuration files, etc.

The errors looks very much like:

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=221111(gcc6-aux)
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=221237 (gcc5)

But for gcc48

CC maintainer
Comment 17 Slawomir Wojciech Wojtczak 2017-08-07 13:24:43 UTC
Sorry.

Also the NAT networking also does not work for me.

11.1-RELEASE with 5.1.26 here.
Comment 18 Will B 2017-08-07 15:55:22 UTC
I also am having problems with bridged AND NAT networking from guests on FreeBSD 11.1 host.  The VMs run fine but they cannot access the internet or the rest of the local network.

I do not want to build this from ports -- I want it to work the way it's always worked until 11.1 did something to it...
Comment 19 Eugene Grosbein freebsd_committer 2017-08-07 16:00:35 UTC
(In reply to Will B from comment #18)

Then you should stick with release branch and re-install pre-compiled package. There is no support for tracking stable branch without rebuild of ports having own kernel modules, if you mean that.
Comment 20 Will B 2017-08-07 16:05:25 UTC
(In reply to Eugene Grosbein from comment #19)

I *am* using 11.1-RELEASE.  I am *not* using a custom kernel and only use packages and not ports.  It's strange that this is marked 'Not a bug' because it most certainly is.  Whenever a software package that worked fine suddenly stops working correctly by no fault of the user, that's called a 'bug'.

I have completely removed all VirtualBox packages, rebooted, then reinstalled and the problem still persists.

I'm stuck on Ubuntu until this gets sorted...not having fun!
Comment 21 steinex 2017-08-07 16:13:42 UTC
(In reply to vermaden from comment #15)
This is already answered in Comment #7. You need to build gcc5 also.
Comment 22 steinex 2017-08-07 16:15:36 UTC
(In reply to steinex from comment #21)
Already answered in Comment #9.
Comment 23 steinex 2017-08-07 16:17:17 UTC
(In reply to Will B from comment #20)
Already answered in Comment #9.
Comment 24 Eugene Grosbein freebsd_committer 2017-08-07 16:18:34 UTC
(In reply to Will B from comment #20)

Please file new PR and supply as many details as possible, f.e. exact "uname" output, exact output of "pkg info -x virtualbox", precise description of your network setup including guest versions and so on. Don't forget to show unexpected behaviour of vbox networking and describe expected behavior, so one can start investigation.
Comment 25 rs18560 2017-10-17 15:08:47 UTC
Tried LAVR's solution but for me it didn't work.

Buid virtualbox-ose-kmod-5.1.30 successfully but the problem persists in my case, no bridged network possible.

Have stopped further investigation and downgraded to 11.0
Comment 26 ionut.vancea 2017-11-19 11:47:25 UTC
Of course it is a bug and downgrade to 11.0 is not an option for me.
Comment 27 ionut.vancea 2017-11-19 13:28:15 UTC
(In reply to ionut.vancea from comment #26)

finally is working for me, more info here: bug #221964, comment #4