Bug 221100 - deskutils/copyq: Update to 3.5.0
Summary: deskutils/copyq: Update to 3.5.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jason E. Hale
URL: https://github.com/hluk/CopyQ/releases
Keywords:
Depends on:
Blocks: 230884
  Show dependency treegraph
 
Reported: 2017-07-30 07:20 UTC by bsd
Modified: 2018-10-26 20:04 UTC (History)
5 users (show)

See Also:
jhale: maintainer-feedback-


Attachments
Update deskutils/copyq to 3.5.0 (4.87 KB, patch)
2018-09-01 13:58 UTC, Jason E. Hale
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description bsd 2017-07-30 07:20:23 UTC
Currently deskutils/copyq port is at version 2.7.1

Would it be possible to update it to latest version, currently 3.1.3?

https://github.com/hluk/CopyQ/releases

Thank you.
Comment 1 Bugzilla Automation freebsd_committer 2017-07-30 07:20:23 UTC
Maintainer informed via mail
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2017-08-01 09:05:17 UTC
@Kris Could you update MAINTAINER lines for your ports to match your Bugzilla account email please? This will enable the auto-assigner to correctly identify and assign new issues correctly and save extra triage time
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-01-12 14:14:45 UTC
Maintainer feedback?
Comment 4 bsd 2018-01-12 15:02:31 UTC
CopyQ is now at version 3.1.2 https://github.com/hluk/CopyQ/releases

I know that maintainers ought to be already informed about new versions. I did submit issue only because in the past a few maintainers confirmed they were appreciating being reminded on upgrades on this venue as well, which they felt proper.
Comment 5 Jason E. Hale freebsd_committer 2018-09-01 13:58:53 UTC
Created attachment 196762 [details]
Update deskutils/copyq to 3.5.0

Update deskutils/copyq to 3.5.0

This fixes the build for upcoming Qt 5.11

- Fix LICENSE
- Use CMake to build
- Install plugins and translations
Comment 6 Jason E. Hale freebsd_committer 2018-09-01 14:02:42 UTC
Build tests successful on FreeBSD 10.4-i386, FreeBSD 11.1-amd64, FreeBSD 12.0-ALPHA3-amd64.

Run tested on FreeBSD 12.0-ALPHA3
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2018-10-20 07:03:16 UTC
Comment on attachment 196762 [details]
Update deskutils/copyq to 3.5.0

Approved by: portmgr (maintainer timeout: > 1 month)
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2018-10-20 07:04:59 UTC
@Jason Feel free to self-assign yourself, the change is approved under maintainer timeout (obviously pending successful QA / confidence there)
Comment 9 Jason E. Hale freebsd_committer 2018-10-26 16:41:58 UTC
Take. Maintainer timeout. Lastest release is at 3.6.1; I will update it to that.
Comment 10 commit-hook freebsd_committer 2018-10-26 20:01:18 UTC
A commit references this bug:

Author: jhale
Date: Fri Oct 26 20:00:43 UTC 2018
New revision: 483047
URL: https://svnweb.freebsd.org/changeset/ports/483047

Log:
  deskutils/copyq: Update to 3.6.1

  - Switch to CMake build
  - Install data (themes, icons, translations) and optional plugins
  - Fix LICENSE and add LICENSE_FILE
  - Reset maintainer (no response for 15 months)

  PR:		221100
  Submitted by:	<bsd@bontempi.net> (update request); jhale (patch)
  Approved by:	maintainer timeout (15 months)

Changes:
  head/deskutils/copyq/Makefile
  head/deskutils/copyq/distinfo
  head/deskutils/copyq/files/
  head/deskutils/copyq/pkg-plist