Bug 221124 - FreeBSD11.1 + nvidia + libmap.conf~gcc crashes most apps
Summary: FreeBSD11.1 + nvidia + libmap.conf~gcc crashes most apps
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 11.1-RELEASE
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-31 14:35 UTC by Hannes Hauswedell
Modified: 2017-07-31 14:35 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hannes Hauswedell 2017-07-31 14:35:17 UTC
I use my workstation for software development and make use of the great weekly compiler snapshots of gcc and clang. To make the newer GCCs work out-of-the-box I have added to my /etc/libmap.conf:
libgcc_s.so.1   gcc8/libgcc_s.so.1
libgomp.so.1    gcc8/libgomp.so.1
libssp.so.0     gcc8/libssp.so.0
libstdc++.so.6  gcc8/libstdc++.so.6

This has always worked fine. But, after my first update to FreeBSD11.0, everything seemed broken, many apps (Firefox, gajim) immediately segfaulted, some after routine usage (most KDE apps). At the time a downgrade of the nvidia-driver to 340 solved these problems.

Now, after updating to 11.1 I was seeing them again, independent of the Nvidia-driver version. After some investigation, I found that this little test:
https://github.com/dumbbell/test-tls-initial-exec
already triggers the problem. It belongs to 
https://lists.freebsd.org/pipermail/freebsd-arch/2016-February/017699.html
so I suspect the whole thing is related to the parallel introduction of mesa-libs with the nvidia driver and some shared library magic breaking with newer GCC's standard library?

I can work around this for now, but it was  quite hard to actually pin this down to libmap.conf and I suspect it will cause issues in other situations, as well. 

Thanks for your help,
Hannes