Bug 221131 - [NEW PORT] x11/dsbautostart: Manage commands to be executed at X session start
Summary: [NEW PORT] x11/dsbautostart: Manage commands to be executed at X session start
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Richard Gallamore
URL: http://freeshell.de/~mk/projects/dsba...
Keywords: easy, feature
Depends on:
Blocks:
 
Reported: 2017-08-01 00:39 UTC by Marcel Kaiser
Modified: 2017-08-09 15:36 UTC (History)
1 user (show)

See Also:


Attachments
svn diff of the new port. (3.48 KB, patch)
2017-08-01 00:39 UTC, Marcel Kaiser
no flags Details | Diff
svn diff of the new port. (3.81 KB, patch)
2017-08-01 10:58 UTC, Marcel Kaiser
no flags Details | Diff
svn diff of the new port. (4.15 KB, patch)
2017-08-01 11:16 UTC, Marcel Kaiser
no flags Details | Diff
svn diff of the new port. (4.15 KB, patch)
2017-08-06 11:37 UTC, Marcel Kaiser
mk: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Kaiser 2017-08-01 00:39:17 UTC
Created attachment 184875 [details]
svn diff of the new port.

DSBAutostart is a Qt program that allows you to manage commands to be executed
at X session start.

WWW: http://freeshell.de/~mk/projects/dsbautostart.html
---

portlint: OK (looks fine.)
testport: OK (poudriere: 110Ramd64, 103Ri386)
Comment 1 Marcel Kaiser 2017-08-01 10:58:39 UTC
Created attachment 184895 [details]
svn diff of the new port.
Comment 2 Marcel Kaiser 2017-08-01 11:16:53 UTC
Created attachment 184897 [details]
svn diff of the new port.
Comment 3 Richard Gallamore freebsd_committer 2017-08-06 05:48:24 UTC
Hello Marcel, I built the port and started it in kde5 session on 12amd64 r321403. The window appears to be blank and unusable. When closing the window there is bus error core dump. Have you verified that the port works properly under releases?
Comment 4 Marcel Kaiser 2017-08-06 11:36:12 UTC
Hello Richard,

thanks a lot for the feedback! The problem was caused by a 'return' statement that I must have left there for testing purposes.

Sorry for the inconvenience.
Comment 5 Marcel Kaiser 2017-08-06 11:37:02 UTC
Created attachment 185086 [details]
svn diff of the new port.
Comment 6 Richard Gallamore freebsd_committer 2017-08-06 15:07:39 UTC
(In reply to Marcel Kaiser from comment #5)
Yeah, I figured it was something like that. Everything appears to work correctly except the save function. It seemingly does nothing.
Comment 7 Richard Gallamore freebsd_committer 2017-08-06 15:09:17 UTC
(In reply to Marcel Kaiser from comment #5)
Ah, nevermind it works. For some reason I was just expecting something along the lines of configuration saved.
Comment 8 commit-hook freebsd_committer 2017-08-09 00:46:52 UTC
A commit references this bug:

Author: ultima
Date: Wed Aug  9 00:46:32 UTC 2017
New revision: 447586
URL: https://svnweb.freebsd.org/changeset/ports/447586

Log:
  DSBAutostart is a Qt program that allows you to manage commands to be executed
  at X session start.

  WWW: http://freeshell.de/~mk/projects/dsbautostart.html

  PR:		221131
  Submitted by:	Marcel Kaiser (maintainer)
  Reviewed by:	matthew (mentor)
  Approved by:	matthew (mentor)
  Differential Revision:	https://reviews.freebsd.org/D11902

Changes:
  head/x11/Makefile
  head/x11/dsbautostart/
  head/x11/dsbautostart/Makefile
  head/x11/dsbautostart/distinfo
  head/x11/dsbautostart/pkg-descr
  head/x11/dsbautostart/pkg-message
  head/x11/dsbautostart/pkg-plist
Comment 9 Richard Gallamore freebsd_committer 2017-08-09 00:48:23 UTC
Committed, thanks!
Comment 10 Marcel Kaiser 2017-08-09 15:36:47 UTC
Thank you, Richard!