Bug 221204 - cad/openvsp: update to 3.13.1
Summary: cad/openvsp: update to 3.13.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jason E. Hale
URL: https://github.com/OpenVSP/OpenVSP/re...
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-03 16:34 UTC by Fernando Apesteguía
Modified: 2017-08-04 08:45 UTC (History)
1 user (show)

See Also:


Attachments
patch to the ports tree (5.61 KB, patch)
2017-08-03 16:34 UTC, Fernando Apesteguía
fernape: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fernando Apesteguía freebsd_committer 2017-08-03 16:34:39 UTC
Created attachment 185001 [details]
patch to the ports tree

The attached patch updates cad/openvsp to 3.13.1.

After some work together, ramcdona (upstream maintainer) managed to merge all of our patches so we now build clean!

From the announcement:

This release is all about bug fixes and cleanups related to the recent
VSPAERO updates and GUI improvements.  Most of these problems have been
encountered by users -- so update and don't have the problems.

Features:
 - Remove temp num points to 1 for VSPAERO calculations

Bug Fixes:
 - Correctly visualize control surface within VSPAERO
 - VSPAERO will read wings with any amount of subsurfaces correctly
 - Fix crash caused by out of bounds index for rotors in VSPAEROScreen
 - Fix build problems for FreeBSD
 - Fix case problems with #includes

Q/A:
 - portlint -AC: OK
 - poudriere builds for {10.3,11.0,11.1}{amd64,i386}: OK
Comment 1 commit-hook freebsd_committer 2017-08-04 08:45:13 UTC
A commit references this bug:

Author: jhale
Date: Fri Aug  4 08:44:57 UTC 2017
New revision: 447322
URL: https://svnweb.freebsd.org/changeset/ports/447322

Log:
  Update to 3.13.1

  PR:		221204
  Submitted by:	<fernando.apesteguia@gmail.com> (maintainer)

Changes:
  head/cad/openvsp/Makefile
  head/cad/openvsp/distinfo
  head/cad/openvsp/files/
Comment 2 Jason E. Hale freebsd_committer 2017-08-04 08:45:51 UTC
Committed, thanks!