Bug 221207 - graphics/cinepaint doesn't build with graphics/oyranos upgrade
Summary: graphics/cinepaint doesn't build with graphics/oyranos upgrade
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Boris Samorodov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-03 16:50 UTC by gja822
Modified: 2017-08-05 14:19 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gja822 2017-08-03 16:50:38 UTC
After upgrade of graphics/oyranos to version 0.9.6 graphics/cinepaint port stopped building (and working if built previously) if with option OYRANOS.

cinepaint requires liboyranos.so but new graphics/oyranos installs libOyranos.so, so cinepaint port tries to rebuild oyranos (obvuiously, with no luck). If I make a (bad idea) symlink from libOyranos.so to liboyranos.so, building of cinepaint stops due to change in oyranos API:

>cms.c:940:44: error: too few arguments to function call, expected 4, have 3
>      iccs = oyProfiles_ForStd( type, 0, 0 );
             ~~~~~~~~~~~~~~~~~             ^
So, now it's impossible to build cinepaint with oyranos support. (Not to mention vulnerabilities in current port's cinepaint.)
Comment 1 Boris Samorodov freebsd_committer 2017-08-03 17:57:17 UTC
The original application seems to be an abandonware (last release was more than 4 years ago, stale links at the website, no public repository, etc).

Our port has no maintainer. Seems that I should mark it BROKEN with option OYRANOS.

If you are in a deadly need of the port to work with oyranos you have some options:
. fix it;
. use old package/version (of oyranos);
. create a port of the needed version of oyranos.
Comment 2 gja822 2017-08-03 18:23:02 UTC
Thank you for the reply. Looks reasonable. For now I could live without oyranos in cinepaint.

(All I need is a support for more than 8-bit channel depths in pictures and support for DICOM format (used in tomorgaphs for example) and optional ICC profiles support. And cinepaint was the first (and the only known by me for now) that I've found.)
Comment 3 commit-hook freebsd_committer 2017-08-05 14:15:22 UTC
A commit references this bug:

Author: bsam
Date: Sat Aug  5 14:14:46 UTC 2017
New revision: 447404
URL: https://svnweb.freebsd.org/changeset/ports/447404

Log:
  graphics/cinepaint: Fix build with Oyranos-0.9.6.

  The port seems to have some unique properties but was broken by my   [1]
  recent Oyranos update.

  . fix build with oyranos-0.9.6, idea from
      https://gitlab.com/beku/cinepaint-ng;
  . QA: add dependencies.

  PR:		221207  [1]
  Reported by:	gja822@narod.ru

Changes:
  head/graphics/cinepaint/Makefile
  head/graphics/cinepaint/files/patch-app__cms.c
  head/graphics/cinepaint/files/patch-app__main.c
Comment 4 Boris Samorodov freebsd_committer 2017-08-05 14:19:07 UTC
So, I went ahead and find some ideas at https://gitlab.com/beku/cinepaint-ng.
The port is fixed for now (it builds with oyranos-0.9.6).

Thanks for the report!