Bug 221278 (plasma5-import) - [exp-run] Import KDE Plasma5 ports
Summary: [exp-run] Import KDE Plasma5 ports
Status: Closed FIXED
Alias: plasma5-import
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL: https://reviews.freebsd.org/D11874
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-06 13:08 UTC by Tobias C. Berner
Modified: 2018-05-25 22:34 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias C. Berner freebsd_committer 2017-08-06 13:08:08 UTC
Hi

kde@ would like to ask for an exp-run for the import of the Plasma5 ports.

The patch is attached, and can also be found here:
http://people.freebsd.org/~tcberner/patches/plasma5.v1.diff


mfg Tobias
Comment 1 Tobias C. Berner freebsd_committer 2017-08-06 13:09:29 UTC
Patch is too large to attach, sorry.
Comment 2 Tobias C. Berner freebsd_committer 2017-08-06 14:20:31 UTC
New version:
http://people.freebsd.org/~tcberner/patches/plasma5.v2.diff
(fixes kate and okular component)
Comment 3 Antoine Brodin freebsd_committer 2017-08-08 07:20:27 UTC
On 11.0 i386 there is 1 new failure:

http://package18.nyi.freebsd.org/data/110i386-default-PR221278/2017-08-07_19h09m13s/logs/plasma5-khotkeys-5.10.4.log

3 ports are skipped due to this failure.


finance/skrooge is ignored:  cannot be installed: unknown USE_KDE component 'attica5'
Comment 4 Tobias C. Berner freebsd_committer 2017-08-08 17:26:51 UTC
This
http://people.freebsd.org/~tcberner/patches/plasma5.v4.diff
fixes finance/skrooge. 

I could not reproduce the issue in plasma5-khotkeys.
Comment 5 Antoine Brodin freebsd_committer 2017-08-09 05:38:20 UTC
The devel/plasma5-khotkeys failure is reproducible here.
Comment 6 Tobias C. Berner freebsd_committer 2017-08-09 06:07:09 UTC
Does it succeed on amd64, and only fail on i386?
Comment 8 Antoine Brodin freebsd_committer 2017-08-12 06:00:55 UTC
On amd64 there is no new failure.
Comment 9 Tobias C. Berner freebsd_committer 2018-05-25 22:34:14 UTC
Thanks for the exp-run, this has landed now in some other version.