Bug 221280 - devel/p5-ExtUtils-ParseXS: update 3.24 -> 3.35 to fix depend for devel/p5-Params-Classify
Summary: devel/p5-ExtUtils-ParseXS: update 3.24 -> 3.35 to fix depend for devel/p5-Par...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Sivachenko
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-08-06 13:44 UTC by Laurence 'GreenReaper' Parry
Modified: 2017-08-07 07:33 UTC (History)
4 users (show)

See Also:
koobs: maintainer-feedback? (perl)


Attachments
Failed build log showing attempt to upgrade port (6.11 KB, text/plain)
2017-08-06 13:44 UTC, Laurence 'GreenReaper' Parry
no flags Details
update-to-3.35 (1005 bytes, patch)
2017-08-06 14:19 UTC, Kurt Jaeger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Laurence 'GreenReaper' Parry 2017-08-06 13:44:59 UTC
Created attachment 185090 [details]
Failed build log showing attempt to upgrade port

When attempting to upgrade from p5-Params-Classify 0.014 to 0.015 via portupgrade I found that the port depended on p5-ExtUtils-ParseXS>=3.30

The script attempts to obtain and install the latest p5-ExtUtils-ParseXS, but this is version 3.24_1. Installation fails as p5-ExtUtils-ParseXS-3.24_1 is already installed.

Probably p5-ExtUtils-ParseXS needs to be upgraded in ports. 3.24 was released 7 Mar 2014, 3.30 on 31 Aug 2015, and 3.35 on 31 Jul 2017:
http://search.cpan.org/dist/ExtUtils-ParseXS/
Comment 1 Kurt Jaeger freebsd_committer 2017-08-06 14:19:31 UTC
Created attachment 185091 [details]
update-to-3.35

Update for devel/p5-ExtUtils-ParseXS, builds fine on 12, 11, 10.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2017-08-06 14:51:07 UTC
cc committer of ports r446918
Comment 3 commit-hook freebsd_committer 2017-08-06 15:06:10 UTC
A commit references this bug:

Author: demon
Date: Sun Aug  6 15:05:30 UTC 2017
New revision: 447468
URL: https://svnweb.freebsd.org/changeset/ports/447468

Log:
  Update to version 3.35.

  PR:		221280
  Submitted by:	Laurence 'GreenReaper' Parry <greenreaper@hotmail.com>

Changes:
  head/devel/p5-ExtUtils-ParseXS/Makefile
  head/devel/p5-ExtUtils-ParseXS/distinfo
Comment 4 Dmitry Sivachenko freebsd_committer 2017-08-06 15:07:24 UTC
Port updated, thanks!

PS: I did not add LICENCE here because I found no mention about it in distro files and
also at project's web page (http://search.cpan.org/dist/ExtUtils-ParseXS/).
Comment 5 Kurt Jaeger freebsd_committer 2017-08-06 15:33:07 UTC
(In reply to Dmitry Sivachenko from comment #4)

work/ExtUtils-ParseXS-3.35/README

says:

    This library is free software; you can redistribute it and/or modify it
    under the same terms as Perl itself.
Comment 6 commit-hook freebsd_committer 2017-08-07 07:33:09 UTC
A commit references this bug:

Author: demon
Date: Mon Aug  7 07:32:55 UTC 2017
New revision: 447484
URL: https://svnweb.freebsd.org/changeset/ports/447484

Log:
  Add LICENCE as mentioned in README.

  PR:		221280
  Reported by:	pi

Changes:
  head/devel/p5-ExtUtils-ParseXS/Makefile
Comment 7 Dmitry Sivachenko freebsd_committer 2017-08-07 07:33:26 UTC
Ah, Okay.