Bug 221295 - D945GCLF2 needs GPT+Active
Summary: D945GCLF2 needs GPT+Active
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 11.1-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Mark Linimon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-07 00:42 UTC by steven_nikkel
Modified: 2017-08-07 19:02 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steven_nikkel 2017-08-07 00:42:37 UTC
Just did a fresh install of 11.1, afterwards system wouldn't find a bootable disk. Found mention of similar issue in 11.0 errata. Applied 'gpart set -a active ada0' and voila, system would boot from disk. Looks like I have yet another example of a system that needs the fix.

# kenv -q smbios.planar.maker
Intel Corporation
# kenv -q smbios.planar.product
D945GCLF2
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2017-08-07 03:33:07 UTC
I am unable to find the similar reference in the 11.X errata.  Can you please point me to that document?  Thanks.
Comment 2 ertyu 2017-08-07 03:57:29 UTC
https://www.freebsd.org/releases/11.0R/errata.html

[2016-10-20] Several recent Dell systems fail to find a bootable disk when the system boots in Legacy/BIOS/CSM mode, the boot disk is partitioned with GPT, and the Active flag in the Protective MBR is not set. To work around this issue, either configure the system to boot in UEFI mode, or choose the "GPT + Active" scheme. [r293860]

https://svnweb.freebsd.org/base?view=revision&revision=293860