Bug 221327 - [NEW PORT] audio/qmidiarp: MIDI arpeggiator, sequencer and LFO for JACK
Summary: [NEW PORT] audio/qmidiarp: MIDI arpeggiator, sequencer and LFO for JACK
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Richard Gallamore
URL:
Keywords: feature
Depends on:
Blocks:
 
Reported: 2017-08-08 06:55 UTC by Yuri Victorovich
Modified: 2017-08-17 20:08 UTC (History)
1 user (show)

See Also:


Attachments
shar (4.30 KB, text/plain)
2017-08-08 06:55 UTC, Yuri Victorovich
no flags Details
shar archive (4.28 KB, text/plain)
2017-08-08 11:05 UTC, Yuri Victorovich
no flags Details
shar archive (4.28 KB, text/plain)
2017-08-14 20:02 UTC, Yuri Victorovich
no flags Details
shar archive (4.27 KB, text/plain)
2017-08-15 03:20 UTC, Yuri Victorovich
no flags Details
shar archive (4.29 KB, text/plain)
2017-08-15 04:49 UTC, Yuri Victorovich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2017-08-08 06:55:59 UTC
Created attachment 185144 [details]
shar

QAs:
* poudriere 11.1 amd64
* portlint
* runs fine
Comment 1 Yuri Victorovich freebsd_committer 2017-08-08 11:05:28 UTC
Created attachment 185148 [details]
shar archive
Comment 2 Richard Gallamore freebsd_committer 2017-08-14 18:09:53 UTC
There are some warnings about at the end of configure, Can you please check them out?

configure: WARNING: unrecognized options: --with-qt-includes, --with-qt-libraries, --with-extra-includes, --with-extra-libs

Will use the following QT libs: -L/usr/local/lib/qt5 -lQt5Widgets -lQt5Gui -lQt5Core

Translation file generation enabled.
sed: 1: "qmidiarp_arp.lv2/qmidia ...": extra characters at the end of q command
sed: 1: "qmidiarp_lfo.lv2/qmidia ...": extra characters at the end of q command
sed: 1: "qmidiarp_seq.lv2/qmidia ...": extra characters at the end of q command


Also please strip the libs.

====> Running Q/A tests (stage-qa)
Warning: 'lib/lv2/qmidiarp_lfo.lv2/qmidiarp_lfo_ui.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/lv2/qmidiarp_lfo.lv2/qmidiarp_lfo.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/lv2/qmidiarp_seq.lv2/qmidiarp_seq.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/lv2/qmidiarp_seq.lv2/qmidiarp_seq_ui.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/lv2/qmidiarp_arp.lv2/qmidiarp_arp.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/lv2/qmidiarp_arp.lv2/qmidiarp_arp_ui.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Comment 3 Yuri Victorovich freebsd_committer 2017-08-14 20:02:01 UTC
Created attachment 185415 [details]
shar archive

> unstripped libs ...

I can't reproduce it. Updated shar in case I fixed this before and the shar was old.

> configure warnings about qt-includes, etc

These are supplied by USE_QT. They are normally recognized, but they are no harm as long as libs are found ok.
Comment 4 Yuri Victorovich freebsd_committer 2017-08-14 20:08:40 UTC
sed commands warnings:
I will let the dev know. They are likely BSD vs. Linux problems.
For now - just commit as is please.
Comment 5 Yuri Victorovich freebsd_committer 2017-08-14 20:17:52 UTC
https://github.com/emuse/qmidiarp/issues/1
Comment 6 Richard Gallamore freebsd_committer 2017-08-14 21:02:38 UTC
There are two changes needed before it is able to commit,

* There are two WWW: in the pkg-descr and should only have one.
* This port is not make job safe. Please add MAKE_JOBS_UNSAFE= yes. This is probably a problem that upstream needs to fix as well.
Comment 7 Yuri Victorovich freebsd_committer 2017-08-15 03:20:07 UTC
Created attachment 185424 [details]
shar archive

Fixed double WWW.

I can't reproduce build multi-cpu build unsafety. Don't see any evidence.

What evidence do you see?

If you are positive this is the case - then just add that statement. But I rebuilt it 10 times and it finished fine. Even setting MAKE_JOBS_NUMBER=100 doesn't break it.
Comment 9 Yuri Victorovich freebsd_committer 2017-08-15 04:49:40 UTC
Created attachment 185427 [details]
shar archive

Added MAKE_JOBS_UNSAFE=yes.

What does `sysctl hw.model` print on your poudriere server?
Comment 10 Richard Gallamore freebsd_committer 2017-08-15 05:36:08 UTC
(In reply to Yuri Victorovich from comment #9)
They are E5-2698V4x2.

Thanks, looks good. Can hopefully get to the rest of your new ports this week but, well... 82 bugs new/open with activity in the past week and 45 are new ports. Wonder how many are yours, looks like more than half so that maybe doubtful. Thanks for all your contributions. You are doing a great!
Comment 11 Yuri Victorovich freebsd_committer 2017-08-15 05:54:53 UTC
(In reply to Richard Gallamore from comment #10)

Thanks!

I decided to bring the FreeBSD audio support up to speed, and learn few more things myself.

Thank you for committing them!
Yuri
Comment 12 Richard Gallamore freebsd_committer 2017-08-15 06:59:18 UTC
One thing that needs to be changed that I keep forgetting. When using GH_TAGNAME and having normal version releases, the proper way to determine the version is,

git describe --tags $GH_TAGNAME,

in this case the output is qmidiarp-0.6.4-26-g1a15c13. We need to add -26 to DISTVERSIONSUFFIX. I already added it, just letting you know for future. Also, because port is using DISTVERSIONPREFIX/SUFFIX it would be best to just use DISTVERSION for the port version.

You don't need to fix, already added and ready for commit.
Comment 13 Yuri Victorovich freebsd_committer 2017-08-15 07:03:25 UTC
(In reply to Richard Gallamore from comment #12)

Ok!
Comment 14 commit-hook freebsd_committer 2017-08-17 20:01:34 UTC
A commit references this bug:

Author: ultima
Date: Thu Aug 17 20:00:47 UTC 2017
New revision: 448187
URL: https://svnweb.freebsd.org/changeset/ports/448187

Log:
  QMidiArp is an advanced MIDI arpeggiator, programmable step sequencer and LFO.
  It can hold any number of arpeggiator, sequencer, or LFO modules running in
  parallel.

  Arpeggiator modules produce sequences depending on the notes sent to their input
  port, which is typically connected to a keyboard or another sequencer.

  Step sequencer modules allow you to create simple linear, monophonic and
  globally transposable sequences similar to the first analog sequencers.

  MIDI LFO modules independently produce MIDI controller data of adjustable
  waveform, time resolution, amplitude and duration.

  A Global Storage Tool can store different setups and switch between them at a
  given time. It allows you to dynamically combine patterns and LFO wave forms.

  WWW: http://qmidiarp.sourceforge.net/

  PR:		221327
  Submitted by:	Yuri Victorovich (maintainer)
  Reviewed by:	matthew (mentor), mat
  Approved by:	matthew (mentor)
  Differential Revision:	https://reviews.freebsd.org/D12033

Changes:
  head/audio/Makefile
  head/audio/qmidiarp/
  head/audio/qmidiarp/Makefile
  head/audio/qmidiarp/distinfo
  head/audio/qmidiarp/pkg-descr
  head/audio/qmidiarp/pkg-plist
Comment 15 Richard Gallamore freebsd_committer 2017-08-17 20:08:07 UTC
Committed, thanks!