Bug 221334 - graphics/gdal: fix include-file so that gmt builds again
Summary: graphics/gdal: fix include-file so that gmt builds again
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-08 12:44 UTC by Kurt Jaeger
Modified: 2017-08-19 14:40 UTC (History)
1 user (show)

See Also:
sunpoet: maintainer-feedback-


Attachments
patch (1.14 KB, patch)
2017-08-08 12:44 UTC, Kurt Jaeger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Jaeger freebsd_committer 2017-08-08 12:44:00 UTC
Created attachment 185153 [details]
patch

patch fixes the build error for graphics/gmt
Comment 1 Kurt Jaeger freebsd_committer 2017-08-09 03:40:15 UTC
Btw, testbuilds on 12a, 11a, 10i are fine.
Comment 2 Sunpoet Po-Chuan Hsieh freebsd_committer 2017-08-19 04:48:24 UTC
It was caused by the following snippets in gmt.

#ifdef __FreeBSD__
#define _XOPEN_SOURCE
#else
#define _XOPEN_SOURCE 600
#endif
Comment 3 commit-hook freebsd_committer 2017-08-19 04:49:55 UTC
A commit references this bug:

Author: sunpoet
Date: Sat Aug 19 04:49:29 UTC 2017
New revision: 448283
URL: https://svnweb.freebsd.org/changeset/ports/448283

Log:
  Unbreak this port

  PR:		221334
  Reported by:	pi
  MFH:		2017Q3

Changes:
  head/graphics/gmt/Makefile
  head/graphics/gmt/files/patch-src-gmt_io.c
  head/graphics/gmt/files/patch-src-gmtmath.c
  head/graphics/gmt/files/patch-src-grdmath.c
  head/graphics/gmt/files/patch-src-misc-gmtdigitize.c
Comment 4 Sunpoet Po-Chuan Hsieh freebsd_committer 2017-08-19 06:14:25 UTC
I changed maintainer-feedback to - because the original patch to gdal is not accepted. I fixed wrong #define in gmt.
Comment 5 commit-hook freebsd_committer 2017-08-19 14:40:04 UTC
A commit references this bug:

Author: sunpoet
Date: Sat Aug 19 14:39:03 UTC 2017
New revision: 448315
URL: https://svnweb.freebsd.org/changeset/ports/448315

Log:
  MFH: r448283

  Unbreak this port

  PR:		221334
  Reported by:	pi

  Approved by:	ports-secteam (blanket)

Changes:
_U  branches/2017Q3/
  branches/2017Q3/graphics/gmt/Makefile
  branches/2017Q3/graphics/gmt/files/patch-src-gmt_io.c
  branches/2017Q3/graphics/gmt/files/patch-src-gmtmath.c
  branches/2017Q3/graphics/gmt/files/patch-src-grdmath.c
  branches/2017Q3/graphics/gmt/files/patch-src-misc-gmtdigitize.c