Bug 221374 - shells/mksh: Update to R56
Summary: shells/mksh: Update to R56
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: patch-ready
: 221383 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-09 17:12 UTC by Olivier Duchateau
Modified: 2017-08-22 17:43 UTC (History)
3 users (show)

See Also:
schaiba: maintainer-feedback+


Attachments
Patch to update shells/mksh (783 bytes, patch)
2017-08-09 17:12 UTC, Olivier Duchateau
no flags Details | Diff
distinfo diff for upgrading to R56 (424 bytes, patch)
2017-08-10 07:35 UTC, schaiba
no flags Details | Diff
Makefile diff for upgrading to R56 (900 bytes, patch)
2017-08-10 07:36 UTC, schaiba
no flags Details | Diff
mksh R56_combined.diff (1.25 KB, patch)
2017-08-15 07:41 UTC, schaiba
schaiba: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Duchateau 2017-08-09 17:12:07 UTC
Created attachment 185209 [details]
Patch to update shells/mksh

Update to R56
Comment 1 schaiba 2017-08-10 06:18:14 UTC
I'll get on it.
Comment 2 schaiba 2017-08-10 07:35:25 UTC
Created attachment 185219 [details]
distinfo diff for upgrading to R56
Comment 3 schaiba 2017-08-10 07:36:06 UTC
Created attachment 185220 [details]
Makefile diff for upgrading to R56
Comment 4 Olivier Duchateau 2017-08-10 13:47:25 UTC
Why do you split diff? SVN is able to provide complete diff.

I do not agree about LICENSE macro. BSD3CLAUSE is required (see Appendix B). Moreover the Public Domain license is needed see paragraph on the public domain bourne shell (pdsh).
Comment 5 Olivier Duchateau 2017-08-10 13:50:49 UTC
Add Dmitry (amdmi3@) for review about license block (he made several changes in Mk/bsd.licenses.db in the past).
Comment 6 schaiba 2017-08-10 14:32:56 UTC
(In reply to Olivier Duchateau from comment #4)
The removal of those licenses comes from a talk I had with Thorsten (mksh author) this morning. He suggested said removal.
Comment 7 Olivier Duchateau 2017-08-10 19:14:17 UTC
(In reply to schaiba from comment #6)

I'm ok about licenses.

But I wonder why you have create new bug #221383 report about this update whereas you have been informed. It's more simple to comment or propose new diff.
Comment 8 schaiba 2017-08-11 06:03:24 UTC
(In reply to Olivier Duchateau from comment #7)
Got it, I'll keep that in mind. Thanks.
Comment 9 Richard Gallamore freebsd_committer 2017-08-15 02:12:47 UTC
*** Bug 221383 has been marked as a duplicate of this bug. ***
Comment 10 Richard Gallamore freebsd_committer 2017-08-15 02:16:26 UTC
Can you please combined these into a single diff? I usually use diff -ruNp when generating one not under version control.

Also, please obsolete the files that are old and approve the patch that is requested to be committed.
Comment 11 schaiba 2017-08-15 07:41:18 UTC
Created attachment 185431 [details]
mksh R56_combined.diff
Comment 12 commit-hook freebsd_committer 2017-08-17 17:14:35 UTC
A commit references this bug:

Author: swills
Date: Thu Aug 17 17:13:55 UTC 2017
New revision: 448156
URL: https://svnweb.freebsd.org/changeset/ports/448156

Log:
  shells/mksh: Update to R56

  PR:		221374
  Submitted by:	Olivier Duchateau <duchateau.olivier@gmail.com>
  Approved by:	schaiba@gmail.com (maintainer)

Changes:
  head/shells/mksh/Makefile
  head/shells/mksh/distinfo
Comment 13 Steve Wills freebsd_committer 2017-08-17 17:17:23 UTC
Committed, thanks!
Comment 14 Dmitry Marakasov freebsd_committer 2017-08-22 17:42:28 UTC
Sorry, I was on a vacation. Though license changes here look good, using _LICENSE_LIST_PERMS is completely broken. You've probably meant to use _LICENSE_PERMS_DEFAULT, though it's still better to list permissions explicitly. Fixing this.
Comment 15 commit-hook freebsd_committer 2017-08-22 17:43:25 UTC
A commit references this bug:

Author: amdmi3
Date: Tue Aug 22 17:42:40 UTC 2017
New revision: 448574
URL: https://svnweb.freebsd.org/changeset/ports/448574

Log:
  - Fix LICENSE_PERMS

  PR:		221374
  Approved by:	portmgr blanket

Changes:
  head/shells/mksh/Makefile