Bug 221395 - www/luakit: Update to latest version (Version-2017.08.10)
Summary: www/luakit: Update to latest version (Version-2017.08.10)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jochen Neumeister
URL:
Keywords:
: 221549 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-10 17:33 UTC by Stefan Hagen
Modified: 2017-08-19 09:27 UTC (History)
2 users (show)

See Also:


Attachments
www/luakit version update diff (4.69 KB, patch)
2017-08-10 17:33 UTC, Stefan Hagen
no flags Details | Diff
updated www/luakit diff (4.45 KB, patch)
2017-08-10 18:07 UTC, Stefan Hagen
no flags Details | Diff
updated www/luakit diff - without portrevision (4.43 KB, patch)
2017-08-11 15:17 UTC, Stefan Hagen
no flags Details | Diff
luakit 2017.08.10 r1 (1.53 KB, patch)
2017-08-16 08:26 UTC, Stefan Hagen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Hagen 2017-08-10 17:33:17 UTC
Created attachment 185238 [details]
www/luakit version update diff

Update for www/luakit

Port changes:
  - Version update to 2017.08.10
  - Needs webkit2 >= 2.16 now
  - Cosmetic changes

Luakit changes:
  - https://github.com/luakit/luakit/blob/develop/CHANGELOG.md

Diff for www/luakit attached.

Thanks!
Comment 1 Bugzilla Automation freebsd_committer 2017-08-10 17:33:17 UTC
Maintainer informed via mail
Comment 2 Stefan Hagen 2017-08-10 18:07:49 UTC
Created attachment 185239 [details]
updated www/luakit diff

I have updated the diff again. The webkit >=2.16 specification made the port compile it instead of taking the package.
Comment 3 Jochen Neumeister freebsd_committer 2017-08-11 08:22:33 UTC
Hey Stefan :-)

Why this:

-PORTVERSION=	2017.07.26
+PORTVERSION=	2017.08.10
+PORTREVISION=	2

When you dump PORTVERSION, there is no reason for PORTREVISION
Comment 4 Stefan Hagen 2017-08-11 15:17:15 UTC
Created attachment 185292 [details]
updated www/luakit diff - without portrevision
Comment 5 Stefan Hagen 2017-08-11 15:18:04 UTC
Hi Jochen,

I've bumped the portrevision between the first and the updated diff in this report. Just in case the first diff was committed already.

I've added a diff without port revision.
Comment 6 Jochen Neumeister freebsd_committer 2017-08-15 14:21:51 UTC
Committed, thanks :-)
Comment 7 commit-hook freebsd_committer 2017-08-15 14:22:22 UTC
A commit references this bug:

Author: joneum
Date: Tue Aug 15 14:21:36 UTC 2017
New revision: 447986
URL: https://svnweb.freebsd.org/changeset/ports/447986

Log:
  - www/luakit: Update from 2017.07.26 to 2017.08.10
  - Changelog: https://github.com/luakit/luakit/blob/develop/CHANGELOG.md

  PR:		221395
  Submitted by:	Stefan Hagen <freebsd-bugzilla@textmail.me> (maintainer)
  Approved by:	miwi (mentor)
  Differential Revision:	https://reviews.freebsd.org/D11983

Changes:
  head/www/luakit/Makefile
  head/www/luakit/distinfo
  head/www/luakit/pkg-plist
Comment 8 Stefan Hagen 2017-08-16 07:15:58 UTC
Hi Jochen,

In the commit I see the line:
"/you/have/to/check/what/makeplist/gives/you" in the plist file.

Could you please check this?

Best Regards,
Stefan
Comment 9 Stefan Hagen 2017-08-16 08:26:50 UTC
Created attachment 185476 [details]
luakit 2017.08.10 r1

I've uploaded a new diff based on the current SVN HEAD tree that contains the last commit already. So you can just add it on top to correct the plist file.

It also contains the NOT_FOR_ARCH_REASON fix and the $(PREFIX) -> ${PREFIX} fix.

I've added PORTREVISION= 1
Comment 10 commit-hook freebsd_committer 2017-08-19 09:26:36 UTC
A commit references this bug:

Author: joneum
Date: Sat Aug 19 09:25:31 UTC 2017
New revision: 448292
URL: https://svnweb.freebsd.org/changeset/ports/448292

Log:
  - fix pkg-plist
  - pet portlint

  PR:		221395
  Submitted by:	Stefan Hagen <freebsd-bugzilla@textmail.me> (maintainer)
  Approved by:	miwi (mentor)
  Differential Revision:	https://reviews.freebsd.org/D12049

Changes:
  head/www/luakit/Makefile
  head/www/luakit/distinfo
  head/www/luakit/pkg-plist
Comment 11 Jochen Neumeister freebsd_committer 2017-08-19 09:27:37 UTC
*** Bug 221549 has been marked as a duplicate of this bug. ***