Bug 221492 - Creating stf interface as "stf" causes kernel panic
Summary: Creating stf interface as "stf" causes kernel panic
Status: Closed DUPLICATE of bug 218895
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.1-RELEASE
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-net (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-13 21:19 UTC by Richard Gallamore
Modified: 2017-08-15 21:37 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Gallamore freebsd_committer 2017-08-13 21:19:13 UTC
This is easily reproducible and have triggered it on two 11.1-RELEASE boxes.


ifconfig stf create --> kernel panic.

Adding a number to stf, eg stf0 or stf1 the interface is created as expected. This is a bug that should be fixed, but probably doesn't affect majority of users.

Also tested on head r321403 and appears to be fixed.
Comment 1 Kristof Provost freebsd_committer 2017-08-14 08:14:24 UTC
Do you have pf loaded? If so, this is a duplicate of #218895.

pf gets confused and upset if there are ifgroups with the same name as an ifnet.
Comment 2 Richard Gallamore freebsd_committer 2017-08-15 21:37:58 UTC
That is the issue, thanks.

*** This bug has been marked as a duplicate of bug 218895 ***