Bug 221529 - Intel i218 VLAN slowness and hang
Summary: Intel i218 VLAN slowness and hang
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: Sean Bruno
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2017-08-14 17:59 UTC by Steve Wills
Modified: 2017-12-30 18:25 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2017-08-14 17:59:33 UTC
Following the docs on creating VLANs on an Intel i218 NIC:

https://www.freebsd.org/doc/handbook/network-vlan.html

(with different IP addresses) produces a very slow network on both the non-VLAN and VLAN interfaces. Trying to then destroy the VLAN interface then results in ifconfig and the non-VLAN network interface hanging.

Details on the NIC in question:

em0@pci0:0:25:0:        class=0x020000 card=0x85c41043 chip=0x15a18086 rev=0x05 hdr=0x00                                                                                                          
    vendor     = 'Intel Corporation'                                                                                                                                                              
    device     = 'Ethernet Connection (2) I218-V'                                                
    class      = network                                                                                                                                                                          
    subclass   = ethernet                                                                        
    bar   [10] = type Memory, range 32, base rxfbf00000, size 131072, enabled                                                                                                                     
    bar   [14] = type Memory, range 32, base rxfbf22000, size 4096, enabled                      
    bar   [18] = type I/O Port, range 32, base rxf000, size 32, enabled                          
    cap 01[c8] = powerspec 2  supports D0 D3  current D0                                         
    cap 05[d0] = MSI supports 1 message, 64 bit enabled with 1 message                           
cap 13[e0] = PCI Advanced Features: FLR TP
Comment 1 Sean Bruno freebsd_committer 2017-11-03 23:00:13 UTC
Steve:

Was this on FreeBSD Head?  Or a stable release?
Comment 2 Steve Wills freebsd_committer 2017-12-30 18:25:59 UTC
(In reply to Sean Bruno from comment #1)
It was HEAD, but I'm unable to reproduce now, could have been fixed or been a local issue. Thanks for checking, I'll let you know if it occurs again.