Bug 221670 - textproc/qt5-xmlpatterns: build fails on 11.1
Summary: textproc/qt5-xmlpatterns: build fails on 11.1
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-20 15:44 UTC by Igor Pavlov
Modified: 2017-08-21 08:58 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments
Full build log (12.08 KB, application/zip)
2017-08-20 15:44 UTC, Igor Pavlov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Pavlov 2017-08-20 15:44:28 UTC
Created attachment 185606 [details]
Full build log

[textproc/qt5-xmlpatterns]# script build.log make install

...

c++ -Wl,--as-needed -fstack-protector -Wl,--gc-sections -Wl,--enable-new-dtags -pthread -Wl,-rpath,/usr/local/lib/qt5 -o ../../bin/xmlpatternsvalidator .obj/main.o   -L/usr/ports/textproc/qt5-xmlpatterns/work/qtxmlpatterns-opensource-src-5.7.1/lib -L/usr/local/lib -lQt5XmlPatterns -L/usr/local/lib/qt5 -lQt5Network -lQt5Core
/usr/local/lib/libQt5Network.so: undefined reference to `qIsEffectiveTLD(QString const&)@Qt_5'
/usr/local/lib/libQt5Network.so: undefined reference to `qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*)@Qt_5'
c++: error: linker command failed with exit code 1 (use -v to see invocation)
*** [../../bin/xmlpatternsvalidator] Error code 1

make[3]: stopped in /usr/ports/textproc/qt5-xmlpatterns/work/qtxmlpatterns-opensource-src-5.7.1/tools/xmlpatternsvalidator
1 error

make[3]: stopped in /usr/ports/textproc/qt5-xmlpatterns/work/qtxmlpatterns-opensource-src-5.7.1/tools/xmlpatternsvalidator
*** [sub-xmlpatternsvalidator-all] Error code 2

make[2]: stopped in /usr/ports/textproc/qt5-xmlpatterns/work/qtxmlpatterns-opensource-src-5.7.1/tools
--- sub-xmlpatterns-all ---
A failure has been detected in another branch of the parallel make

make[3]: stopped in /usr/ports/textproc/qt5-xmlpatterns/work/qtxmlpatterns-opensource-src-5.7.1/tools/xmlpatterns
*** [sub-xmlpatterns-all] Error code 2

make[2]: stopped in /usr/ports/textproc/qt5-xmlpatterns/work/qtxmlpatterns-opensource-src-5.7.1/tools
2 errors

make[2]: stopped in /usr/ports/textproc/qt5-xmlpatterns/work/qtxmlpatterns-opensource-src-5.7.1/tools
*** [sub-tools-all] Error code 2

make[1]: stopped in /usr/ports/textproc/qt5-xmlpatterns/work/qtxmlpatterns-opensource-src-5.7.1
1 error

make[1]: stopped in /usr/ports/textproc/qt5-xmlpatterns/work/qtxmlpatterns-opensource-src-5.7.1
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/textproc/qt5-xmlpatterns
Comment 1 Tobias C. Berner freebsd_committer 2017-08-20 16:24:53 UTC
Hi there

Are your ports up to date -- what FreeBSD version are you using?

mfg Tobias
Comment 2 Tobias C. Berner freebsd_committer 2017-08-20 16:26:01 UTC
äh, right, I should read the title :)
Comment 3 Igor Pavlov 2017-08-20 16:27:55 UTC
All ports are up to date. I've just updated to the 11.1 and I'm trying to rebuild ports.
Comment 4 Tobias C. Berner freebsd_committer 2017-08-20 16:48:05 UTC
I cannot reproduce this here. Can you try to rebuild&reinstall net/qt5-network and try again?

mfg Tobias
Comment 5 Igor Pavlov 2017-08-20 16:54:32 UTC
I've already tried to rebuild net/qt5-network, it has been build successfully, but it doesn't help with the textproc/qt5-xmlpatterns issue.
Comment 6 Igor Pavlov 2017-08-20 17:12:00 UTC
I've found the problem. There were links to the old libQt5Network in the /usr/local/lib/:

/usr/local/lib/libQt5Network.prl
/usr/local/lib/libQt5Network.so -> libQt5Network.so.5.6.2
/usr/local/lib/libQt5Network.so.5 -> libQt5Network.so.5.6.2
/usr/local/lib/libQt5Network.so.5.6 -> libQt5Network.so.5.6.2
/usr/local/lib/libQt5Network.so.5.6.2

I've deleted them and it helped to build qt5-xmlpatterns successfully.

To prevent such an issue in future I think the following link option should be swapped with each other:

-L/usr/local/lib -L/usr/local/lib/qt5

should be:

-L/usr/local/lib/qt5 -L/usr/local/lib
Comment 7 Tobias C. Berner freebsd_committer 2017-08-21 08:58:21 UTC
In that case something went wrong with your upgrade to Qt-5.7.


mfg Tobias