Bug 221718 - net/megatools: use secure master site, change run_depends
Summary: net/megatools: use secure master site, change run_depends
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-22 16:23 UTC by Johannes Jost Meixner
Modified: 2017-08-23 17:13 UTC (History)
1 user (show)

See Also:
max: maintainer-feedback+


Attachments
megatools 1.9.98_1 (681 bytes, text/plain)
2017-08-22 16:23 UTC, Johannes Jost Meixner
no flags Details
buildlog (31.02 KB, text/x-log)
2017-08-22 16:23 UTC, Johannes Jost Meixner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Jost Meixner freebsd_committer 2017-08-22 16:23:21 UTC
Created attachment 185666 [details]
megatools 1.9.98_1

- Use HTTPS in MASTER_SITES
- Drop glib-networking dependency, it has become unnecessary upstream
Comment 1 Johannes Jost Meixner freebsd_committer 2017-08-22 16:23:49 UTC
Created attachment 185667 [details]
buildlog
Comment 2 Max Kostikov 2017-08-22 16:45:50 UTC
I have no objections.
Thank you!
Comment 3 commit-hook freebsd_committer 2017-08-23 17:13:45 UTC
A commit references this bug:

Author: amdmi3
Date: Wed Aug 23 17:13:22 UTC 2017
New revision: 448631
URL: https://svnweb.freebsd.org/changeset/ports/448631

Log:
  - Update MASTER_SITES to https
  - Remove unneeded dependency
  - While here, update WWW

  PR:		221718
  Submitted by:	xmj
  Approved by:	max@kostikov.com (maintainer)

Changes:
  head/net/megatools/Makefile
  head/net/megatools/pkg-descr