Bug 221736 - deskutils/py-khal: Update to 0.9.6
Summary: deskutils/py-khal: Update to 0.9.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-patch
: 218850 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-23 09:23 UTC by Zane C. Bowers-Hadley
Modified: 2018-01-14 22:58 UTC (History)
7 users (show)

See Also:
bugzilla: maintainer-feedback? (che)


Attachments
Updating to 0.9.7. (3.33 KB, patch)
2017-10-02 01:36 UTC, Alexandre C. Guimarães
no flags Details | Diff
svn diff (3.07 KB, patch)
2017-10-02 02:12 UTC, Zane C. Bowers-Hadley
no flags Details | Diff
Update to v0.9.7, and fix the previous patch. (3.47 KB, patch)
2017-10-02 03:31 UTC, Alexandre C. Guimarães
no flags Details | Diff
patch: updating to 0.9.8 (3.23 KB, patch)
2017-10-24 07:09 UTC, Alexandre C. Guimarães
no flags Details | Diff
Updating to 0.9.8 with @${FLAVOR} support. (3.67 KB, patch)
2017-12-01 01:36 UTC, Alexandre C. Guimarães
no flags Details | Diff
Updating to 0.9.8 with @${FLAVOR} support. (4.01 KB, patch)
2017-12-05 13:57 UTC, Alexandre C. Guimarães
no flags Details | Diff
Updating to 0.9.8 with @${FLAVOR} support. (4.21 KB, patch)
2017-12-05 19:07 UTC, Alexandre C. Guimarães
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zane C. Bowers-Hadley 2017-08-23 09:23:26 UTC
Howdy!

0.7.1 is a bit out of date. 0.9.6 is out now.

https://github.com/pimutils/khal/releases
Comment 1 Alexandre C. Guimarães freebsd_committer 2017-10-02 01:36:12 UTC
Created attachment 186845 [details]
Updating to 0.9.7.

The patch do:

* update deskutils/py-khal to 0.9.7 version;
* switch it to DISTVERSION;
* some minor alphabetizing.

Could not switch to USE_GITHUB:

...
LookupError: setuptools-scm was unable to detect version for '/home/alex/GIT/freebsd-ports/deskutils/py-khal/work/khal-0.9.7'.

Make sure you're either building from a fully intact git repository or PyPI tarballs. Most other sources (such as GitHub's tarballs, a git checkout without the .git folder) don't contain the necessary metadata and will not work.
...

Thanks!
Comment 2 Zane C. Bowers-Hadley 2017-10-02 02:12:17 UTC
Created attachment 186846 [details]
svn diff

Woot! Thanks. Was trying to figure out what what I was missing when I was mucking around with this awhile back... the python:3.3+ bit.

That said, here is a cleaned up svn diff.
Comment 3 Zane C. Bowers-Hadley 2017-10-02 02:19:38 UTC
Okay. Just updated my config for it and it is all awesome.

W00t!
Comment 4 Alexandre C. Guimarães freebsd_committer 2017-10-02 03:12:19 UTC
Unfortunatelly I missed the devel/py-atomicwrites dependency.

I will update the patch ASAP.
Comment 5 Alexandre C. Guimarães freebsd_committer 2017-10-02 03:31:19 UTC
Created attachment 186847 [details]
Update to v0.9.7, and fix the previous patch.

This patch do:

* update deskutils/py-khal to 0.9.7 version;
* add new dependencies;
* switch it to DISTVERSION;
* some minor alphabetizing.

Could not switch to USE_GITHUB:

...
LookupError: setuptools-scm was unable to detect version for '/home/alex/GIT/freebsd-ports/deskutils/py-khal/work/khal-0.9.7'.

Make sure you're either building from a fully intact git repository or PyPI tarballs. Most other sources (such as GitHub's tarballs, a git checkout without the .git folder) don't contain the necessary metadata and will not work.
...

Thanks!
Comment 6 Alexandre C. Guimarães freebsd_committer 2017-10-24 07:09:14 UTC
Created attachment 187415 [details]
patch: updating to 0.9.8

The patch does:

* update deskutils/py-khal to 0.9.8 version
* switch it to DISTVERSION
* some minor alphabetizing
Comment 7 kaltheat 2017-11-21 10:14:46 UTC
Hi,

are there any problems with the provided patch? I would like to see a more recent version of khal in portstree, too ... ;)

Regards,
kaltheat
Comment 8 Alexandre C. Guimarães freebsd_committer 2017-11-21 16:07:00 UTC
(In reply to kaltheat from comment #7)

The provided patch have a mix of python:2 and python:3 based dependencies, while it should be all python:3, but some of the dependencies does not still have a slave python:3 port in the tree.

It build and seem work fine if built using make and probably also using portmaster and similars, but fail with Synth and Poudriere (what is used to create the FreeBSD packages) because they require the python:3 of all dependencies.

The reason of I did not asked to pull in the necessary python:3 dependencies in the tree, is the fact Poudriere just acquired the ability to handle ports with FLAVOURS, what means in a near future there will be no need to have those slave ports but just a proper one to build all necessary variations.

So, IMO, py-khal is port not that important (and not seem to be broken) to justify the addition of a few new python:3 slaves ports what should be removed in a not distant future.

That said, I am updating it in here in a way it can be built and used for those whom need/want it.
Comment 9 Alexandre C. Guimarães freebsd_committer 2017-12-01 01:36:44 UTC
Created attachment 188443 [details]
Updating to 0.9.8 with @${FLAVOR} support.

This port still need some work:

* figure out what "setproctitle" actually does in the software (I do not use khal), and if it should be set as OPTION.
* if do-test is necessary and how to add it.

I actually know very little about python!

Other than those, it is working already.

Cheers!
Comment 10 Christian Geier 2017-12-04 23:49:31 UTC
Thanks for taking care of this! I put updating the port on my todo list when I read about flavours (since khal 0.8+ only supports python 3+).

proctitle sets a processes title, so it appears in top etc. as `python: khal` instead of `python /usr/local/bin/khal`. This is more useful on Linux where it sets the title to just `khal`.

do-test is not more or less necessary than for any other software, but if you want to enable it, make it run `pytest tests` in the source folder and make sure to install the test requirements.

Feel free to send a mail or open an issue on github if there are any other issues with updating.
Comment 11 Christian Geier 2017-12-04 23:53:52 UTC
Quick note: setuptools-scm should not be needed when installing from the PyPI tarballs, sqlite3 is needed though (probably only works because vdirsyncer depends on sqlite3 in recent versions).
Comment 12 Alexandre C. Guimarães freebsd_committer 2017-12-05 00:15:10 UTC
Thank you for your input. I will back to it tomorrow because I have poudriere building +700 ports right now. :)
Comment 13 Alexandre C. Guimarães freebsd_committer 2017-12-05 13:57:44 UTC
Created attachment 188548 [details]
Updating to 0.9.8 with @${FLAVOR} support.
Comment 14 Alexandre C. Guimarães freebsd_committer 2017-12-05 14:00:56 UTC
I am updating the patch now because the one in the tree is marked as broken, but I still want to move "proctitle" to an optional dependency.

I will need to be out (probably) until tomorrow, and so I will not have time to do that.

Thanks.
Comment 15 Alexandre C. Guimarães freebsd_committer 2017-12-05 19:07:26 UTC
Created attachment 188562 [details]
Updating to 0.9.8 with @${FLAVOR} support.

Added an OPTION to setproctile + what were added in the previous patches.

I think everything is fine now.

PS. does not built without "setuptools-scm".

Thanks.
Comment 16 Alexandre C. Guimarães freebsd_committer 2017-12-08 15:43:16 UTC
Just to notice, the version in ports is marked as broken.

Thanks!
Comment 17 rsos+freebsd 2017-12-10 10:10:43 UTC
*** Bug 218850 has been marked as a duplicate of this bug. ***
Comment 18 Alexandre C. Guimarães freebsd_committer 2017-12-10 13:48:16 UTC
In the Phab: https://reviews.freebsd.org/D13432
Comment 19 kaltheat 2018-01-08 14:57:30 UTC
What needs to be done to solve this issue? According to "the Phab" "a comment" needs to be "double-checked", which already seems do be done ...

What's next?

Kind regards,
kaltheat
Comment 20 commit-hook freebsd_committer 2018-01-14 21:23:50 UTC
A commit references this bug:

Author: adridg
Date: Sun Jan 14 21:23:13 UTC 2018
New revision: 459002
URL: https://svnweb.freebsd.org/changeset/ports/459002

Log:
  Update khal to 0.9.8. Previous version was marked BROKEN due to
  missing (versioned) dependencies. This version works with the
  current deskutils/py-vdirsyncer.

   - Also switch to DISTVERSION
   - Minor fixes in Makefile, alphabetizing
   - Updated dependencies
   - Optional (non-default) dependency on setproctitle

  Move maintainership from upstream to lbdm.

  PR:		221736 224732
  Submitted by:	lbdm@privacychain.ch
  Reviewed by:	che@bein.link (maintainer) adridg
  Approved by:	tcberner (mentor)
  Differential Revision:	https://reviews.freebsd.org/D13432

Changes:
  head/deskutils/py-khal/Makefile
  head/deskutils/py-khal/distinfo
  head/deskutils/py-khal/files/
  head/deskutils/py-khal/pkg-message
Comment 21 Adriaan de Groot freebsd_committer 2018-01-14 21:28:10 UTC
Passed it by on the way to 0.9.8
Comment 22 kaltheat 2018-01-14 22:58:01 UTC
Thanks :)