Bug 221770 - textproc/p5-XML-Parser: build fails: /usr/local/bin/perl5.24.2 not found
Summary: textproc/p5-XML-Parser: build fails: /usr/local/bin/perl5.24.2 not found
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jun Kuriyama
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-24 16:57 UTC by MMacD
Modified: 2019-06-16 16:04 UTC (History)
6 users (show)

See Also:
jbeich: maintainer-feedback+
jbeich: maintainer-feedback? (kuriyama)
jbeich: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MMacD 2017-08-24 16:57:43 UTC
===>  Applying FreeBSD patches for intltool-0.51.0_1
===>   intltool-0.51.0_1 depends on package: p5-XML-Parser>=0 - not found
===>  License ART10 GPLv1 accepted by the user
===>   p5-XML-Parser-2.44 depends on file: /usr/local/sbin/pkg - found
=> XML-Parser-2.44.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch http://cpan.metacpan.org/modules/by-module/XML/XML-Parser-2.44.tar.gz
XML-Parser-2.44.tar.gz                        100% of  231 kB  113 kBps 00m02s
===> Fetching all distfiles required by p5-XML-Parser-2.44 for building
===>  Extracting for p5-XML-Parser-2.44
=> SHA256 Checksum OK for XML-Parser-2.44.tar.gz.
===>  Patching for p5-XML-Parser-2.44
===>  Applying FreeBSD patches for p5-XML-Parser-2.44
===>   p5-XML-Parser-2.44 depends on package: perl5>=5.24<5.25 - found
===>   p5-XML-Parser-2.44 depends on shared library: libexpat.so - found (/usr/local/lib/libexpat.so)
===>  Configuring for p5-XML-Parser-2.44
env: /usr/local/bin/perl5.24.2: No such file or directory
*** Error code 127

Stop.
make[5]: stopped in /usr/ports/textproc/p5-XML-Parser
*** Error code 1
Comment 1 Jan Beich freebsd_committer 2017-08-24 22:36:07 UTC
Does textproc/p5-XML-Parser fail to build even standalone i.e., when not pulled as a dependency?

www/firefox doesn't directly depend on intltool or p5-XML-Parser. Reassigning.
Comment 2 MMacD 2017-08-25 09:30:42 UTC
(In reply to Jan Beich from comment #1)
No, it fails because it can't find bin/perl5.24.2.  And given the 345,678 p5 ports listed, I've no clue which one would populate that subtree.

One of the things I've noticed is that config options never include the choice of excluding some functionality, xml or sound or some other thing, completely.  The only options are what *kind* of sound or xml or whatever.  I haven't counted, but Firefox must have at least 100 dependencies, few of which have much to do with fetching and displaying web pages (what critical role does perl play, for example?).  And because of the huge number of non-optional "options", and the lack of resources to do QA, it's a crapshoot whether something will build without bugs, or even at all. 

Maybe it would be good policy to coarsen the granularity of the config choices? Offer them at the functional level, not the mere-flavoring one?
Comment 3 rkoberman 2017-08-25 23:29:23 UTC
/usr/local/perl5.24.2 is installed by the perl5.24.
% pkg which  /usr/local/bin/perl5.24.2
/usr/local/bin/perl5.24.2 was installed by package perl5-5.24.2

If it is missing, it got deleted.
% 
pkg info -l perl5 | grep bin/perl5
	/usr/local/bin/perl5
	/usr/local/bin/perl5.24.2

perl, perl5, and perl5.24.2 all appear to be hardlinks to the perl executable.
Try re-installing perl and see if the file is installed.

This all assumes that you use default values for environmental variables related to port installation.
Comment 4 Adrian Radu 2017-09-03 09:18:05 UTC
Reinstalling perl5.24.2 from ports worked for me.
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-02-12 18:38:47 UTC
Is this still relevant?
Comment 6 Walter Schwarzenfeld freebsd_triage 2018-02-12 22:08:15 UTC
Overlooked comment4.
Comment 7 Sunny007 2019-06-16 16:04:21 UTC
MARKED AS SPAM