Bug 221883 - lang/gcc6-aux: Update to last snapshot of GCC6
Summary: lang/gcc6-aux: Update to last snapshot of GCC6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Tobias Kortkamp
URL:
Keywords:
: 222133 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-28 19:46 UTC by frederic.praca
Modified: 2017-10-08 19:16 UTC (History)
3 users (show)

See Also:
tobik: merge-quarterly-


Attachments
svn patch file (2.90 KB, patch)
2017-08-28 19:46 UTC, frederic.praca
no flags Details | Diff
synth screenshot (10.82 KB, image/png)
2017-09-21 16:06 UTC, mayhem30
no flags Details
New patch updated after last commit (2.90 KB, patch)
2017-09-24 07:47 UTC, frederic.praca
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description frederic.praca 2017-08-28 19:46:53 UTC
Created attachment 185846 [details]
svn patch file

Here's a patch to upgrade GCC6-aux to the last snapshot version (i.e. 20170802).

Moreover, this patch fixes a problem when PREFIX is different from /usr/local.
As the port needs gmake to run, it must be in the path when building.
Comment 1 frederic.praca 2017-08-28 19:54:34 UTC
I forgot to tell that the current version 20170202 is not available any more.
Comment 2 mayhem30 2017-09-11 15:50:30 UTC
Could someone please update the ports to this new version?

This will also fix : https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=222133
Comment 3 frederic.praca 2017-09-11 16:38:07 UTC
As soon as I will have finish upgrading Ada ports, maybe not all but several ones, I will try to provide a gcc7-aux port.
Stay tuned :)
Comment 4 mayhem30 2017-09-13 18:57:22 UTC
That would be great, thank you!
Comment 5 mayhem30 2017-09-21 16:06:30 UTC
Created attachment 186592 [details]
synth screenshot

Why is it taking so long for this patch to get approved?

It's now takes over 4 minutes to fetch the files for gcc6-aux port. Pretty soon, the files will no longer be available.

(see image attachment for proof).
Comment 6 frederic.praca 2017-09-24 07:47:39 UTC
Created attachment 186653 [details]
New patch updated after last commit

Update patch due to last commit on lang/gcc6-aux
Comment 7 Tobias Kortkamp freebsd_committer 2017-10-05 11:39:32 UTC
*** Bug 222133 has been marked as a duplicate of this bug. ***
Comment 8 commit-hook freebsd_committer 2017-10-05 13:53:58 UTC
A commit references this bug:

Author: tobik
Date: Thu Oct  5 13:53:40 UTC 2017
New revision: 451312
URL: https://svnweb.freebsd.org/changeset/ports/451312

Log:
  lang/gcc6-aux: Update to 20170802 snapshot [1]

  - Make sure gmake can be found during the build when PREFIX is
    different from LOCALBASE [1]
  - This also fixes fetching the port since the 20170202 snapshot is
    gone from a lot of mirrors [2]

  PR:		221883 [1, 2], 222133 [2]
  Submitted by:	frederic.praca@free.fr (based on) [1]
  Reported by:	mayhem30@gmail.com [2]
  MFH:		2017Q4

Changes:
  head/lang/gcc6-aux/Makefile
  head/lang/gcc6-aux/Makefile.version
  head/lang/gcc6-aux/distinfo
Comment 9 Tobias Kortkamp freebsd_committer 2017-10-08 15:35:00 UTC
The MFH was denied because the update broke some ports, so closing the bug because there is nothing more to do here.
Comment 10 frederic.praca 2017-10-08 18:59:56 UTC
could you precise which ports failed as I also provided some other patches?
Comment 11 Tobias Kortkamp freebsd_committer 2017-10-08 19:13:30 UTC
(In reply to frederic.praca from comment #10)
I'm sorry I don't know.  I wasn't told and I haven't asked.

I'm pretty sure at least lang/gnatdroid-armv7 and lang/gnat_util were broken
by it.
Comment 12 frederic.praca 2017-10-08 19:16:40 UTC
Right for lang/gnat_util as I also provided a patch (see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=222230 ) ;)