Bug 221891 - [UPDATE] textproc/py-sphinx to 1.6.5
Summary: [UPDATE] textproc/py-sphinx to 1.6.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Marcelo Araujo
URL:
Keywords:
: 225136 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-29 08:27 UTC by Marcelo Araujo
Modified: 2018-01-29 11:30 UTC (History)
2 users (show)

See Also:
araujo: exp-run+


Attachments
patch (7.63 KB, patch)
2017-08-29 08:27 UTC, Marcelo Araujo
no flags Details | Diff
New py-sphinx diff. (8.40 KB, patch)
2017-08-30 03:44 UTC, Marcelo Araujo
no flags Details | Diff
Unified diff. (230.19 KB, patch)
2017-09-01 05:39 UTC, Marcelo Araujo
no flags Details | Diff
09042017-Unifieddiff (239.07 KB, patch)
2017-09-04 09:17 UTC, Marcelo Araujo
no flags Details | Diff
New diff. (78.95 KB, patch)
2017-10-03 07:42 UTC, Marcelo Araujo
no flags Details | Diff
Unified 10032017 (79.65 KB, patch)
2017-10-03 08:51 UTC, Marcelo Araujo
no flags Details | Diff
10122017 (86.37 KB, patch)
2017-10-12 08:39 UTC, Marcelo Araujo
no flags Details | Diff
Fixed cmake-doc (241.96 KB, patch)
2017-11-06 03:51 UTC, Marcelo Araujo
no flags Details | Diff
New py-sphinx diff 2018. (239.67 KB, patch)
2018-01-05 04:53 UTC, Marcelo Araujo
no flags Details | Diff
08012018 (246.39 KB, patch)
2018-01-08 03:36 UTC, Marcelo Araujo
no flags Details | Diff
11012018 (278.17 KB, patch)
2018-01-11 09:40 UTC, Marcelo Araujo
no flags Details | Diff
11012018-2 (282.33 KB, patch)
2018-01-11 15:50 UTC, Marcelo Araujo
no flags Details | Diff
patch for swift (3.53 KB, patch)
2018-01-22 15:01 UTC, Antoine Brodin
no flags Details | Diff
Unified patch (287.85 KB, patch)
2018-01-26 06:17 UTC, Marcelo Araujo
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marcelo Araujo freebsd_committer 2017-08-29 08:27:42 UTC
Created attachment 185859 [details]
patch

Update py-sphinx to 1.6.3.
Comment 1 Marcelo Araujo freebsd_committer 2017-08-29 08:28:47 UTC
Hi, there are hundreds ports that depends of textproc/py-sphinx, I would like to request an exp-run.
Comment 2 Antoine Brodin freebsd_committer 2017-08-29 13:23:08 UTC
Exp-run results:

http://package23.nyi.freebsd.org/build.html?mastername=110i386-default-PR221891&build=2017-08-29_08h54m02s

Failure logs:


http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py27-pyaudio-0.2.11.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py27-xapian-1.4.4.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/bpython-py27-0.17.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/cmake-3.8.2.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/llvm35-3.5.2_4.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py27-Jinja2-doc-2.9.5.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py27-noseofyeti-1.5.1.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py27-pathlib-1.0.1.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py27-pathtools-0.1.2_3.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py27-pip-9.0.1.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py27-virtualenv-15.1.0.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py36-pip-9.0.1.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py36-virtualenv-15.1.0.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/ghc-8.0.2_1.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py27-gntp-0.8_3.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/xmlada-17.0.0.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py27-cssselect-0.9.1_1.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-29_08h54m02s/logs/py27-webob-1.6.3.log

More than 200 ports were skipped due to those failures
Comment 3 Marcelo Araujo freebsd_committer 2017-08-30 03:43:14 UTC
Thanks for the exp-run, I added a new port textproc/py-sphinxcontrib-websupport and also I modified py-sphinx Makefile adding new dependencies.

Could you please run an exp-run again?


Thanks.
Comment 4 Marcelo Araujo freebsd_committer 2017-08-30 03:44:00 UTC
Created attachment 185908 [details]
New py-sphinx diff.

This is the new diff, also the portstree need to be updated.
Comment 5 Marcelo Araujo freebsd_committer 2017-08-30 04:51:27 UTC
There is only one drawback with this update, as we can't add py3-* anymore, there are some py3 ports failing because I can't add an py3-sphinxcontrib-websupport. So, my suggestion is if py27 ports pass the build we might consider update it and after we move to PYTHON FLAVORS we fix any py3 failure related with this update.
Comment 6 Adam Weinberger freebsd_committer 2017-08-30 12:19:55 UTC
Breaking ports isn't a good option. Either delay the update, or add the py3- port. Is 1.6.3 a delayable update, or does it contain fixes that we should have in the tree now?
Comment 7 Marcelo Araujo freebsd_committer 2017-08-30 12:57:54 UTC
(In reply to Adam Weinberger from comment #6)

I'm more than happy to add the py3 port if possible and solve the py3 issues.

This new version has features that we at iX needs to create documentation and manuals for TrueOS and FreeNAS.

Also this port for months doesn't receive an update because it broken some other ports, I rather fix everything that comes up and update it. But of course it will requires a ping you guys to run exp-run.
Comment 8 Antoine Brodin freebsd_committer 2017-08-30 14:47:06 UTC
Exp-run results:

http://package23.nyi.freebsd.org/build.html?mastername=110i386-default-PR221891&build=2017-08-30_05h49m09s

New failure logs:


http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/owncloudclient-2.3.2.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/ahven-2.6_2.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/cmake-doc-3.8.2.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/gnatcoll-2016_1.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/kf5-extra-cmake-modules-5.37.0.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/llvm-devel-5.0.d20170524.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/llvm33-3.3_12.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/llvm34-3.4.2_6.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/llvm35-3.5.2_4.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/py27-pathtools-0.1.2_3.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/py27-spyder-2.3.7.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/py27-virtualenvwrapper-4.7.1.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/py36-pip-9.0.1.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/py36-virtualenv-15.1.0.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/shiboken-1.2.2_2.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/py27-scikit-image-0.13.0.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/py27-gntp-0.8_3.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/py27-cssselect-0.9.1_1.log
http://package23.nyi.freebsd.org/data/110i386-default-PR221891/2017-08-30_05h49m09s/logs/py27-kivy-1.9.1_4.log

3 ports were not tested due to those failures.
Comment 9 Marcelo Araujo freebsd_committer 2017-09-01 05:39:10 UTC
Created attachment 185967 [details]
Unified diff.

Hi, could you please run another round of exp-run?
Comment 11 Marcelo Araujo freebsd_committer 2017-09-04 09:17:12 UTC
Created attachment 186058 [details]
09042017-Unifieddiff

All ports fixed, only devel/llvm-devel seems to have no relation with this update.

Also I need to add a textproc/py3-sphinxcontrib-websupport to be able to fix those py3-pip and py3-virtualenv issues.

So in this case I will need portmgr approve.
Please, could you run one more exp-run?
Comment 12 Antoine Brodin freebsd_committer 2017-09-08 06:06:38 UTC
There is a problem:

Duplicated origin for py27-sphinxcontrib-websupport-1.0.1: textproc/py-sphinxcontrib-websupport AND textproc/py3-sphinxcontrib-websupport.
Comment 13 Antoine Brodin freebsd_committer 2017-09-08 06:09:31 UTC
(In reply to Antoine Brodin from comment #12)
Adding a USES?=python to textproc/py-sphinxcontrib-websupport seems to fix this
Comment 14 Antoine Brodin freebsd_committer 2017-09-08 06:10:21 UTC
Also there is a mismerge in your patch in devel/gnatcoll
Comment 15 Antoine Brodin freebsd_committer 2017-09-08 11:59:41 UTC
The devel/llvm-devel changes break it on amd64,  changes to this port can be omitted
Comment 16 Antoine Brodin freebsd_committer 2017-09-08 12:24:44 UTC
Note: a cmake exp-run is ongoing so the plist will change
Comment 17 Antoine Brodin freebsd_committer 2017-09-15 05:46:49 UTC
Can you refresh the patch:

- after CMake updated to 3.9.2
- with textproc/py-sphinxcontrib-websupport USES fixed
- with devel/gnatcoll mismerge removed
- with devel/llvm-devel changes reverted
Comment 18 Marcelo Araujo freebsd_committer 2017-09-25 10:24:37 UTC
(In reply to Antoine Brodin from comment #17)

Just a hands up! I just got back from a business trip, will get back to you tomorrow or after tomorrow.. Thanks!
Comment 19 Marcelo Araujo freebsd_committer 2017-10-03 07:42:31 UTC
Created attachment 186876 [details]
New diff.

Hi,

Here is the new diff. I ran another round with poudriere for this port using python36 and python27, wall built ok.

Please one more exp-run :)


Thank you!
Comment 20 Marcelo Araujo freebsd_committer 2017-10-03 08:51:07 UTC
Created attachment 186877 [details]
Unified 10032017

Sorry, use this diff, the previous one I forgot to add textproc/py3-sphinxcontrib-websupport.

Best,
Comment 21 Antoine Brodin freebsd_committer 2017-10-06 07:52:53 UTC
Both py-sphinx and py3-sphinx fail during patch phase.
Comment 22 Marcelo Araujo freebsd_committer 2017-10-12 08:39:58 UTC
Created attachment 187095 [details]
10122017

Remove py-sphinx files/patch-b03b7e543f5e135d046d2fe407def219336c12b2
Comment 23 Marcelo Araujo freebsd_committer 2017-10-12 08:42:54 UTC
I forgot to remove a patch from py-sphinx.
I hope this time it goes good.

Thanks again.
Comment 24 Antoine Brodin freebsd_committer 2017-10-13 05:37:12 UTC
On 11.0 amd64,  cmake-doc fails to package:

http://package18.nyi.freebsd.org/data/110amd64-default-PR221891/2017-10-12_20h16m08s/logs/cmake-doc-3.9.3_1.log
Comment 25 Marcelo Araujo freebsd_committer 2017-11-06 03:51:17 UTC
Created attachment 187776 [details]
Fixed cmake-doc

Hi, here there is a new diff with the cmake-doc fixed.

Thanks,
Comment 26 Antoine Brodin freebsd_committer 2017-11-30 17:18:08 UTC
Please update your patch and mark the old ones obsolete.
Comment 27 Marcelo Araujo freebsd_committer 2018-01-05 04:52:18 UTC
(In reply to Antoine Brodin from comment #26)

Hi, attached a new patch that cover the new python FLAVOR option.


Best,
Comment 28 Marcelo Araujo freebsd_committer 2018-01-05 04:53:08 UTC
Created attachment 189425 [details]
New py-sphinx diff 2018.
Comment 30 Marcelo Araujo freebsd_committer 2018-01-08 03:36:55 UTC
Created attachment 189499 [details]
08012018

I forgot to remove py-sphinx patch. Sorry about that.
Comment 31 Antoine Brodin freebsd_committer 2018-01-09 12:33:34 UTC
There is 1 new failure: x11-toolkits/py-kivy

http://pb2.nyi.freebsd.org/data/103amd64-default-PR221891/2018-01-08_07h10m08s/logs/errors/py27-kivy-1.10.0.log
Comment 32 Marcelo Araujo freebsd_committer 2018-01-11 09:40:33 UTC
Created attachment 189607 [details]
11012018

Hi,

With this patch, I have fixed the new issue on: x11-toolkits/py-kivy

Thanks again for all tests.
Comment 33 Antoine Brodin freebsd_committer 2018-01-11 14:41:43 UTC
Comment on attachment 189607 [details]
11012018

The patch fails to apply.
Comment 34 Marcelo Araujo freebsd_committer 2018-01-11 15:50:57 UTC
Created attachment 189618 [details]
11012018-2

Portstree updated and remade the patch.
Comment 35 Antoine Brodin freebsd_committer 2018-01-12 18:51:21 UTC
On amd64,  lang/swift fails to build:


http://pb2.nyi.freebsd.org/data/111amd64-default-PR221891/2018-01-12_10h01m41s/logs/swift-3.1.1_3.log
Comment 36 Marcelo Araujo freebsd_committer 2018-01-15 01:38:39 UTC
*** Bug 225136 has been marked as a duplicate of this bug. ***
Comment 37 Marcelo Araujo freebsd_committer 2018-01-22 06:01:56 UTC
(In reply to Antoine Brodin from comment #35)

It looks like a problem with lang/swift itself on amd64 and not directly related with py-sphinx.

I don't know what to do with lang/swift.

Any suggestion?
Comment 38 Antoine Brodin freebsd_committer 2018-01-22 06:12:17 UTC
(In reply to Marcelo Araujo from comment #37)
swift is ONLY_FOR_ARCHS: amd64
Comment 39 Marcelo Araujo freebsd_committer 2018-01-22 06:19:20 UTC
(In reply to Antoine Brodin from comment #38)

Yes, I saw it! Any suggestion what I could do with swift?
Perhaps I need to contact swills@ about this build issue as he is the maintainer?

What do you think?
Comment 40 Antoine Brodin freebsd_committer 2018-01-22 06:32:36 UTC
Yes,  contact maintainer.

You can also check upstream changes,  like https://github.com/apple/swift/commit/9f0b2c7da4f0ba577aeee363e04fcb13084fa578  (I didn't try)
Comment 41 Antoine Brodin freebsd_committer 2018-01-22 10:15:47 UTC
(In reply to Antoine Brodin from comment #40)
With this patch,  the build goes a bit further and fails with:

Warning, treated as error:                                                                                                                            /wrkdirs/usr/ports/lang/swift/work/swift-3.1.1/swift/docs/proposals/InitializerInheritance.rst:395:Footnote [#] is not referenced.
Comment 42 Antoine Brodin freebsd_committer 2018-01-22 10:17:41 UTC
(In reply to Antoine Brodin from comment #41)
Maybe this patch fixes it:
https://github.com/apple/swift/pull/9980/commits/9547aad68ca27885965101dbcd7816dbbf21f3c5
Comment 43 Marcelo Araujo freebsd_committer 2018-01-22 10:20:27 UTC
(In reply to Antoine Brodin from comment #42)


Thank you! I will try it later.
Comment 44 Antoine Brodin freebsd_committer 2018-01-22 15:01:27 UTC
Created attachment 189970 [details]
patch for swift
Comment 45 Marcelo Araujo freebsd_committer 2018-01-25 10:27:21 UTC
OK, spent 2 days and definitely I would prefer mark lang/swift as broken.
Even with that swift patch it still doesn't build clean on poudriere.

Here are some PR for lang/swift:
https://bugs.freebsd.org/bugzilla/buglist.cgi?component=Individual%20Port%28s%29&list_id=210507&product=Ports%20%26%20Packages&query_format=advanced&resolution=---&short_desc=lang%2Fswift&short_desc_type=allwordssubstr

I got hit at least by 2 of them.

Also I got hit by this one here:
https://github.com/apple/swift/pull/14040

Can we mark it as broken and move forward?


Best,
Comment 46 Antoine Brodin freebsd_committer 2018-01-25 10:29:03 UTC
(In reply to Marcelo Araujo from comment #45)
with the patch it built fine in poudriere on 11.1 amd64 for me.
Comment 47 Marcelo Araujo freebsd_committer 2018-01-25 10:32:46 UTC
(In reply to Antoine Brodin from comment #46)

It doesn't for me!


OK, shall I unify those 2 patches or are we good to go?

I can make 2 commits, one for py-sphinx and another including your patch for lang/swift for all dependencies of py-sphinx.

Best,
Comment 48 Antoine Brodin freebsd_committer 2018-01-25 10:34:35 UTC
(In reply to Marcelo Araujo from comment #47)
I prefer 1 atomic commit.
Comment 49 Marcelo Araujo freebsd_committer 2018-01-25 10:38:44 UTC
(In reply to Antoine Brodin from comment #48)

OK, I'm gonna unify the path then! Thank you!
Comment 50 Marcelo Araujo freebsd_committer 2018-01-26 06:17:48 UTC
Created attachment 190077 [details]
Unified patch

Here we go, this is the unified patch that includes lang/swift changes.

Changelog:
- Update textproc/py-sphinx to 1.6.5.
- Update all ports that depends of py-sphinx.

Approved by: antoine (portmgr)
Exprun by: antoine (several rounds)
Comment 51 Antoine Brodin freebsd_committer 2018-01-26 15:27:36 UTC
Approved,  don't commit the ".orig" files.
Comment 52 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-01-26 16:00:49 UTC
Please update Makefile before commit because some dependencies are incorrect.

If you do not want to use the full version [1], please include the changes I mentioned in bug #225136, comment #2:
- Remove BUILD_DEPENDS
- Conditional RUN_DEPENDS (See [2])
- Add TEST_DEPENDS

Thanks!

[1] https://people.FreeBSD.org/~sunpoet/patch/textproc-py-sphinx.txt
[2] https://github.com/sphinx-doc/sphinx/blob/master/setup.py#L38-L40
Comment 53 commit-hook freebsd_committer 2018-01-29 06:46:03 UTC
A commit references this bug:

Author: araujo
Date: Mon Jan 29 06:45:17 UTC 2018
New revision: 460241
URL: https://svnweb.freebsd.org/changeset/ports/460241

Log:
  - Update textproc/py-sphinx to 1.6.5. [0]
  - Update all ports that depends of py-sphinx. [0]
  - Add conditional RUN_DEPENDS. [1]
  - Add TEST_DEPENDS. [1]

  PR:		ports/221891 [0] and ports/225136 [1]
  Submitted by:	sunpoet [1]
  Approved by:	antoine (portmgr)
  Exprun by:	antoine (several rounds)
  Sponsored by:	iXsystems, Inc.

Changes:
  head/deskutils/owncloudclient/Makefile
  head/deskutils/owncloudclient/pkg-plist
  head/devel/ahven/Makefile
  head/devel/ahven/pkg-plist
  head/devel/cmake-doc/Makefile
  head/devel/cmake-doc/pkg-plist
  head/devel/kf5-extra-cmake-modules/Makefile
  head/devel/kf5-extra-cmake-modules/pkg-plist
  head/devel/llvm33/Makefile
  head/devel/llvm33/pkg-plist
  head/devel/llvm34/Makefile
  head/devel/llvm34/pkg-plist
  head/devel/llvm35/Makefile
  head/devel/llvm35/pkg-plist
  head/devel/py-pathtools/Makefile
  head/devel/py-pathtools/pkg-plist
  head/devel/py-spyder/Makefile
  head/devel/py-virtualenvwrapper/Makefile
  head/devel/py-virtualenvwrapper/pkg-plist
  head/devel/shiboken/Makefile
  head/devel/shiboken/pkg-plist
  head/lang/swift/Makefile
  head/lang/swift/files/patch-swift-docs-CMakeLists.txt
  head/lang/swift/files/patch-swift-docs-conf.py
  head/lang/swift/files/patch-swift-docs-proposals-InitializerInheritance.rst
  head/net/py-gntp/Makefile
  head/net/py-gntp/pkg-plist
  head/textproc/py-sphinx/Makefile
  head/textproc/py-sphinx/distinfo
  head/textproc/py-sphinx/files/patch-b03b7e543f5e135d046d2fe407def219336c12b2
  head/textproc/py-sphinxcontrib-adadomain/Makefile
  head/www/py-cssselect/Makefile
  head/www/py-cssselect/pkg-plist
  head/www/py-pyquery/Makefile
  head/www/py-pyquery/pkg-plist
  head/x11-toolkits/py-kivy/Makefile
  head/x11-toolkits/py-kivy/pkg-plist
Comment 54 Marcelo Araujo freebsd_committer 2018-01-29 06:47:16 UTC
Thanks guys!
Comment 55 commit-hook freebsd_committer 2018-01-29 11:30:00 UTC
A commit references this bug:

Author: sunpoet
Date: Mon Jan 29 11:29:15 UTC 2018
New revision: 460284
URL: https://svnweb.freebsd.org/changeset/ports/460284

Log:
  Fix RUN_DEPENDS

  - Bump PORTREVISION for dependency change

  typing is a conditional RUN_DEPENDS for Python versions prior to 3.5.

  PR:		221891, 225136

Changes:
  head/textproc/py-sphinx/Makefile