Bug 221904 - [MAINTAINER-UPDATE] audio/mpdas to 0.4.4
Summary: [MAINTAINER-UPDATE] audio/mpdas to 0.4.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: easy, needs-qa, patch
Depends on:
Blocks:
 
Reported: 2017-08-29 12:36 UTC by henrik
Modified: 2017-10-01 14:40 UTC (History)
1 user (show)

See Also:
riggs: merge-quarterly-


Attachments
mpdas update patch (837 bytes, patch)
2017-08-29 12:36 UTC, henrik
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description henrik 2017-08-29 12:36:50 UTC
Created attachment 185872 [details]
mpdas update patch

Updates mpdas to 0.4.4

This update contains important maintenance changes:
- Fix parsing of passwords containing special characters
- Fix handshake bug caused by passwords containing special characters such as ampersands
- Also load configuration file from $XDG_CONFIG_HOME/mpdasrc or ~/.config/mpdasrc, if the former is not set

Additional changes from 0.4.3 which was not ported:
- Use HTTPS for communication
- Move away from the deprecated authToken authentication.
- NOTE: This requires you to change your configuration. Your Last.fm password now needs to be set as plaintext, not an MD5 hash (as before).
Comment 1 commit-hook freebsd_committer 2017-09-02 11:27:55 UTC
A commit references this bug:

Author: riggs
Date: Sat Sep  2 11:27:21 UTC 2017
New revision: 449122
URL: https://svnweb.freebsd.org/changeset/ports/449122

Log:
  Update to upstream version 0.4.4

  PR:		221904
  Submitted by:	henrik@affekt.org (maintainer)
  MFH:		2017Q3

Changes:
  head/audio/mpdas/Makefile
  head/audio/mpdas/distinfo
Comment 2 Thomas Zander freebsd_committer 2017-10-01 14:40:17 UTC
MFH has not been granted, and has not become obsolete, since new quartal has started.