Bug 221908 - [patch] adapt devel/llvm* and lang/clang* to new 'armv7' architecture
Summary: [patch] adapt devel/llvm* and lang/clang* to new 'armv7' architecture
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Brooks Davis
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-08-29 13:07 UTC by Mark Linimon
Modified: 2018-02-23 22:21 UTC (History)
1 user (show)

See Also:


Attachments
patches to various files in clang* and llvm* (13.85 KB, patch)
2017-08-29 13:07 UTC, Mark Linimon
no flags Details | Diff
updated patch (13.85 KB, patch)
2017-08-29 21:20 UTC, Mark Linimon
no flags Details | Diff
llvm50 patch (1.22 KB, patch)
2017-10-10 11:11 UTC, Michal Meloun
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Linimon freebsd_committer freebsd_triage 2017-08-29 13:07:00 UTC
Created attachment 185877 [details]
patches to various files in clang* and llvm*

The src tree is splitting 32-bit arm support into 'armv6' and the new 'armv7'.  This patch adds armv7 support.  It should provide no regression on any existing architecture.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2017-08-29 13:07:51 UTC
I will be testing these patches for no regression on amd64 this afternoon.
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2017-08-29 21:20:17 UTC
Created attachment 185899 [details]
updated patch
Comment 3 Michal Meloun freebsd_committer 2017-10-10 11:11:20 UTC
Created attachment 187047 [details]
llvm50 patch

Update proposed patch for llvm50
- add support for ARMv7
- for ARMv[67], use correct API when building CONFIGURE_TARGET
Comment 4 commit-hook freebsd_committer 2017-10-30 10:20:14 UTC
A commit references this bug:

Author: brooks
Date: Mon Oct 30 10:19:40 UTC 2017
New revision: 453163
URL: https://svnweb.freebsd.org/changeset/ports/453163

Log:
  Update to an October 23rd snapshot.

  Merge cleanups to targets.[0]

  PR:		221908 [0]

Changes:
  head/devel/llvm-devel/Makefile
  head/devel/llvm-devel/Makefile.snapshot
  head/devel/llvm-devel/distinfo
  head/devel/llvm-devel/pkg-plist
Comment 5 Brooks Davis freebsd_committer 2018-02-23 22:21:41 UTC
It looks like I've committed these to llvm50 and llvm60 so at least so I'm closing this.  If it's needed for any other ports, let me know and I'll take a look.