Bug 221964 - Bridged networking does not work on 11.1-RELEASE for emulators/virtualbox-ose-kmod
Summary: Bridged networking does not work on 11.1-RELEASE for emulators/virtualbox-ose...
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: vbox
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-31 20:04 UTC by Kamil Choudhury
Modified: 2017-12-03 21:56 UTC (History)
6 users (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kamil Choudhury 2017-08-31 20:04:25 UTC
Bridged networking does not work in emulators/virtualbox-ose-kmod using -latest of Q3 pkg branches on 11.1-RELEASE-p1 after upgrade from 11.0-RELEASE

Workaround: 

- uninstall virtualbox-ose-kmod
- build port from scratch on 11.1

This indicates a KBI change between 11.0 and 11.1

To restore briding functionality to this port, would it be possible to provide a binary build of this port that was built on 11.1 for both -latest and q3? 

Previously: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=221050
Comment 1 freebsd 2017-11-19 00:20:51 UTC
It isn't just upgrades; my system is a completely fresh install of 11.1-RELEASE (which I have upgraded to -p4) and bridged networking does not work for me either. No errors appear when loading the modules or running the VM, but no packets are passed through to it.

Unlike Kamil, manually building the module from source does not make packets route for me. I still have 0 packets being sent to the VM even after downloading the ports tree, kernel source, and a partridge in a pear tree as required to build the module.

Compilation of the module was successful, and I had deleted the pkg with the module manually before I built it.

This is with virtualbox-ose 5.2.0, installed via pkg, and the module built from the ports tree updated today:

[~]$ pkg info -x virtualbox
virtualbox-ose-kmod-5.2.0_1
virtualbox-ose-nox11-5.2.0_1

[~]$ uname -a
FreeBSD hostname 11.1-RELEASE-p4 FreeBSD 11.1-RELEASE-p4 #0: Tue Nov 14 06:12:40 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64

[~]# kldstat
Id Refs Address            Size     Name
 1   39 0xffffffff80200000 1f67a88  kernel
 2    1 0xffffffff82169000 316708   zfs.ko
 3    2 0xffffffff82480000 cb78     opensolaris.ko
 4    1 0xffffffff8248d000 6178     uhid.ko
 5    1 0xffffffff82494000 4d18     coretemp.ko
 7    1 0xffffffff8273d000 a877     linprocfs.ko
 8    1 0xffffffff82748000 7b0f     linux_common.ko
 9    1 0xffffffff82750000 bb55     tmpfs.ko
11    2 0xffffffff8275f000 c57d     netgraph.ko
12    1 0xffffffff8276c000 43da     ng_ether.ko
14    1 0xffffffff82776000 17f7     accf_http.ko
15    1 0xffffffff82778000 d8f      accf_data.ko
16    3 0xffffffff82779000 53b40    vboxdrv.ko
17    2 0xffffffff8275c000 2cbf     vboxnetflt.ko
18    1 0xffffffff82771000 4016     vboxnetadp.ko
Comment 2 freebsd 2017-11-19 05:03:37 UTC
Well, I can eat some crow here after continued troubleshooting - the vboxnet /dev handle has improper permissions by default, as is noted in the Handbook. I had changed those, but forgot to log out and back in.

That said -- if I remove the modules I built and install the ones from pkg, the config breaks. If I reinstall the ones I built manually, it works.
Comment 3 ionut.vancea 2017-11-19 11:07:23 UTC
I have the same issue and all my VMs are not working anymore. (FreeBSD 11.1 + Virtualbox 5.2) 

The workaround provided by Kamil is not working in my case.

Please try to fix it.
Comment 4 ionut.vancea 2017-11-19 13:24:49 UTC
(In reply to ionut.vancea from comment #3)

I played a bit more with that, and now is working.

- I removed the previous installed virtualbox-ose-5.1.28_2 and virtualbox-ose-kmod-5.1.28 but I still kept phpvirtualbox-5.1.1_1 (all three packages were installed using "pkg")
- I reinstalled from ports virtualbox-ose-5.2.0_1 and virtualbox-ose-kmod-5.2.0_1
- I changed the permissions for "vboxnectl" as mentioned in handbook: https://www.freebsd.org/doc/handbook/virtualization-host-virtualbox.html

and now it works.

phpvirtualbox is still giving a warning that is not compatible with virtualbox 5.2 but I don't see any problem right now.
Comment 5 MacGyver 2017-12-01 15:46:37 UTC
Sorry if I'm a little impatient but 11.0 is now officially EoL'ed, yet this problem still persists with the pkg installed virtualbox-ose-kmod on an 11.1-RELEASE system?
Comment 6 ionut.vancea 2017-12-01 15:50:58 UTC
(In reply to MacGyver from comment #5)

as mentioned in comment #3 I was running 11.1. More exactly, is: 11.1-RELEASE-p4
Comment 7 MacGyver 2017-12-01 21:51:55 UTC
(In reply to ionut.vancea from comment #6)

Yes, I too built it from ports on one of my boxes which then worked, but the issue is specifically with the pkg version.  I could be wrong but believe the pkg version simply needs to be re-compiled on an 11.1 system as Kamil originally requested so those of us wanting to only use pkg can do so.

I recognize one is stuck with the default config options when using a binary pkg instead of the port, but this does not appear to be the situation here... it's been some time since I first used the port to install it but I don't recall deviating from any default config options.
Comment 8 Robroy Gregg 2017-12-03 21:56:44 UTC
I have the same problem; 'just commenting so y'all will know others are seeing this.  Kamil, thanks for filing the bug!