Bug 222052 - [new port] devel/fuzzylite: Fuzzy logic control library in C++
Summary: [new port] devel/fuzzylite: Fuzzy logic control library in C++
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks: 221885
  Show dependency treegraph
 
Reported: 2017-09-04 15:40 UTC by Piotr Kubaj
Modified: 2017-11-18 16:42 UTC (History)
2 users (show)

See Also:


Attachments
shar (6.25 KB, text/plain)
2017-09-04 15:40 UTC, Piotr Kubaj
no flags Details
shar (6.24 KB, text/plain)
2017-10-02 12:38 UTC, Piotr Kubaj
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2017-09-04 15:40:43 UTC
Created attachment 186064 [details]
shar

This is a port for fuzzylite: fuzzy logic control library in C++.

It's necessary for the new port of games/vcmi.

Builds fine with both 10.3 on Poudriere and 11.1.

Portlint says "looks fine".
Comment 1 Greg V 2017-09-28 20:19:51 UTC
USES=execinfo → /usr/ports/Mk/Uses/execinfo.mk does not exist. Otherwise, works on 12-CURRENT.
Comment 2 Piotr Kubaj freebsd_committer 2017-10-02 12:38:06 UTC
Created attachment 186861 [details]
shar

(In reply to Greg V from comment #1)
Yes, the problem is that execinfo USES was removed.
The updated shar is attached.
Comment 3 Yuri Victorovich freebsd_committer 2017-11-03 08:18:08 UTC
Thank you for your submission.

The following changes are needed:
* Remove the 'Created by' line: they are being phased out
* Rename PORTVERSION -> DISTVERSION
* USES should have cmake:outsource instead of just cmake, this is the new default now
* No need to set WRKSRC. Set CMAKE_SOURCE_PATH instead.
* pkg-descr is missing WWW: (it should be set to https://www.fuzzylite.com)

The bug with varargs errors/warnings should be reported to the upstream.
Comment 4 commit-hook freebsd_committer 2017-11-18 16:41:35 UTC
A commit references this bug:

Author: yuri
Date: Sat Nov 18 16:41:07 UTC 2017
New revision: 454447
URL: https://svnweb.freebsd.org/changeset/ports/454447

Log:
  New port: devel/fuzzylite: Fuzzy logic control library in C++

  PR:		222052
  Submitted by:	Piotr Kubaj <pkubaj@anongoth.pl>
  Approved by:	tcberner (mentor)
  Differential Revision:	https://reviews.freebsd.org/D13142

Changes:
  head/devel/Makefile
  head/devel/fuzzylite/
  head/devel/fuzzylite/Makefile
  head/devel/fuzzylite/distinfo
  head/devel/fuzzylite/files/
  head/devel/fuzzylite/files/patch-fuzzylite_CMakeLists.txt
  head/devel/fuzzylite/pkg-descr
  head/devel/fuzzylite/pkg-plist
Comment 5 Yuri Victorovich freebsd_committer 2017-11-18 16:42:00 UTC
Committed with modifications.