Bug 222067 - [PATCH] www/nginx: fix for fastdfs module
Summary: [PATCH] www/nginx: fix for fastdfs module
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jochen Neumeister
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-09-05 13:28 UTC by Daniel Ylitalo
Modified: 2017-10-17 07:20 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (joneum)


Attachments
Config fix for fastdfs module (2.93 KB, patch)
2017-09-05 13:28 UTC, Daniel Ylitalo
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Ylitalo 2017-09-05 13:28:08 UTC
Created attachment 186078 [details]
Config fix for fastdfs module

As of ftp/fastdfs 5.0.11 nginx wont start by default if the fastdfs module is loaded.

Provided patch sorts that out by adding the missing params to the mod_fastdfs.conf file.

While patching mod_fastdfs.conf i also changed the storage paths to match the ftp/fastdfs port
Comment 1 Jochen Neumeister freebsd_committer 2017-09-05 18:17:03 UTC
Hey Daniel,

thanks for the PR. I will have a look! :-)

jochen
Comment 2 Jochen Neumeister freebsd_committer 2017-09-18 18:24:56 UTC
Hi Daniel,

what was the problem for the patch? Was there an error when starting ftp / fastdfs 5.0.11? You are currently the only person to report this
Comment 3 Daniel Ylitalo 2017-09-18 19:17:39 UTC
Probably not that many using the fastdfs module to nginx other than me :)

The problem is that nginx workers will crash if you load the fastdfs module with the default sample config as of fastdfs 5.0.11.

The patch fixes the sample config so nginx will start with the installed sample-default values.

The problem is that these 2 variables are added to fastdfs 5.0.11 which are missing from the sample config.

http.default_content_type = application/octet-stream
http.mime_types_filename=/usr/local/etc/nginx/mime.types

When added with the patch nginx will start fine again.
Comment 4 commit-hook freebsd_committer 2017-10-14 12:33:09 UTC
A commit references this bug:

Author: joneum
Date: Sat Oct 14 12:32:17 UTC 2017
New revision: 452061
URL: https://svnweb.freebsd.org/changeset/ports/452061

Log:
  - www/nginx: fix for fastdfs module
  - As of ftp/fastdfs 5.0.11 nginx wont start by default if the fastdfs module is loaded.
    Provided patch sorts that out by adding the missing params to the mod_fastdfs.conf file.
    While patching mod_fastdfs.conf i also changed the storage paths to match the ftp/fastds port

  PR:		222067
  Reported by:	Daniel Ylitalo <daniel@blodan.se>
  Approved by:	miwi (mentor)
  MFH:		2017Q4
  Differential Revision:	https://reviews.freebsd.org/D12246

Changes:
  head/www/nginx/Makefile
  head/www/nginx/files/extra-patch-fastdfs-src-mod_fastdfs.conf
Comment 5 commit-hook freebsd_committer 2017-10-17 07:20:26 UTC
A commit references this bug:

Author: joneum
Date: Tue Oct 17 07:19:45 UTC 2017
New revision: 452269
URL: https://svnweb.freebsd.org/changeset/ports/452269

Log:
  MFH: r452061

  - www/nginx: fix for fastdfs module
  - As of ftp/fastdfs 5.0.11 nginx wont start by default if the fastdfs module is loaded.
    Provided patch sorts that out by adding the missing params to the mod_fastdfs.conf file.
    While patching mod_fastdfs.conf i also changed the storage paths to match the ftp/fastds port

  PR:		222067
  Reported by:	Daniel Ylitalo <daniel@blodan.se>
  Approved by:	miwi (mentor)
  Differential Revision:	https://reviews.freebsd.org/D12246

  Approved by:	ports-secteam (swills)

Changes:
_U  branches/2017Q4/
  branches/2017Q4/www/nginx/Makefile
  branches/2017Q4/www/nginx/files/extra-patch-fastdfs-src-mod_fastdfs.conf