Bug 222091 - editors/vanubi: mark DEPRECATED and set EXPIRATION_DATE
Summary: editors/vanubi: mark DEPRECATED and set EXPIRATION_DATE
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Carlos J. Puga Medina
URL:
Keywords:
Depends on:
Blocks: 221941
  Show dependency treegraph
 
Reported: 2017-09-06 00:58 UTC by Carlos J. Puga Medina
Modified: 2017-09-06 11:22 UTC (History)
0 users

See Also:


Attachments
patch (396 bytes, patch)
2017-09-06 00:58 UTC, Carlos J. Puga Medina
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos J. Puga Medina freebsd_committer 2017-09-06 00:58:22 UTC
Created attachment 186102 [details]
patch

- Mark deprecated and set to expire at 2017-10-06

Vanubi is no longer actively maintained. Today after talking to the lead developer, Luca Bruno, he is not maintaining vanubi anymore - it was a nice project until Atom and Visual Studio Code came around.

Furthermore, vanubi fails to build with upcoming vala update to 0.36 and then must be mark as BROKEN.
Comment 1 commit-hook freebsd_committer 2017-09-06 11:21:35 UTC
A commit references this bug:

Author: cpm
Date: Wed Sep  6 11:21:07 UTC 2017
New revision: 449337
URL: https://svnweb.freebsd.org/changeset/ports/449337

Log:
  - Mark DEPRECATED and set to expire at 2017-10-06

  Vanubi is no longer actively maintained. Today after talking to the lead developer,
  Luca Bruno, he is not maintaining vanubi anymore - it was a nice project until Atom
  and Visual Studio Code came around.

  PR:		222091
  Submitted by:	cpm

Changes:
  head/editors/vanubi/Makefile