Bug 222104 - devel/jsoncpp: jsoncpp.pc.in changed in 1.8.1 and the REINPLACE_CMD needs to catch up
Summary: devel/jsoncpp: jsoncpp.pc.in changed in 1.8.1 and the REINPLACE_CMD needs to ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Po-Chuan Hsieh
URL:
Keywords:
: 222422 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-06 15:48 UTC by John Hein
Modified: 2017-11-26 20:45 UTC (History)
4 users (show)

See Also:
yuri: maintainer-feedback+


Attachments
[patch] catch up to .pc.in change (859 bytes, patch)
2017-09-06 15:48 UTC, John Hein
yuri: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Hein 2017-09-06 15:48:09 UTC
Created attachment 186121 [details]
[patch] catch up to .pc.in change

The 1.8.1 update regressed the jsoncpp.pc file:

% pkgconf --cflags jsoncpp
-I@CMAKE_INSTALL_FULL_INCLUDEDIR@

The jsoncpp.pc.in file was changed to add _FULL for some reason.
Comment 1 Yuri Victorovich freebsd_committer 2017-09-06 19:41:45 UTC
Comment on attachment 186121 [details]
[patch] catch up to .pc.in change

Thanks!
Comment 2 John Hein 2017-09-14 01:30:28 UTC
(In reply to Yuri Victorovich from comment #1)
Try setting 'maintainer-approval' for the patch attachment to '+'.  I'm not sure that setting 'maintainer-feedback' to '+' on the main page for the bug helps to get it committed.
Comment 3 Yuri Victorovich freebsd_committer 2017-09-14 02:00:17 UTC
(In reply to John Hein from comment #2)

It doesn't work for me on attachment.
Comment 4 John Hein 2017-09-14 16:11:41 UTC
Comment on attachment 186121 [details]
[patch] catch up to .pc.in change

Yuri,
Do you have more details about how "it didn't work".

I set 'maintainer-approval' on the patch to '?'.  Maybe you can't change it to '+' unless it's set to '?'.
Comment 5 Yuri Victorovich freebsd_committer 2017-09-14 16:16:41 UTC
(In reply to John Hein from comment #4)

> Maybe you can't change it to '+' unless it's set to '?'.

Looks like this is exactly the case.
Comment 6 Johan Ström 2017-10-03 06:42:08 UTC
+1 here, having the same issue, breaking anything which depends on jsoncpp (in my case, stuff not in ports).

Patch looks good.
Comment 7 Mikael Urankar freebsd_committer 2017-10-03 07:52:30 UTC
*** Bug 222422 has been marked as a duplicate of this bug. ***
Comment 8 commit-hook freebsd_committer 2017-10-04 10:57:37 UTC
A commit references this bug:

Author: sunpoet
Date: Wed Oct  4 10:56:17 UTC 2017
New revision: 451212
URL: https://svnweb.freebsd.org/changeset/ports/451212

Log:
  Fix jsoncpp.pc

  - Bump PORTREVISION for package change

  PR:		222104
  Submitted by:	John Hein <z7dr6ut7gs@snkmail.com>
  Approved by:	Yuri Victorovich <yuri@rawbw.com> (maintainer)

Changes:
  head/devel/jsoncpp/Makefile
Comment 9 Po-Chuan Hsieh freebsd_committer 2017-10-04 11:23:39 UTC
Committed. Thanks!
Comment 10 vali gholami 2017-11-26 20:45:45 UTC
MARKED AS SPAM