Bug 222362 - devel/zookeeper Should not force Java 7
Summary: devel/zookeeper Should not force Java 7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steven Kreuzer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-16 04:18 UTC by ari
Modified: 2017-09-22 13:28 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (skreuzer)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ari 2017-09-16 04:18:18 UTC
The Makefile forces us to use Java 7 which is now EOL. It also forces openjdk for no reason. Instead just make java 7 a minimum version.


--- zookeeper.orig/Makefile	2017-09-01 02:06:36.000000000 +1000
+++ zookeeper/Makefile	2017-09-16 14:12:51.968291000 +1000
@@ -2,7 +2,7 @@

 PORTNAME=	zookeeper
 PORTVERSION=	3.4.10
-PORTREVISION=	1
+PORTREVISION=	2
 CATEGORIES=	devel java
 MASTER_SITES=	APACHE/${PORTNAME}/current

@@ -43,8 +43,7 @@
 NO_BUILD=	yes
 NO_ARCH=	yes
 USE_JAVA=	yes
-JAVA_VERSION=	1.7
-JAVA_VENDOR=	openjdk
+JAVA_VERSION=	1.7+
 JAVA_RUN=	yes
 USE_RC_SUBR=	zookeeper
Comment 1 ari 2017-09-16 04:19:53 UTC
I've tested this by building in poudriere on 11.1 and running it in production.
Comment 2 Steven Kreuzer freebsd_committer 2017-09-22 13:28:53 UTC
Thanks for the report. I committed those changes
Comment 3 commit-hook freebsd_committer 2017-09-22 13:28:57 UTC
A commit references this bug:

Author: skreuzer
Date: Fri Sep 22 13:28:29 UTC 2017
New revision: 450372
URL: https://svnweb.freebsd.org/changeset/ports/450372

Log:
  Set JAVA_VERSION to 1.7+
  Remove JAVA_VENDOR

  PR:		222362
  Submitted by:	ari@ish.com.au

Changes:
  head/devel/zookeeper/Makefile