Bug 222381 - print/harfbuzz-icu libharfbuzz-icu.so is not getting installed
Summary: print/harfbuzz-icu libharfbuzz-icu.so is not getting installed
Status: Closed DUPLICATE of bug 219008
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-17 05:35 UTC by Zane C. Bowers-Hadley
Modified: 2018-02-13 01:15 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
harfbuzz-icu buildlog (120.27 KB, text/plain)
2017-09-17 05:35 UTC, Zane C. Bowers-Hadley
no flags Details
libreoffice buildlog (126.46 KB, text/plain)
2017-09-17 05:36 UTC, Zane C. Bowers-Hadley
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zane C. Bowers-Hadley 2017-09-17 05:35:27 UTC
Created attachment 186446 [details]
harfbuzz-icu buildlog

libharfbuzz-icu.so never seems to be getting installed by this port.

I've included the build log for libreoffice as well as harfbuzz-icu.
Comment 1 Zane C. Bowers-Hadley 2017-09-17 05:36:15 UTC
Created attachment 186447 [details]
libreoffice buildlog
Comment 2 Zane C. Bowers-Hadley 2017-09-17 05:53:27 UTC
On top of that, even with the port installed the currently installed version of libreoffice does not work... or anything else that requires harfbuzz-icu.


Libreoffice errors with this...
Shared object "libharfbuzz-icu.so.0" not found, required by "libvcllo.so"

For anything that wants it, I need to do this...
ln -s /usr/local/lib/compat/pkg/libharfbuzz-icu.so.0.10400.7 /usr/local/lib/libharfbuzz-icu.so.0
Comment 3 Zane C. Bowers-Hadley 2017-09-20 06:24:06 UTC
Submitted 222466 for print/harfbuzz to unsplit this all.
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-02-12 19:00:20 UTC
Is this still relevant?
Comment 5 Jan Beich freebsd_committer 2018-02-13 01:15:27 UTC

*** This bug has been marked as a duplicate of bug 219008 ***