Bug 222466 - print/harfbuzz unsplit ICU support
Summary: print/harfbuzz unsplit ICU support
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-20 06:22 UTC by Zane C. Bowers-Hadley
Modified: 2017-11-05 09:44 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)
jbeich: maintainer-feedback? (office)


Attachments
print/harfbuzz.diff (2.15 KB, patch)
2017-09-20 06:22 UTC, Zane C. Bowers-Hadley
no flags Details | Diff
editors/libreoffice dependency update (417 bytes, patch)
2017-09-20 06:26 UTC, Zane C. Bowers-Hadley
no flags Details | Diff
update LIB_DEPENDS for various ports (3.55 KB, patch)
2017-09-20 06:34 UTC, Zane C. Bowers-Hadley
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zane C. Bowers-Hadley 2017-09-20 06:22:31 UTC
Created attachment 186560 [details]
print/harfbuzz.diff

Splitting it has just broken Libreoffice and other things depending on ICU support.

I've been unable to get print/harfbuzz-icu to play nice at all. Merging this all back in is just easier.
Comment 1 Zane C. Bowers-Hadley 2017-09-20 06:26:01 UTC
Created attachment 186562 [details]
editors/libreoffice dependency update
Comment 2 Zane C. Bowers-Hadley 2017-09-20 06:34:29 UTC
Created attachment 186563 [details]
update LIB_DEPENDS for various ports

Fix depend list for the following ports that used attempted to used the broken ICU cutout and could not build because of it...


editors/libreoffice
www/webkit2-gtk3
print/tex-xetex
print/texlive-base
www/chromium
www/webkit-gtk2
www/webkit-gtk3
www/webkit2-gtk3
Comment 3 Jack 2017-10-30 22:21:48 UTC
Any news on when we can get this port fixed?
Comment 4 Jan Beich freebsd_committer 2017-11-01 03:36:54 UTC
(In reply to Zane C. Bowers-Hadley from comment #0)
> Splitting it has just broken Libreoffice and other things depending on ICU support.

Can you elaborate? What exactly has regressed? Maybe take a screenshot like in bug 215393. If this is not about runtime provide a full build log including make.conf contents, environment variables defined, FreeBSD version/architecture, list of installed packages and their versions, etc.

I don't use LibreOffice but maybe its maintainer can help confirm the regression.

(In reply to xxjack12xx from comment #3)
> Any news on when we can get this port fixed?

It's not yet clear *why* the change is required.
Comment 5 Vladimir Kondratyev freebsd_committer 2017-11-01 10:59:54 UTC
(In reply to Jan Beich from comment #4)
Probably, author has been hit by harfbuzz-icu PLIST issue reported in PR/219008 https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=219008
Comment 6 Vladimir Kondratyev freebsd_committer 2017-11-01 11:08:44 UTC
joining harfbuzz and harfbuzz-icu again would result in gtk->icu dependence and would hurt all light-weight gtk-based DE/WMs like xfce
Comment 7 Zane C. Bowers-Hadley 2017-11-02 02:15:11 UTC
I really don't see this as hurting XFCE.

The problem boils down to splitting this and the gnome maintainers completely fucking half assing maintaining print/harfbuzz-icu, even though there were more than a few complaints about this breaking building libreoffice, firefox, and the like.
Comment 8 Jan Beich freebsd_committer 2017-11-02 04:28:26 UTC
(In reply to Vladimir Kondratyev from comment #5)
> Probably, author has been hit by harfbuzz-icu PLIST issue reported in PR/219008

Thanks for the pointer. After looking at the proposed fix there it was easy to reproduce. I've fixed at least one similar issue with relative paths in ports makefiles years ago.

(In reply to Zane C. Bowers-Hadley from comment #7)
Does your rationale still hold after bug 219008 was fixed?
Comment 9 Vladimir Kondratyev freebsd_committer 2017-11-02 09:43:05 UTC
(In reply to Zane C. Bowers-Hadley from comment #7)
> I really don't see this as hurting XFCE.

icu is a huge library written in C++. Compiling it alone and compiling whole xfce requires similar amount of time. I submitted original PR with icu split after I had tried to build xfce on netbook powered by Intel atom CPU and found that I can speed up this long process by a factor of 2

We have similar issue with clang/llvm in base system
Comment 10 Zane C. Bowers-Hadley 2017-11-05 09:44:23 UTC
Sorry about being so slow to double check.

Aye! It appears it has finally been fixed, so my quick fix for this is no longer needed.

I've successfully built both and have tested both firefox and libreoffice. Stuff builds fine and runs fine now.

Going a head and just closing this.