Bug 222496 - sysutils/vm-bhyve patch for verbose boot and proper vm_dir treatment
Summary: sysutils/vm-bhyve patch for verbose boot and proper vm_dir treatment
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
: 223428 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-21 17:04 UTC by Dmitry Morozovsky
Modified: 2017-12-23 10:41 UTC (History)
2 users (show)

See Also:
marck: maintainer-feedback-


Attachments
lib/vm-{util,zfs} patches (2.27 KB, patch)
2017-09-21 17:04 UTC, Dmitry Morozovsky
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Morozovsky freebsd_committer 2017-09-21 17:04:59 UTC
Created attachment 186596 [details]
lib/vm-{util,zfs} patches

There are at least two useful fixes in the development tree, one of them fixes non-working vm with verbose FreeBSD boot.

here they are, while there's no fresh vm-bhyve release
Comment 1 Dmitry Morozovsky freebsd_committer 2017-12-18 14:09:25 UTC
*** Bug 223428 has been marked as a duplicate of this bug. ***
Comment 2 commit-hook freebsd_committer 2017-12-23 09:59:46 UTC
A commit references this bug:

Author: marck
Date: Sat Dec 23 09:58:55 UTC 2017
New revision: 457036
URL: https://svnweb.freebsd.org/changeset/ports/457036

Log:
  Merge 2 useful diffs from the dev tree:

  - compatibility with verbose boot
  - proper treatment for undefined vm_dir

  PR:		222496
  Approved by:	maintainer-timeout (since 20170921)

Changes:
  head/sysutils/vm-bhyve/Makefile
  head/sysutils/vm-bhyve/files/
  head/sysutils/vm-bhyve/files/patch-lib_vm-util
  head/sysutils/vm-bhyve/files/patch-lib_vm-zfs
Comment 3 Dmitry Morozovsky freebsd_committer 2017-12-23 10:41:53 UTC
Committed after maintainer timeout