Bug 222581 - lang/lua53: Add bug fix patches, change in maintainership
Summary: lang/lua53: Add bug fix patches, change in maintainership
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Thomas Zander
URL:
Keywords: needs-qa, patch
Depends on:
Blocks:
 
Reported: 2017-09-25 04:59 UTC by Russell Haley
Modified: 2017-12-02 10:18 UTC (History)
1 user (show)

See Also:
riggs: merge-quarterly+


Attachments
Port Patch - lang/lua53. Three new patches, port maintainer change. (4.46 KB, patch)
2017-09-25 04:59 UTC, Russell Haley
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Russell Haley 2017-09-25 04:59:29 UTC
Created attachment 186688 [details]
Port Patch - lang/lua53. Three new patches, port maintainer change.

The Lua team maintains a list of bugs found in each release of Lua since 4.0 [1] with examples that show the bug and a patch when the fix is available.

This patch includes three patches to the files ldebug.c, lgc.c and lparser.c. See https://www.lua.org/bugs.html for details on the patches. 

As discussed with the maintainer, this issue is also a request to take maintainership of the lua53 port. I have been an avid user of lua for two years now and I am active on their mailing list. I use FreeBSD as my daily driver at home and build fbsd and lua for arm.

I have the following future goals for the port:

1) Become more familiar with the current port makefile in the hopes of cleaning it up with the communities help.
2) Currently the upstream freebsd target fails on all FreeBSD instances I have tried (some of the reason for port makefile bloat imho). I would like to work with PUC-Rio (maintainer) to bring this in line. 
3) Create a high quality port for the next release of Lua.
Comment 1 Bugzilla Automation freebsd_committer 2017-09-25 04:59:29 UTC
Maintainer informed via mail
Comment 2 Thomas Zander freebsd_committer 2017-11-11 12:41:05 UTC
Hi Russel,

thank you for the patch and for volunteering to maintain the port.
I am happy to QA the patch and commit the fixes asap.

Regarding the maintainership change, and please don't take this as an offence, I'd like to see some indication from the previous maintainer first hand that it's okay.

Since it looks like there is no Bugzila account associated with the current maintainer's e-mail address, could you contact him again and ask him to either comment on this bug report or (if he does not want to create a bugzilla account) send an email to me confirming he wants to pass on maintainership to you?
When you send a mail to him, please keep me on CC, as this would allow me to transfer maintainership to you after 2 weeks response timeout.
Comment 3 commit-hook freebsd_committer 2017-11-11 12:49:59 UTC
A commit references this bug:

Author: riggs
Date: Sat Nov 11 12:48:54 UTC 2017
New revision: 453971
URL: https://svnweb.freebsd.org/changeset/ports/453971

Log:
  Fix multiple runtime errors and crashes in lua 5.3.4

  Details
  - Import upstream patches for known runtime errors
    and crashes in lua 5.3.4
    Details, see https://www.lua.org/bugs.html
    in the section on version 5.3.4

  PR:		222581
  Submitted by:	russ.haley@gmail.com
  Approved by:	maintainer timeout
  MFH:		2017Q4

Changes:
  head/lang/lua53/Makefile
  head/lang/lua53/files/patch-src__ldebug.c
  head/lang/lua53/files/patch-src__lgc.c
  head/lang/lua53/files/patch-src__lparser.c
Comment 4 commit-hook freebsd_committer 2017-11-11 18:09:43 UTC
A commit references this bug:

Author: riggs
Date: Sat Nov 11 18:08:45 UTC 2017
New revision: 453985
URL: https://svnweb.freebsd.org/changeset/ports/453985

Log:
  MFH: r453971

  Fix multiple runtime errors and crashes in lua 5.3.4

  Details
  - Import upstream patches for known runtime errors
    and crashes in lua 5.3.4
    Details, see https://www.lua.org/bugs.html
    in the section on version 5.3.4

  PR:		222581
  Submitted by:	russ.haley@gmail.com
  Approved by:	maintainer timeout

  Approved by:	ports-secteam (swills)

Changes:
_U  branches/2017Q4/
  branches/2017Q4/lang/lua53/Makefile
  branches/2017Q4/lang/lua53/files/patch-src__ldebug.c
  branches/2017Q4/lang/lua53/files/patch-src__lgc.c
  branches/2017Q4/lang/lua53/files/patch-src__lparser.c
Comment 5 Russell Haley 2017-11-13 06:14:06 UTC
(In reply to Thomas Zander from comment #2)
Email sent to original maintainer with you CC'd. I think I would have been a little sad if you hadn't done something to check. :P

Russ
Comment 6 commit-hook freebsd_committer 2017-11-14 06:28:32 UTC
A commit references this bug:

Author: riggs
Date: Tue Nov 14 06:28:06 UTC 2017
New revision: 454163
URL: https://svnweb.freebsd.org/changeset/ports/454163

Log:
  New maintainer: Russell Haley <russ.haley@gmail.com>

  Details:
  - This is the second bit of the patch in PR 222581
  - Guilherme Salazar <gmesalazar@gmail.com>, the previous maintainer,
    has confirmed the transfer of maintainership via e-mail

  PR:		222581
  Submitted by:	russ.haley@gmail.com (new maintainer)
  Approved by:	gmesalazar@gmail.com (previous maintainer, via email)
  MFH:		2017Q4

Changes:
  head/lang/lua53/Makefile