Bug 222590 - hangs when rebooted KVM Guest
Summary: hangs when rebooted KVM Guest
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.1-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-virtualization (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-25 11:56 UTC by Anton
Modified: 2017-10-11 20:38 UTC (History)
1 user (show)

See Also:


Attachments
Hang screen (17.61 KB, image/png)
2017-09-25 11:56 UTC, Anton
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton 2017-09-25 11:56:24 UTC
Created attachment 186698 [details]
Hang screen

After upgrade KVM guest from releng/10.3 to releng/11.1 after every reboot guest hang with  PANIC: AP #1 (PHY# 1) failed!

If i poweroff and cold start guest working fine.

Kernel is generic.

KVM Guest start with options:
===
/usr/bin/qemu-system-x86_64 -machine accel=kvm -name guest=freebsd11-atomic,debug-threads=on -S -object secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-15-freebsd11-atomic/master-key.aes -machine pc-i440fx-2.6,accel=kvm,usb=off,vmport=off,dump-guest-core=off -cpu Broadwell,+vme,+ds,+acpi,+ss,+ht,+tm,+pbe,+dtes64,+monitor,+ds_cpl,+vmx,+est,+tm2,+xtpr,+pdcm,+osxsave,+f16c,+rdrand,+arat,+tsc_adjust,+mpx,+clflushopt,+xsaveopt,+xsavec,+xgetbv1,+pdpe1gb,+abm -m 4096 -realtime mlock=off -smp 8,sockets=8,cores=1,threads=1 -uuid fd4619b7-d990-44e6-ae61-de5fe6644618 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-15-freebsd11-atomic/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x4.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x4 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x4.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x4.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -drive file=/dev/LVM_MAIN/freebsd_11-atomic,format=raw,if=none,id=drive-virtio-disk0,cache=writeback,aio=threads -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=24,id=hostnet0,vhost=on,vhostfd=26 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:b3:1c:1c,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -spice port=5900,addr=127.0.0.1,disable-ticketing,image-compression=off,seamless-migration=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vram64_size_mb=0,vgamem_mb=16,max_outputs=1,bus=pci.0,addr=0x2 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0,bus=usb.0,port=1 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1,bus=usb.0,port=2 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -msg timestamp=on
Comment 1 Anton 2017-09-25 12:03:41 UTC
This problem is reproduced on 2 stands
Comment 2 Anton 2017-09-26 16:28:44 UTC
Build kernel without "options EARLY_AP_STARTUP"
not help.
Comment 3 Anton 2017-10-11 19:52:38 UTC
Update qemu resolve this issue
Comment 4 Eugene Grosbein freebsd_committer 2017-10-11 20:38:35 UTC
Submitter reports the problem's gone with qemu update.