Bug 222783 - graphics/geoserver Can't start geoserver with warning "Nothing to start, exiting ..."
Summary: graphics/geoserver Can't start geoserver with warning "Nothing to start, exit...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Muhammad Moinur Rahman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-04 17:59 UTC by David Wahlund
Modified: 2020-06-06 10:13 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (bofh)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Wahlund 2017-10-04 17:59:30 UTC
Geoserver: 2.11.2
Freebsd: 10.3-RELEASE-p21

Calling 'service geoserver start'

In /var/log/geoserver_error.log:
Usage: java -jar start.jar [options] [properties] [configs]
       java -jar start.jar --help  # for more information

In /var/log/geoserver_error.log:
WARNING: Nothing to start, exiting ...

Calling start.jar with debug flag (--debug) outputs:
jetty.home=/usr/local/geoserver
jetty.base=/usr/local/geoserver
Parsing collected arguments
parse("--debug", "<command-line>", true)
Registering all modules
getPaths('modules/*.mod')
Using relative path pattern: glob:**/modules/*.mod
Building Module Graph
Expanding Libs
Expanding Modules
StartArgs: StartArgs [enabledModules=[], xmlRefs=[], properties=org.eclipse.jetty.start.Props@baf30c, jvmArgs=[]]
Loaded 0 URLs into URLClassLoader
WARNING: Nothing to start, exiting ...
java.lang.ClassNotFoundException: org.eclipse.jetty.xml.XmlConfiguration
        at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        at org.eclipse.jetty.start.Main.invokeMain(Main.java:299)
        at org.eclipse.jetty.start.Main.start(Main.java:817)
        at org.eclipse.jetty.start.Main.main(Main.java:112)

I noticed that the start.ini-file is missing from /usr/local/geoserver after install. Not sure if that's intended or not.
Comment 1 Muhammad Moinur Rahman freebsd_committer 2018-01-06 17:52:20 UTC
Updated Geoserver. Can you please try to reproduce?
Comment 2 David Wahlund 2018-01-12 09:26:20 UTC
(In reply to Muhammad Moinur Rahman from comment #1)
running 'service geoserver start' after update

In error log:
WARNING: Cannot enable requested module [webapp]: not a valid module name.
WARNING: Cannot enable requested module [server]: not a valid module name.
WARNING: Cannot enable requested module [resources]: not a valid module name.
WARNING: Cannot enable requested module [http]: not a valid module name.
WARNING: Cannot enable requested module [deploy]: not a valid module name.

Usage: java -jar start.jar [options] [properties] [configs]
       java -jar start.jar --help  # for more information
Comment 3 David Wahlund 2018-01-12 13:43:17 UTC
(In reply to David Wahlund from comment #2)
There's no modules directory in /usr/local/geoserver

Copying it from the workdir fixes this problem, now I just get: 
'WARNING: Module not found [ssl]'

but it works.
Comment 4 David Wahlund 2018-06-07 12:55:44 UTC
This is still broken.

I still need to manually copy start.ini and the modules dir for it to run.
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-11-16 13:36:29 UTC
Last Release: http://geoserver.org/release/2.14.0/
Comment 6 Walter Schwarzenfeld freebsd_triage 2019-08-16 01:13:39 UTC
We have now version 2.15.1. Is this still relevant?
Comment 7 David Wahlund 2019-08-16 08:18:25 UTC
(In reply to Walter Schwarzenfeld from comment #6)
Yes. The problem is with the port not the version. You still need to manually copy start.ini and modules/ from the work dir of the port. The pkg is also broken because of this since there's files missing that's required for it to start.

There's also new errors because a few config files in geoserver/etc/ are only samples. They need do be renamed for it to start. There's 12 of them so it's a bit dedious.

It's probably just a simple update to the port for it to copy and rename the files. I'm lacking the time/knowledge though.
Comment 8 David Wahlund 2019-12-14 21:23:23 UTC
So this is still a very broken port. This does not start after install. Nor does the packages. Can someone PLEASE at least remove the part of the Makefile that renames all xml-files to xml.sample. That's just terrible. Spent a few days now trying to make this work after reinstall. 

Just please test this after install and make the port work. It's so broken...
Comment 9 Muhammad Moinur Rahman freebsd_committer 2019-12-14 21:44:56 UTC
Fixing @sample but can you please confirm where should I put start.ini? In ETCDIR or PREFIX/geoserver/ ?
Comment 10 commit-hook freebsd_committer 2019-12-15 21:43:58 UTC
A commit references this bug:

Author: bofh
Date: Sun Dec 15 21:43:31 UTC 2019
New revision: 520201
URL: https://svnweb.freebsd.org/changeset/ports/520201

Log:
  graphics/geoserver: Update version 2.15.1=>2.16.1

  - Fix geoserver start [1]

  PR:		222783 [1]
  Reported by:	david@dafnet.se [1]

Changes:
  head/graphics/geoserver/Makefile
  head/graphics/geoserver/distinfo
  head/graphics/geoserver/pkg-plist