Bug 222790 - [PATCH]: comms/telldus-core devd-rule & misc cleanup
Summary: [PATCH]: comms/telldus-core devd-rule & misc cleanup
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: patch
: 198019 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-05 07:37 UTC by Johan Ström
Modified: 2017-11-01 07:56 UTC (History)
2 users (show)

See Also:
johan: maintainer-feedback+


Attachments
telldus-core devd fixes (14.04 KB, patch)
2017-10-05 07:37 UTC, Johan Ström
no flags Details | Diff
testport output (51.97 KB, text/plain)
2017-10-05 07:37 UTC, Johan Ström
no flags Details
telldus-core devd fixes, including Tellstick Duo (14.65 KB, patch)
2017-10-31 20:34 UTC, Johan Ström
johan: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Johan Ström 2017-10-05 07:37:02 UTC
Created attachment 186916 [details]
telldus-core devd fixes

Update devd rules as per hps@ recommendations in mail.

General cleanup to use avoid @preunexec etc, and use @sample for /var/telldus/tellstick-core.conf (which is not really a conf but a state file for telldusd).


This superseeds 198019 which contained same/similar devd patch, which was never applied but lost somewhere along the way of other changes. That contained iconv stuff too, which does not seem to be required any longer (after https://github.com/freebsd/freebsd-ports/commit/ff176a3eb176ed56a19a9ec55117606d2c0c34a4)
Comment 1 Johan Ström 2017-10-05 07:37:33 UTC
Created attachment 186917 [details]
testport output
Comment 2 Johan Ström 2017-10-05 07:41:38 UTC
*** Bug 198019 has been marked as a duplicate of this bug. ***
Comment 3 Hans Petter Selasky freebsd_committer 2017-10-05 07:55:47 UTC
Looks good to me.
Comment 4 Johan Ström 2017-10-05 07:59:51 UTC
FYI: most changed patch files are due to running "make makepatch", it's only the devd file which actually changed.
Comment 5 Hans Petter Selasky freebsd_committer 2017-10-31 14:17:45 UTC
Hi,

I see we need to duplicate the rules for the USB device auto plug:

ugen0.3: <Telldus TellStick Duo> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON (90mA)

  bLength = 0x0012 
  bDescriptorType = 0x0001 
  bcdUSB = 0x0200 
  bDeviceClass = 0x0000  <Probed by interface class>
  bDeviceSubClass = 0x0000 
  bDeviceProtocol = 0x0000 
  bMaxPacketSize0 = 0x0008 
  idVendor = 0x1781 
  idProduct = 0x0c31 
^^^ we also need to match this connect and disconnect event

  bcdDevice = 0x0600 
  iManufacturer = 0x0001  <Telldus>
  iProduct = 0x0002  <TellStick Duo>
  iSerialNumber = 0x0003  <XXXXXXXXXXXXXXXXXXXXXXX>
  bNumConfigurations = 0x0001 

Can you update the patch?

--HPS
Comment 6 Johan Ström 2017-10-31 20:34:30 UTC
Created attachment 187625 [details]
telldus-core devd fixes, including Tellstick Duo

Updated patch to include vid/pid for Tellstick Duo. Note that I have no duo to test with.

Only difference from previous patch is added devd rules to already existing file.
Comment 7 Hans Petter Selasky freebsd_committer 2017-11-01 07:46:31 UTC
Fixed some @CMAKE_INSTALL_PREFIX@ in the devd configuration file before commit.
Comment 8 commit-hook freebsd_committer 2017-11-01 07:56:25 UTC
A commit references this bug:

Author: hselasky
Date: Wed Nov  1 07:55:35 UTC 2017
New revision: 453267
URL: https://svnweb.freebsd.org/changeset/ports/453267

Log:
  Update devd rules and various build cleanup.
  Added support for Tellstick Duo.

  Approved by:	maintainer (Johan Strom, johan@stromnet.se)
  Tested by:	hselasky @
  PR:		222790

Changes:
  head/comms/telldus-core/Makefile
  head/comms/telldus-core/files/patch-CMakeLists.txt
  head/comms/telldus-core/files/patch-common-Socket_unix.cpp
  head/comms/telldus-core/files/patch-service-SettingsConfuse.cpp
  head/comms/telldus-core/files/patch-tdadmin-freebsd-devd-tellstick.conf
  head/comms/telldus-core/files/pkg-message.in
  head/comms/telldus-core/pkg-message
  head/comms/telldus-core/pkg-plist