Bug 222792 - devel/pijul: Fix Poudriere build
Summary: devel/pijul: Fix Poudriere build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Carlo Strub
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-10-05 12:42 UTC by Tobias Kortkamp
Modified: 2017-10-22 08:50 UTC (History)
1 user (show)

See Also:
cs: maintainer-feedback+


Attachments
pijul.diff (25.45 KB, patch)
2017-10-05 12:42 UTC, Tobias Kortkamp
tobik: maintainer-approval? (cs)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2017-10-05 12:42:07 UTC
Created attachment 186920 [details]
pijul.diff

Currently Pijul doesn't build in Poudriere at all since it fetches
dependencies during the build (see the error message below).  This is
exactly the sort of thing the cargo macro is supposed to prevent.

CARGO_CONFIGURE=no should only be set if the port has all crate
dependencies in the tarball already or has no dependencies at all.
This is clearly not the case here.

INSTALL_TARGET is not used by cargo.mk.

Use CARGO_CRATES to list all dependent crates.  `make cargo-crates`
will conveniently generate this list for you from
${WRKSRC}/Cargo.lock.

Building the backtrace-sys crate requires USES=gmake.

Note that we have to set DISTFILES=${DISTNAME}${EXTRACT_SUFX}
explicitly for now because of a bug in cargo.mk.  It currently
ignores/overrides the default DISTFILES when CARGO_CRATES is set which
means pijule-0.8.0.tar.gz is not being fetched/extracted properly without
it.

===>  Building for pijul-0.8.0                                                                                        
    Updating registry `https://github.com/rust-lang/crates.io-index`                                                  
warning: spurious network error (2 tries remaining): [12/-1] curl error: Could not resolve host: github.com           

warning: spurious network error (1 tries remaining): [12/-1] curl error: Could not resolve host: github.com

error: failed to fetch `https://github.com/rust-lang/crates.io-index`

Caused by:
  [12/-1] curl error: Could not resolve host: github.com

*** Error code 101
Comment 1 Carlo Strub freebsd_committer 2017-10-05 18:37:14 UTC
Thank you very much Tobias!
Comment 2 commit-hook freebsd_committer 2017-10-05 18:57:04 UTC
A commit references this bug:

Author: cs
Date: Thu Oct  5 18:56:33 UTC 2017
New revision: 451334
URL: https://svnweb.freebsd.org/changeset/ports/451334

Log:
  Fix build

  PR:		222792
  Submitted by:	tobik@
  Approved by:	maintainer
  MFH:		2017Q4

Changes:
  head/devel/pijul/Makefile
  head/devel/pijul/distinfo
Comment 3 commit-hook freebsd_committer 2017-10-22 08:50:24 UTC
A commit references this bug:

Author: antoine
Date: Sun Oct 22 08:49:47 UTC 2017
New revision: 452625
URL: https://svnweb.freebsd.org/changeset/ports/452625

Log:
  MFH: r451334

  Fix build

  PR:		222792
  Submitted by:	tobik@
  Approved by:	maintainer

Changes:
_U  branches/2017Q4/
  branches/2017Q4/devel/pijul/Makefile
  branches/2017Q4/devel/pijul/distinfo