Bug 222814 - www/apache24: Update to 2.4.29
Summary: www/apache24: Update to 2.4.29
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Bernard Spil
URL:
Keywords: needs-qa, patch
Depends on:
Blocks:
 
Reported: 2017-10-06 07:54 UTC by Bernard Spil
Modified: 2017-11-01 07:46 UTC (History)
4 users (show)

See Also:
ohauer: maintainer-feedback+


Attachments
svn diff for www/apache24 (16.18 KB, patch)
2017-10-06 07:54 UTC, Bernard Spil
no flags Details | Diff
svn diff for www/apache24 (19.06 KB, patch)
2017-10-23 06:59 UTC, Bernard Spil
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2017-10-06 07:54:37 UTC
Created attachment 186940 [details]
svn diff for www/apache24

```
www/apache24: Update to 2.4.28

 - Remove patch for CVE-2017-9798 (included upstream)
 - Remove mod_ssl LibreSSL patches (included upstream)

PR: 
```
Comment 1 Bernard Spil freebsd_committer 2017-10-23 06:59:01 UTC
Created attachment 187386 [details]
svn diff for www/apache24

Update patch for 2.4.29

```
www/apache24: Update to 2.4.29

 - Remove patch for CVE-2017-9798 (included upstream)
 - Remove mod_ssl LibreSSL patches (included upstream)
 - Fix SSL stapling patch for LibreSSL
 - mod_http2 no longer experimental

PR: 222814
```
Comment 2 Olli Hauer freebsd_committer 2017-10-23 11:44:43 UTC
Hi Bernhard,

build is OK on 10.3-amd64 (I haven't tested other releases at the moment).
I've rolled the new release on 15 systems including some subversion and load balancer and don't any issues in this short time.

Please go on and commit with HAT @apache (since you are a member)

Thanks!
Comment 3 commit-hook freebsd_committer 2017-10-23 18:50:27 UTC
A commit references this bug:

Author: brnrd
Date: Mon Oct 23 18:49:28 UTC 2017
New revision: 452732
URL: https://svnweb.freebsd.org/changeset/ports/452732

Log:
  www/apache24: Update to 2.4.29

   - Remove patch for CVE-2017-9798 (included upstream)
   - Remove mod_ssl LibreSSL patches (included upstream)
   - Fix SSL stapling patch for LibreSSL
   - mod_http2 no longer experimental

  PR:		222814
  With hat:	apache

Changes:
  head/www/apache24/Makefile
  head/www/apache24/Makefile.modules
  head/www/apache24/Makefile.options.desc
  head/www/apache24/distinfo
  head/www/apache24/files/patch-CVE-2017-9798
  head/www/apache24/files/patch-configure.in
  head/www/apache24/files/patch-modules_ssl_mod__ssl.c
  head/www/apache24/files/patch-modules_ssl_ssl__engine__init.c
  head/www/apache24/files/patch-modules_ssl_ssl__engine__io.c
  head/www/apache24/files/patch-modules_ssl_ssl__engine__kernel.c
  head/www/apache24/files/patch-modules_ssl_ssl__engine__vars.c
  head/www/apache24/files/patch-modules_ssl_ssl__private.h
  head/www/apache24/files/patch-modules_ssl_ssl__util.c
  head/www/apache24/files/patch-modules_ssl_ssl__util__ssl.h
  head/www/apache24/files/patch-modules_ssl_ssl__util__stapling.c
Comment 4 Ben RUBSON 2017-10-31 18:17:37 UTC
Hi,
Do you know why the binary package is not available through pkg(8) ?
Do you plan to release it ?
Thank you very much for your support !
Ben
Comment 5 Bernard Spil freebsd_committer 2017-11-01 07:46:09 UTC
(In reply to Ben RUBSON from comment #4)
The package will become available with the next poudriere run on the FreeBSD cluster. As this was not a security release, this won't happen for the quarterly branch.