Bug 222825 - databases/mariadb102-server, databases/mariadb102-client: fix build of dependent ports with mysql=102m
Summary: databases/mariadb102-server, databases/mariadb102-client: fix build of depend...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Bernard Spil
URL:
Keywords:
Depends on:
Blocks: 221242 222965 223053
  Show dependency treegraph
 
Reported: 2017-10-06 11:33 UTC by Piotr Kubaj
Modified: 2018-01-15 08:09 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (brnrd)
koobs: merge-quarterly?


Attachments
client patch (1.30 KB, patch)
2017-10-06 11:33 UTC, Piotr Kubaj
ultima: maintainer-approval+
Details | Diff
server patch (1.23 KB, patch)
2017-10-06 11:34 UTC, Piotr Kubaj
ultima: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2017-10-06 11:33:43 UTC
Created attachment 186949 [details]
client patch

Upgrade of MariaDB to 10.2.9 made some ports fail to build.

Those patches fix that.

The ports build fine on Poudriere with 10.3-RELEASE. I also build successfully p5-DBD-mysql, which failed before.
Comment 1 Piotr Kubaj freebsd_committer 2017-10-06 11:34:06 UTC
Created attachment 186950 [details]
server patch
Comment 2 Richard Gallamore freebsd_committer 2017-10-14 04:15:33 UTC
Comment on attachment 186950 [details]
server patch

Tested both the patches and everything looks good to me.
Comment 3 commit-hook freebsd_committer 2017-10-15 13:20:35 UTC
A commit references this bug:

Author: brnrd
Date: Sun Oct 15 13:19:35 UTC 2017
New revision: 452143
URL: https://svnweb.freebsd.org/changeset/ports/452143

Log:
  databases/mariadb102-server: Fix client ports and build

   - Move client headers to the client port [1]
   - Fix SNAPPY option for mariabackup [2]
     * switch to noninja to generate link.txt

  PR:		222825 [1], 221159 [2]
  Submitted by:	Piotr Kubaj <pkubaj@anongoth.pl> [1]
  Reported by:	sdalu@sdalu.com [2]

Changes:
  head/databases/mariadb102-client/pkg-plist
  head/databases/mariadb102-server/Makefile
  head/databases/mariadb102-server/pkg-plist
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2017-10-16 07:34:40 UTC
*** Bug 222965 has been marked as a duplicate of this bug. ***
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2017-10-16 07:38:10 UTC
What is required for this issue to be confirmed/closed?
Comment 6 Piotr Kubaj freebsd_committer 2017-10-16 07:59:45 UTC
It's already patched and fine, thanks.
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2017-10-17 02:41:30 UTC
Client ports are still affected in quarterly (see bug 223053)
Comment 8 ari 2018-01-08 23:39:03 UTC
This is still not fixed for me against trunk of the ports tree and ports like zabbix34-server.
Comment 9 commit-hook freebsd_committer 2018-01-14 21:54:20 UTC
A commit references this bug:

Author: brnrd
Date: Sun Jan 14 21:54:00 UTC 2018
New revision: 459005
URL: https://svnweb.freebsd.org/changeset/ports/459005

Log:
  databases/mariadb102-server: Update to 10.2.12

   - Fix some client utility builds [1]

  PR:		222825 [1]
  Submitted by:	Piotr Kubaj [1]

Changes:
  head/databases/mariadb102-client/Makefile
  head/databases/mariadb102-client/pkg-plist
  head/databases/mariadb102-server/Makefile
  head/databases/mariadb102-server/distinfo
  head/databases/mariadb102-server/files/patch-MDEV-14337
  head/databases/mariadb102-server/pkg-plist