Bug 222920 - www/wt: Update to 3.3.8
Summary: www/wt: Update to 3.3.8
Status: Closed DUPLICATE of bug 226160
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: needs-patch, needs-qa
: 222919 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-11 02:17 UTC by Mohammad S. Babaei
Modified: 2018-03-10 20:25 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback? (info)


Attachments
upgrade patch against ports tree (68.23 KB, patch)
2017-10-11 02:19 UTC, Mohammad S. Babaei
koobs: maintainer-approval-
Details | Diff
www/wt-3.3.7_4 to 3.3.8 upgrade patch (69.83 KB, patch)
2017-10-16 17:58 UTC, Mohammad S. Babaei
info: maintainer-approval+
Details | Diff
www/wt-3.3.7_4 to 3.3.8 upgrade patch (69.77 KB, patch)
2017-10-16 18:04 UTC, Mohammad S. Babaei
info: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mohammad S. Babaei 2017-10-11 02:17:01 UTC
Fixes:

* Upgrade to 3.3.8.
* Add UNWIND menu option in order to build Wt with stacktrace support
* Fix brokens builds on Firebird as backend
* Fix build errors on the benchmark
* A few minor improvements and cleanups
* Supress portlint warnings and errors
Comment 1 Mohammad S. Babaei 2017-10-11 02:19:32 UTC
Created attachment 187068 [details]
upgrade patch against ports tree
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2017-10-11 02:24:19 UTC
*** Bug 222919 has been marked as a duplicate of this bug. ***
Comment 3 Richard Gallamore freebsd_committer 2017-10-16 03:51:37 UTC
Hello Mohammad, thank you for your contributions.

Can you please provide portlint and qa. There are many failures to create symlinks and items missing from plist as well as some warnings, can you please fix these items?

Here is a log
https://poudriere.ultimasbox.com/data/103amd64-test/2017-10-15_15h24m51s/logs/errors/wt-3.3.8.log
Comment 4 Mohammad S. Babaei 2017-10-16 06:20:57 UTC
Sure, I'll look into it and provide a new patch.
Comment 5 Mohammad S. Babaei 2017-10-16 17:58:18 UTC
Created attachment 187215 [details]
www/wt-3.3.7_4 to 3.3.8 upgrade patch

Fixes:

* Upgrade to 3.3.8
* Add optional UNWIND menu option in order to build Wt with stacktrace support
* Fix brokens builds using PostgreSQL as backend
* Fix brokens builds using Firebird as backend
* Fix brokens builds using MySQL as backend
* Fix build errors on the benchmark example
* Include benchmark example binaries if only PostgreSQL or MySQL option is selected
* Respect ${DESTDIR} whenever creating symlinks
* A few minor improvements and cleanups
* Supress portlint warnings and errors
* Add dependency on fontconfig when pango option is enabled

I ran the following tests, and it passed them all successfully:

$ portlint
$ make stage
$ make stage-qa
$ make check-plist
$ make check-orphans
$ make package
$ make install
$ make deinstall
Comment 6 Mohammad S. Babaei 2017-10-16 18:04:47 UTC
Created attachment 187216 [details]
www/wt-3.3.7_4 to 3.3.8 upgrade patch

Please ignore the previous patch. It was created in reverse order 3.3.8 to 3.3.7 which was my mistake. Here is the final patch.
Comment 7 Mohammad S. Babaei 2017-10-16 18:10:22 UTC
Please let me know if there are any other issues.
Comment 8 Richard Gallamore freebsd_committer 2017-10-16 22:44:45 UTC
Updated log file: https://poudriere.ultimasbox.com/data/103amd64-test/2017-10-16_11h37m31s/logs/errors/wt-3.3.8.log

The port is still attempting to install the symlinks but failing, looks like this is due to STAGEDIR being omitted from the target path. The port is also creating /var/run/wt during stage and not in stage directory.


I wanted to verify if this was with the new version or not and that is a negative, 3.3.7_4 is currently having the same build issues.
Comment 9 Mohammad S. Babaei 2017-10-17 12:22:11 UTC
Thank you for the feedback. Unfortunately, I don't have poudriere on my FreeBSD boxes. But, the port passes all the tests mentioned in the FreeBSD Porter's Handbook which I mentioned above.

As for the symlinks I can confirm that they exist on the system after make install inside /usr/local/lib/Wt/examples/{example-name}/resources. And, make deinstall uninstalls them.

In my estimation, it should be the same for 3.3.7_4. But, if you kindly provide the same build/test using poudriere we could be sure about that.

Additional notes: the symlinks are created by the CMake script. So, I took a look at other ports (namely, graphics/openjpeg15) with a similar patch for symlink creation inside cmake.

As for /var/run/wt the 3.3.7_4 also creates the same folder outside the stage dir. I am not sure whether I shoud treat the directories inside /var/run the same as /etc or let the port delete the them.
Comment 10 Yuri Victorovich freebsd_committer 2018-03-10 20:25:14 UTC
Update to 4.0.2 was submitted in bug#226160

*** This bug has been marked as a duplicate of bug 226160 ***