Bug 223016 - benchmarks/fio: unbreak on aarch64
Summary: benchmarks/fio: unbreak on aarch64
Status: Closed DUPLICATE of bug 228042
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Only Me
Assignee: Baptiste Daroussin
URL:
Keywords: patch, patch-ready
Depends on:
Blocks: 201763
  Show dependency treegraph
 
Reported: 2017-10-14 22:08 UTC by Jan Beich
Modified: 2018-06-21 06:32 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (bapt)


Attachments
v0 (2.30 KB, patch)
2017-10-14 22:08 UTC, Jan Beich
no flags Details | Diff
v0.1 (2.52 KB, patch)
2017-10-14 22:26 UTC, Jan Beich
jbeich: maintainer-approval? (bapt)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-10-14 22:08:42 UTC
Created attachment 187178 [details]
v0

HWCAP_CRC32 isn't supported by aarch64 yet but let's prepare in advance.

Build logs:
11.1 aarch64 - http://sprunge.us/AWKR
12.0 aarch64 - http://sprunge.us/TEQR
Comment 1 Jan Beich freebsd_committer 2017-10-14 22:21:45 UTC
Comment on attachment 187178 [details]
v0

*Sigh* crc32 is auto-disabled by configure after ports r437997.

$ make configure
[...]
march_armv8_a_crc_crypto      no
Comment 2 Jan Beich freebsd_committer 2017-10-14 22:26:52 UTC
Created attachment 187179 [details]
v0.1

Build logs:
11.1 aarch64 - http://sprunge.us/dYjZ
12.0 aarch64 - http://sprunge.us/WUJQ
Comment 3 Jan Beich freebsd_committer 2017-10-14 23:03:47 UTC
Alternatively, BROKEN_aarch64 can simply be dropped.
Comment 4 Andrew Turner freebsd_committer 2017-11-15 14:21:15 UTC
As a heads up I'm planning on allowing userspace to read the ID registers and not implement the HWCAP bits on arm64.
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2018-06-11 04:22:42 UTC
jbeich: do you agree that this has been obsoleted by 228042 ?
Comment 7 Mark Linimon freebsd_committer freebsd_triage 2018-06-21 06:26:40 UTC
Superseded by 228042.
Comment 8 Jan Beich freebsd_committer 2018-06-21 06:32:11 UTC

*** This bug has been marked as a duplicate of bug 228042 ***