Bug 223028 - [exp-run] print/indexinfo: indexinfo does not support gzipped info file
Summary: [exp-run] print/indexinfo: indexinfo does not support gzipped info file
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Baptiste Daroussin
URL:
Keywords:
: 220720 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-15 13:35 UTC by Yasuhiro KIMURA
Modified: 2017-10-24 15:16 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (bapt)
bapt: exp-run?


Attachments
indexinfo 0.3 (1.03 KB, patch)
2017-10-17 21:13 UTC, Baptiste Daroussin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro KIMURA 2017-10-15 13:35:55 UTC
editors/emacs installs all info files into ${DATADIR}/info as gzipped ones. But indexinfo does not support gzipped info file. So when package of editors/emacs is installed ${DATADIR}/info/dir is not properly created.
Comment 1 Baptiste Daroussin freebsd_committer 2017-10-17 21:13:10 UTC
Created attachment 187244 [details]
indexinfo 0.3
Comment 2 Baptiste Daroussin freebsd_committer 2017-10-17 21:14:51 UTC
This new release of indexinfo supports gzip info files via zlib.
It also incorporates some capsicum changes for the same reason.

I would like an exp-run to ensure there is no regressions introduced
Comment 3 Baptiste Daroussin freebsd_committer 2017-10-24 13:27:10 UTC
*** Bug 220720 has been marked as a duplicate of this bug. ***
Comment 4 Antoine Brodin freebsd_committer 2017-10-24 14:54:16 UTC
Exp-run looks fine.
Comment 5 commit-hook freebsd_committer 2017-10-24 15:16:27 UTC
A commit references this bug:

Author: bapt
Date: Tue Oct 24 15:15:53 UTC 2017
New revision: 452781
URL: https://svnweb.freebsd.org/changeset/ports/452781

Log:
  Update to 0.3

  - improved portability
  - add support for compressed info files (like provided by the emacs port) [1]

  PR:		223028 [1]
  Reported by:	 Yasuhiro KIMURA <yasu@utahime.org> [1]

Changes:
  head/print/indexinfo/Makefile
  head/print/indexinfo/distinfo